summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2013-09-14 05:07:04 +0000
committerJohann Schmitz <ercpe@gentoo.org>2013-09-14 05:07:04 +0000
commitbee58dcccd6f8934d02984f31a6ce97ff17b2607 (patch)
tree9a4e13fb6ae9aa56c4fe9b61e33273c7423db328 /dev-java/aspectj
parentfinal fix for bug #483318, patch taken from upstream (diff)
downloadgentoo-2-bee58dcccd6f8934d02984f31a6ce97ff17b2607.tar.gz
gentoo-2-bee58dcccd6f8934d02984f31a6ce97ff17b2607.tar.bz2
gentoo-2-bee58dcccd6f8934d02984f31a6ce97ff17b2607.zip
(Re-)added aspectj - A seamless aspect-oriented extension to java (dependency of spring framework).
The current version bundles a modified and renamed version of bcel, which makes the reason of the previous treeclean obsolete. (Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java/aspectj')
-rw-r--r--dev-java/aspectj/ChangeLog11
-rw-r--r--dev-java/aspectj/aspectj-1.7.3.ebuild44
-rw-r--r--dev-java/aspectj/metadata.xml6
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-java/aspectj/ChangeLog b/dev-java/aspectj/ChangeLog
new file mode 100644
index 000000000000..99640a759008
--- /dev/null
+++ b/dev-java/aspectj/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/aspectj
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/aspectj/ChangeLog,v 1.27 2013/09/14 05:07:04 ercpe Exp $
+
+*aspectj-1.7.3 (14 Sep 2013)
+
+ 14 Sep 2013; Johann Schmitz <ercpe@gentoo.org> +aspectj-1.7.3.ebuild,
+ +metadata.xml:
+ (Re-)added aspectj - A seamless aspect-oriented extension to java (dependency
+ of spring framework). The current version bundles a modified and renamed
+ version of bcel, which makes the reason of the previous treeclean obsolete.
diff --git a/dev-java/aspectj/aspectj-1.7.3.ebuild b/dev-java/aspectj/aspectj-1.7.3.ebuild
new file mode 100644
index 000000000000..6d3c7bf5efd9
--- /dev/null
+++ b/dev-java/aspectj/aspectj-1.7.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/aspectj/aspectj-1.7.3.ebuild,v 1.1 2013/09/14 05:07:04 ercpe Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A seamless aspect-oriented extension to the Java programming language"
+HOMEPAGE="http://eclipse.org/aspectj/"
+SRC_URI="http://www.eclipse.org/downloads/download.php?file=/tools/aspectj/aspectj-1.7.3-src.jar&r=1 -> ${P}.jar"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/asm:4
+ dev-java/commons-logging:0"
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/zip
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+S="${WORKDIR}"
+
+JAVA_SRC_DIR="${S}/src"
+JAVA_GENTOO_CLASSPATH="commons-logging,asm-4"
+
+src_unpack() {
+ default
+ unzip "${S}/aspectjweaver1.7.3-src.jar" -d "${S}/src/" || die
+}
+
+src_prepare() {
+ default
+ # needs part of BEA JRockit to compile
+ rm "${S}"/src/org/aspectj/weaver/loadtime/JRockitAgent.java || die
+ # aspectj uses a renamed version of asm:4
+ find -name "*.java" -exec sed -i -e 's/import aj.org.objectweb.asm./import org.objectweb.asm./g' {} \; || die
+}
diff --git a/dev-java/aspectj/metadata.xml b/dev-java/aspectj/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/dev-java/aspectj/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+