summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-11-08 22:53:55 +0000
committerVlastimil Babka <caster@gentoo.org>2009-11-08 22:53:55 +0000
commit2ebf4ec05ba46e7c02c6333fdf9b3c9f53660ba0 (patch)
tree5622b0231d0515a578897808bc95f2ee59d2ed79 /dev-java/c3p0/c3p0-0.9.1.2.ebuild
parentFix for 249486 - thanks to jer and Raphael Barrois (diff)
downloadgentoo-2-2ebf4ec05ba46e7c02c6333fdf9b3c9f53660ba0.tar.gz
gentoo-2-2ebf4ec05ba46e7c02c6333fdf9b3c9f53660ba0.tar.bz2
gentoo-2-2ebf4ec05ba46e7c02c6333fdf9b3c9f53660ba0.zip
Version bump. Remove dependency on 1.5 jdk - bug #292001.
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/c3p0/c3p0-0.9.1.2.ebuild')
-rw-r--r--dev-java/c3p0/c3p0-0.9.1.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-java/c3p0/c3p0-0.9.1.2.ebuild b/dev-java/c3p0/c3p0-0.9.1.2.ebuild
new file mode 100644
index 000000000000..d6d0cd472d92
--- /dev/null
+++ b/dev-java/c3p0/c3p0-0.9.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/c3p0/c3p0-0.9.1.2.ebuild,v 1.1 2009/11/08 22:53:55 caster Exp $
+
+EAPI=2
+JAVA_PKG_IUSE="doc source"
+JAVA_PKG_WANT_BOOTCLASSPATH="1.5"
+
+inherit java-pkg-2 java-ant-2
+
+SRC_P="${P}.src"
+
+JAVA_PKG_WANT_SOURCE="1.4"
+JAVA_PKG_WANT_TARGET="1.4"
+
+DESCRIPTION="Library for augmenting traditional (DriverManager-based) JDBC drivers with JNDI-bindable DataSources"
+HOMEPAGE="http://c3p0.sourceforge.net/"
+# how to package the generated sources:
+# 1) comment out the sed build.xml calls below and compile with forced sun-jdk-1.5
+# 2) go to the ${WORKDIR}
+# 3) tar -cjf c3p0-0.9.1.2-codegen.tar.bz2 c3p0-0.9.1.2.src/build/codegen/
+SRC_URI="mirror://sourceforge/${PN}/${SRC_P}.tgz
+ mirror://gentoo/c3p0-0.9.1.2-codegen.tar.bz2"
+# Does not like Java 1.6's JDBC API
+COMMON_DEPEND="dev-java/log4j"
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEPEND}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${SRC_P}"
+
+src_prepare() {
+ echo "j2ee.jar.base.dir=${JAVA_HOME}" > build.properties
+ echo "log4j.jar.file=$(java-pkg_getjar log4j log4j.jar)" >> build.properties
+
+ java-ant_rewrite-bootclasspath 1.5
+ # don't generate sources, use the pregenerated from gentoo mirrors
+ # since generator uses reflection, it's not as simple as javac bootclasspath rewrite
+ sed -i 's/depends="codegen"//' build.xml
+ sed -i 's/depends="codegen,/depends="init,/' build.xml
+}
+
+EANT_DOC_TARGET="javadocs"
+
+src_install() {
+ java-pkg_newjar build/${P}.jar
+ dodoc README-SRC
+ use doc && java-pkg_dojavadoc build/apidocs
+ use source && java-pkg_dosrc src/classes/com
+}