summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-20 15:15:25 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-20 15:15:25 +0000
commit5ac8c2cb4ace0b4709f63f8878787f8eead13cb7 (patch)
tree518a503288006d1efdd3a697cadf11188925f5ff /dev-java/commons-io
parentlibapreq2 move, bug 162120 (diff)
downloadgentoo-2-5ac8c2cb4ace0b4709f63f8878787f8eead13cb7.tar.gz
gentoo-2-5ac8c2cb4ace0b4709f63f8878787f8eead13cb7.tar.bz2
gentoo-2-5ac8c2cb4ace0b4709f63f8878787f8eead13cb7.zip
Cleanup ebuild and add unit test support.
(Portage version: 2.1.2-r1)
Diffstat (limited to 'dev-java/commons-io')
-rw-r--r--dev-java/commons-io/ChangeLog7
-rw-r--r--dev-java/commons-io/commons-io-1.2.ebuild41
-rw-r--r--dev-java/commons-io/files/digest-commons-io-1.02
3 files changed, 25 insertions, 25 deletions
diff --git a/dev-java/commons-io/ChangeLog b/dev-java/commons-io/ChangeLog
index 0d63ee2aa965..7a40c0772f98 100644
--- a/dev-java/commons-io/ChangeLog
+++ b/dev-java/commons-io/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/commons-io
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.12 2006/12/09 09:13:15 flameeyes Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.13 2007/01/20 15:15:25 betelgeuse Exp $
+
+ 20 Jan 2007; Petteri Räty <betelgeuse@gentoo.org> commons-io-1.2.ebuild:
+ Cleanup ebuild and add unit test support.
09 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> commons-io-1.2.ebuild:
Add ~x86-fbsd keyword.
diff --git a/dev-java/commons-io/commons-io-1.2.ebuild b/dev-java/commons-io/commons-io-1.2.ebuild
index 923ff02780f6..b4ef1af7635c 100644
--- a/dev-java/commons-io/commons-io-1.2.ebuild
+++ b/dev-java/commons-io/commons-io-1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/commons-io-1.2.ebuild,v 1.2 2006/12/09 09:13:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/commons-io-1.2.ebuild,v 1.3 2007/01/20 15:15:25 betelgeuse Exp $
inherit java-pkg-2 java-ant-2 eutils
@@ -12,43 +12,38 @@ SRC_URI="mirror://apache/jakarta/commons/io/source/${MY_P}.tar.gz"
LICENSE="Apache-1.1"
SLOT="1"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="doc source"
+IUSE="doc source test"
DEPEND="dev-java/ant-core
source? ( app-arch/zip )
- >=virtual/jdk-1.3"
-RDEPEND=">=virtual/jre-1.3"
+ test? ( dev-java/junit dev-java/ant-tasks )
+ >=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
S="${WORKDIR}/${MY_P}"
-# junit tests are disabled for now.
-# one of the tests (FileUtilsCleanDirectoryTestCase) always fails when run as
-# root.
-# TODO report upstream
-
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
+ rm -v *.jar
epatch ${FILESDIR}/${P}-gentoo.diff
-
- mkdir -p build/lib
- cd build/lib
-# use junit && java-pkg_jar-from junit
+ java-ant_ignore-system-classes
+ java-ant_rewrite-classpath
}
-src_compile() {
- local antflags="jar -Dlibdir=build/lib"
- use doc && antflags="${antflags} javadoc -Djavadocdir=dist/docs/api"
-# use junit && antflags="${antflags} test"
- eant ${antflags} || die "compile problem"
+# one of the tests (FileUtilsCleanDirectoryTestCase) used to always fail
+# when run as root, but I could not get this behaviour any more.
+
+src_test() {
+ eant test -Dgentoo.classpath="$(java-pkg_getjars junit)" \
+ -DJunit.present=true
}
src_install() {
java-pkg_newjar build/${P}.jar ${PN}.jar
- dodoc RELEASE-NOTES.txt NOTICE.txt
- dohtml PROPOSAL.html STATUS.html usersguide.html
- use doc && java-pkg_dohtml -r dist/docs/api
+ dodoc RELEASE-NOTES.txt NOTICE.txt || die
+ use doc && java-pkg_dojavadoc dist/docs/api
use source && java-pkg_dosrc src/java/*
}
diff --git a/dev-java/commons-io/files/digest-commons-io-1.0 b/dev-java/commons-io/files/digest-commons-io-1.0
index 704bdfd93bed..ee1509e9d395 100644
--- a/dev-java/commons-io/files/digest-commons-io-1.0
+++ b/dev-java/commons-io/files/digest-commons-io-1.0
@@ -1 +1,3 @@
MD5 4d17035d061f4ccbbd88feb049df703d commons-io-1.0-src.tar.gz 132118
+RMD160 4d14bf89b27031d6c4459ec7d18757acae5a6e34 commons-io-1.0-src.tar.gz 132118
+SHA256 8cf89ec0adda70e57e456619f296a67715503b44021d8a72643c36ce50474e10 commons-io-1.0-src.tar.gz 132118