summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 22:53:27 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 22:53:27 +0000
commit8e61063e9e5372249fc605ef2f2029641df899ca (patch)
treed0472670cedaac6ce78ec75ee9857b7fa9eff51b /dev-java/commons-io
parentMigrated to Generation 2. (diff)
downloadgentoo-2-8e61063e9e5372249fc605ef2f2029641df899ca.tar.gz
gentoo-2-8e61063e9e5372249fc605ef2f2029641df899ca.tar.bz2
gentoo-2-8e61063e9e5372249fc605ef2f2029641df899ca.zip
Migrated to Generation 2.
(Portage version: 2.1.1_pre3-r3)
Diffstat (limited to 'dev-java/commons-io')
-rw-r--r--dev-java/commons-io/ChangeLog10
-rw-r--r--dev-java/commons-io/commons-io-1.1-r1.ebuild54
-rw-r--r--dev-java/commons-io/files/digest-commons-io-1.12
-rw-r--r--dev-java/commons-io/files/digest-commons-io-1.1-r13
4 files changed, 67 insertions, 2 deletions
diff --git a/dev-java/commons-io/ChangeLog b/dev-java/commons-io/ChangeLog
index 1a53bcd0b2a6..4b3fa57b8430 100644
--- a/dev-java/commons-io/ChangeLog
+++ b/dev-java/commons-io/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-io
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.3 2005/12/04 18:38:25 nichoj Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.4 2006/07/22 22:53:27 nelchael Exp $
+
+*commons-io-1.1-r1 (22 Jul 2006)
+
+ 22 Jul 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +commons-io-1.1-r1.ebuild:
+ Migrated to Generation 2.
*commons-io-1.1 (04 Dec 2005)
diff --git a/dev-java/commons-io/commons-io-1.1-r1.ebuild b/dev-java/commons-io/commons-io-1.1-r1.ebuild
new file mode 100644
index 000000000000..d2740fc834ed
--- /dev/null
+++ b/dev-java/commons-io/commons-io-1.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/commons-io-1.1-r1.ebuild,v 1.1 2006/07/22 22:53:27 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_P="${P}-src"
+DESCRIPTION="Commons-IO contains utility classes , stream implementations, file filters , and endian classes."
+HOMEPAGE="http://jakarta.apache.org/commons/io"
+SRC_URI="mirror://apache/jakarta/commons/io/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="1"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc source"
+
+DEPEND="dev-java/ant-core
+ source? ( app-arch/zip )
+ >=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+
+S="${WORKDIR}/${MY_P}"
+
+# junit tests are disabled for now.
+# one of the tests (FileUtilsCleanDirectoryTestCase) always fails when run as
+# root.
+# TODO report upstream
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ mkdir -p build/lib
+ cd build/lib
+# use junit && java-pkg_jar-from junit
+}
+
+src_compile() {
+ local antflags="jar -Dlibdir=build/lib"
+ use doc && antflags="${antflags} javadoc -Djavadocdir=dist/docs/api"
+# use junit && antflags="${antflags} test"
+ eant ${antflags} || die "compile problem"
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt NOTICE.txt
+ dohtml PROPOSAL.html STATUS.html usersguide.html
+ use doc && java-pkg_dohtml -r dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-io/files/digest-commons-io-1.1 b/dev-java/commons-io/files/digest-commons-io-1.1
index be3229d48ab8..4d76588f0172 100644
--- a/dev-java/commons-io/files/digest-commons-io-1.1
+++ b/dev-java/commons-io/files/digest-commons-io-1.1
@@ -1 +1,3 @@
MD5 0a39b54885b86dc42169ffd761caf414 commons-io-1.1-src.tar.gz 197922
+RMD160 ad7be482ee4eebcdc193fe78497ed17394309ab1 commons-io-1.1-src.tar.gz 197922
+SHA256 375983a026c86afee9b07405a616b3614de3f844b2530d54a5f12c06a666b92c commons-io-1.1-src.tar.gz 197922
diff --git a/dev-java/commons-io/files/digest-commons-io-1.1-r1 b/dev-java/commons-io/files/digest-commons-io-1.1-r1
new file mode 100644
index 000000000000..4d76588f0172
--- /dev/null
+++ b/dev-java/commons-io/files/digest-commons-io-1.1-r1
@@ -0,0 +1,3 @@
+MD5 0a39b54885b86dc42169ffd761caf414 commons-io-1.1-src.tar.gz 197922
+RMD160 ad7be482ee4eebcdc193fe78497ed17394309ab1 commons-io-1.1-src.tar.gz 197922
+SHA256 375983a026c86afee9b07405a616b3614de3f844b2530d54a5f12c06a666b92c commons-io-1.1-src.tar.gz 197922