summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-07-23 21:00:28 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-07-23 21:00:28 +0000
commit667c710e5914682c33ddb4d8be50ac03935ee5ea (patch)
tree8fdcfdb52727e7a56fedb9d0fc37e73997e0acdb /dev-java/commons-net
parentput a hacky fix for bug #46593 while the sparc team figures out what the actu... (diff)
downloadgentoo-2-667c710e5914682c33ddb4d8be50ac03935ee5ea.tar.gz
gentoo-2-667c710e5914682c33ddb4d8be50ac03935ee5ea.tar.bz2
gentoo-2-667c710e5914682c33ddb4d8be50ac03935ee5ea.zip
use -D instead of build.properties
Diffstat (limited to 'dev-java/commons-net')
-rw-r--r--dev-java/commons-net/ChangeLog6
-rw-r--r--dev-java/commons-net/commons-net-1.1.0.ebuild5
-rw-r--r--dev-java/commons-net/commons-net-1.2.0.ebuild5
-rw-r--r--dev-java/commons-net/commons-net-1.2.2.ebuild5
4 files changed, 11 insertions, 10 deletions
diff --git a/dev-java/commons-net/ChangeLog b/dev-java/commons-net/ChangeLog
index 2397a16bab99..cd5977a34027 100644
--- a/dev-java/commons-net/ChangeLog
+++ b/dev-java/commons-net/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-net
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/ChangeLog,v 1.11 2004/07/16 20:01:29 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/ChangeLog,v 1.12 2004/07/23 21:00:28 axxo Exp $
+
+ 23 Jul 2004; Thomas Matthijs <axxo@gentoo.org> commons-net-1.1.0.ebuild,
+ commons-net-1.2.0.ebuild, commons-net-1.2.2.ebuild:
+ use -D instead of build.properties
*commons-net-1.2.2 (16 Jul 2004)
diff --git a/dev-java/commons-net/commons-net-1.1.0.ebuild b/dev-java/commons-net/commons-net-1.1.0.ebuild
index 133717c130e3..2904eeedee4d 100644
--- a/dev-java/commons-net/commons-net-1.1.0.ebuild
+++ b/dev-java/commons-net/commons-net-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.1.0.ebuild,v 1.7 2004/07/14 01:48:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.1.0.ebuild,v 1.8 2004/07/23 21:00:28 axxo Exp $
inherit eutils java-pkg
@@ -20,11 +20,10 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/gentoo.diff
- echo "oro.jar=`java-config -p oro`" >> build.properties
}
src_compile() {
- local antflags="jar -propertyfile build.properties"
+ local antflags="-Doro.jar=$(java-config -p oro) jar"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
ant ${antflags} || die "died on ant"
}
diff --git a/dev-java/commons-net/commons-net-1.2.0.ebuild b/dev-java/commons-net/commons-net-1.2.0.ebuild
index 750b236d0246..b4b01c8ee70b 100644
--- a/dev-java/commons-net/commons-net-1.2.0.ebuild
+++ b/dev-java/commons-net/commons-net-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.2.0.ebuild,v 1.2 2004/06/24 22:23:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.2.0.ebuild,v 1.3 2004/07/23 21:00:28 axxo Exp $
inherit eutils java-pkg
@@ -20,11 +20,10 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/gentoo-1.2.diff
- echo "oro.jar=`java-config -p oro`" >> build.properties
}
src_compile() {
- local antflags="jar"
+ local antflags="-Doro.jar=$(java-config -p oro) jar"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
use doc && antflags="${antflags} javadoc"
ant ${antflags} || die "died on ant"
diff --git a/dev-java/commons-net/commons-net-1.2.2.ebuild b/dev-java/commons-net/commons-net-1.2.2.ebuild
index 9381270e59e0..8e993acbc225 100644
--- a/dev-java/commons-net/commons-net-1.2.2.ebuild
+++ b/dev-java/commons-net/commons-net-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.2.2.ebuild,v 1.1 2004/07/16 20:01:29 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.2.2.ebuild,v 1.2 2004/07/23 21:00:28 axxo Exp $
inherit eutils java-pkg
@@ -20,13 +20,12 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/gentoo-1.2.diff
- echo "oro.jar=`java-config -p oro`" >> build.properties
#for some reason 1.2.2 claims its 1.3
sed "s/commons-net-1.3.0-dev/commons-net-1.2.2-dev/" -i build.xml
}
src_compile() {
- local antflags="jar"
+ local antflags="-Doro.jar=$(java-config -p oro) jar"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
use doc && antflags="${antflags} javadoc"
ant ${antflags} || die "died on ant"