summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-22 12:30:24 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-22 12:30:24 +0000
commitf7fc7c6ef72c5fb31a0b8bb6dad9836248a9393b (patch)
tree01f34d59e112cc1a59c21d603c65b041996073eb /dev-java/commons-net
parentMoved to using jakarta-commons eclass; 'doc' USE flag. Keywords ~x86. (diff)
downloadgentoo-2-f7fc7c6ef72c5fb31a0b8bb6dad9836248a9393b.tar.gz
gentoo-2-f7fc7c6ef72c5fb31a0b8bb6dad9836248a9393b.tar.bz2
gentoo-2-f7fc7c6ef72c5fb31a0b8bb6dad9836248a9393b.zip
Initial import. Keywords ~x86.
Diffstat (limited to 'dev-java/commons-net')
-rw-r--r--dev-java/commons-net/ChangeLog9
-rw-r--r--dev-java/commons-net/commons-net-1.0.0.ebuild24
-rw-r--r--dev-java/commons-net/files/digest-commons-net-1.0.01
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/commons-net/ChangeLog b/dev-java/commons-net/ChangeLog
new file mode 100644
index 000000000000..ca14545e06f1
--- /dev/null
+++ b/dev-java/commons-net/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-java/commons-net
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/ChangeLog,v 1.1 2003/03/22 12:30:24 absinthe Exp $
+
+*commons-net-1.0.0 (22 Mar 2003)
+
+ 22 Mar 2003; Dylan Carlson <absinthe@gentoo.org> commons-net-1.0.0.ebuild:
+ Initial import.
+
diff --git a/dev-java/commons-net/commons-net-1.0.0.ebuild b/dev-java/commons-net/commons-net-1.0.0.ebuild
new file mode 100644
index 000000000000..35e35023328a
--- /dev/null
+++ b/dev-java/commons-net/commons-net-1.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.0.0.ebuild,v 1.1 2003/03/22 12:30:24 absinthe Exp $
+
+inherit jakarta-commons
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
+HOMEPAGE="http://jakarta.apache.org/commons/net/index.html"
+SRC_URI="http://www.apache.org/dist/jakarta/commons/net/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes junit"
+
+src_compile() {
+ jakarta-commons_src_compile myconf make
+ jakarta-commons_src_install dojar
+ use doc && jakarta-commons_src_compile makedoc
+ use doc && jakarta-commons_src_install html
+}
diff --git a/dev-java/commons-net/files/digest-commons-net-1.0.0 b/dev-java/commons-net/files/digest-commons-net-1.0.0
new file mode 100644
index 000000000000..dff4992888f2
--- /dev/null
+++ b/dev-java/commons-net/files/digest-commons-net-1.0.0
@@ -0,0 +1 @@
+MD5 54e84a689719aa66c7564324606199a5 commons-net-1.0.0-src.tar.gz 134465