summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-08-12 18:00:41 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-08-12 18:00:41 +0000
commit1fb62c56d015e27dda5f20f17c1af98e8e019b86 (patch)
tree7dea8ef0220bc2c843c758d2723d8c9e8cfb4537 /dev-java/commons-pool
parentRemove dev-ruby/pry:0 from the ruby18 mask for now since adhearsion still dep... (diff)
downloadgentoo-2-1fb62c56d015e27dda5f20f17c1af98e8e019b86.tar.gz
gentoo-2-1fb62c56d015e27dda5f20f17c1af98e8e019b86.tar.bz2
gentoo-2-1fb62c56d015e27dda5f20f17c1af98e8e019b86.zip
Version bump to 1.6, API compatible with previous version.
(Portage version: 2.1.13.7/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/commons-pool')
-rw-r--r--dev-java/commons-pool/ChangeLog10
-rw-r--r--dev-java/commons-pool/commons-pool-1.6.ebuild40
2 files changed, 47 insertions, 3 deletions
diff --git a/dev-java/commons-pool/ChangeLog b/dev-java/commons-pool/ChangeLog
index 273f79ed27d0..f06eb1ad5402 100644
--- a/dev-java/commons-pool/ChangeLog
+++ b/dev-java/commons-pool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-pool
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.63 2011/07/17 20:30:50 halcy0n Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.64 2013/08/12 18:00:41 tomwij Exp $
+
+*commons-pool-1.6 (12 Aug 2013)
+
+ 12 Aug 2013; Tom Wijsman <TomWij@gentoo.org> +commons-pool-1.6.ebuild:
+ Version bump to 1.6, API compatible with previous version.
17 Jul 2011; Mark Loeser <halcy0n@gentoo.org> commons-pool-1.5.6.ebuild:
Stable for ppc/ppc64; bug #371811
@@ -252,4 +257,3 @@
31 Oct 2002; Karl Trygve Kalleberg <karltk@gentoo.org> commons-pool-1.0.1.ebuild files/digest-commons-pool-1.0.1 :
Initial import. Ebuild submitted by Adrian Almenar
<aalmenar@conectium.com>.
-
diff --git a/dev-java/commons-pool/commons-pool-1.6.ebuild b/dev-java/commons-pool/commons-pool-1.6.ebuild
new file mode 100644
index 000000000000..edc07a2b4cea
--- /dev/null
+++ b/dev-java/commons-pool/commons-pool-1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.6.ebuild,v 1.1 2013/08/12 18:00:41 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Provides general purpose object pooling API"
+HOMEPAGE="http://commons.apache.org/pool/"
+SRC_URI="mirror://apache/commons/pool/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5
+ test? (
+ dev-java/ant-junit
+ dev-java/junit:0
+ )"
+
+S="${WORKDIR}/${P}-src"
+
+EANT_BUILD_TARGET="build-jar"
+
+src_test() {
+ ANT_TASKS="ant-junit" eant -Dclasspath="$(java-pkg_getjars junit)" test
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}-SNAPSHOT.jar
+ dodoc README.txt RELEASE-NOTES.txt
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/org
+}