summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2005-11-26 13:36:10 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2005-11-26 13:36:10 +0000
commitb2b8a84bb4dc00e17eaf5e9197d2edac50be0f43 (patch)
tree137dec5cc5f085f347ff034418fe135559db553a /dev-java/commons-validator
parentChange to init script for bug #86560 (diff)
downloadgentoo-2-b2b8a84bb4dc00e17eaf5e9197d2edac50be0f43.tar.gz
gentoo-2-b2b8a84bb4dc00e17eaf5e9197d2edac50be0f43.tar.bz2
gentoo-2-b2b8a84bb4dc00e17eaf5e9197d2edac50be0f43.zip
Version bump. Corrected license to Apache-2.0, removed unneeded dependency on xerces and the installation of LICENSE.txt.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-java/commons-validator')
-rw-r--r--dev-java/commons-validator/ChangeLog9
-rw-r--r--dev-java/commons-validator/Manifest20
-rw-r--r--dev-java/commons-validator/commons-validator-1.1.4.ebuild78
-rw-r--r--dev-java/commons-validator/files/digest-commons-validator-1.1.3-r12
-rw-r--r--dev-java/commons-validator/files/digest-commons-validator-1.1.42
5 files changed, 95 insertions, 16 deletions
diff --git a/dev-java/commons-validator/ChangeLog b/dev-java/commons-validator/ChangeLog
index 757d1662f94e..c04959d5781e 100644
--- a/dev-java/commons-validator/ChangeLog
+++ b/dev-java/commons-validator/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/commons-validator
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/ChangeLog,v 1.27 2005/07/10 15:02:29 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/ChangeLog,v 1.28 2005/11/26 13:36:10 betelgeuse Exp $
+
+*commons-validator-1.1.4 (26 Nov 2005)
+
+ 26 Nov 2005; Petteri Räty <betelgeuse@gentoo.org>
+ +commons-validator-1.1.4.ebuild:
+ Version bump. Corrected license to Apache-2.0, removed unneeded dependency
+ on xerces and the installation of LICENSE.txt.
10 Jul 2005; Thomas Matthijs <axxo@gentoo.org>
commons-validator-1.0.2-r5.ebuild, commons-validator-1.1.3-r1.ebuild:
diff --git a/dev-java/commons-validator/Manifest b/dev-java/commons-validator/Manifest
index 5d04af134a75..f1d5d279d2e8 100644
--- a/dev-java/commons-validator/Manifest
+++ b/dev-java/commons-validator/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 a3fe367b34eb395fd5312c3c43452acd commons-validator-1.1.3-r1.ebuild 2254
+MD5 fe50de87c4317acb45ad1ce3f8582576 ChangeLog 4857
MD5 4cc22229724efca697eac432dcf08198 commons-validator-1.0.2-r5.ebuild 2121
-MD5 cd91bd95a00ffdbb39e205b8ec0fbc56 ChangeLog 4602
-MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 a3fe367b34eb395fd5312c3c43452acd commons-validator-1.1.3-r1.ebuild 2254
+MD5 faabe3504d658512904af72fec52f75b commons-validator-1.1.4.ebuild 2350
MD5 3b4d11c72fe5990ec6689406240d3ef6 files/digest-commons-validator-1.0.2-r5 78
-MD5 b4056d324a1cc96ca13a9f0c3e7c68fc files/digest-commons-validator-1.1.3-r1 173
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC0Tii/rLF9B432nYRAlr/AKCmQUGnC4bkUfRX/eZRc8OiWhKWAACeIdhL
-b0i6I1zUkB29XIDanO6jQMA=
-=MFQm
------END PGP SIGNATURE-----
+MD5 28c22d3ce7df384daed2a3ae19cc93ec files/digest-commons-validator-1.1.3-r1 173
+MD5 1ed459aabc6a07d81e4d3ac0679f5eea files/digest-commons-validator-1.1.4 173
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
diff --git a/dev-java/commons-validator/commons-validator-1.1.4.ebuild b/dev-java/commons-validator/commons-validator-1.1.4.ebuild
new file mode 100644
index 000000000000..3d95df10127b
--- /dev/null
+++ b/dev-java/commons-validator/commons-validator-1.1.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/commons-validator-1.1.4.ebuild,v 1.1 2005/11/26 13:36:10 betelgeuse Exp $
+
+inherit java-pkg
+
+MY_P=${P}-src
+DESCRIPTION="Jakarta component to validate user input, or data input"
+HOMEPAGE="http://jakarta.apache.org/commons/validator/"
+SRC_URI="mirror://apache/jakarta/commons/validator/source/${MY_P}.tar.gz
+ mirror://gentoo/${P}-gentoo-missingfiles.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc examples jikes source"
+
+# Was not able to test on 1.3 jdk at this point. Feel free to to lower this
+# back to 1.3 if you have tested it on one and proved working. Then you
+# probably need to bring the xerces dependency back.
+
+RDEPEND=">=virtual/jre-1.4
+ =dev-java/jakarta-oro-2.0*
+ >=dev-java/commons-digester-1.5
+ >=dev-java/commons-collections-3.1
+ >=dev-java/commons-logging-1.0.3
+ =dev-java/commons-beanutils-1.6*"
+
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-1.4
+ ${RDEPEND}
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm *.jar
+ #dirty hack
+ sed -e 's:target name="compile" depends="static":target name="compile" depends="prepare":' -i build.xml \
+ || die "Failed to sed build.xml"
+
+ echo "oro.jar=$(java-pkg_getjars jakarta-oro-2.0)" >> build.properties
+ echo "commons-digester.jar=$(java-pkg_getjars commons-digester)" >> build.properties
+ echo "commons-beanutils.jar=$(java-pkg_getjars commons-beanutils-1.6)" >> build.properties
+}
+
+src_compile() {
+ local antflags="compile"
+
+ # Because the build.xml file uses <pathelement location="">
+ # we can only have only have one jar per property
+ antflags="${antflags} -Dcommons-logging.jar=$(java-pkg_getjar commons-logging commons-logging.jar)"
+ antflags="${antflags} -Dcommons-collections.jar=$(java-pkg_getjars commons-collections)"
+
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+
+ ant ${antflags} || die "build failed"
+ jar -cf ${PN}.jar -C target/classes/ . || die "could not create jar"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ if use doc; then
+ java-pkg_dohtml -r dist/docs/
+ java-pkg_dohtml PROPOSAL.html STATUS.html
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r src/example/* ${D}/usr/share/doc/${PF}/examples
+ fi
+
+ use source && java-pkg_dosrc src/share/*
+}
diff --git a/dev-java/commons-validator/files/digest-commons-validator-1.1.3-r1 b/dev-java/commons-validator/files/digest-commons-validator-1.1.3-r1
index 14da3e258aa4..2fbee17342ee 100644
--- a/dev-java/commons-validator/files/digest-commons-validator-1.1.3-r1
+++ b/dev-java/commons-validator/files/digest-commons-validator-1.1.3-r1
@@ -1,2 +1,2 @@
-MD5 a24f8612138427019269af37148b590d commons-validator-1.1.3-src.tar.gz 180203
MD5 9c19c398966e4aac3783deb06cba41d6 commons-validator-1.1.3-gentoo-missingfiles.tar.bz2 4161
+MD5 a24f8612138427019269af37148b590d commons-validator-1.1.3-src.tar.gz 180203
diff --git a/dev-java/commons-validator/files/digest-commons-validator-1.1.4 b/dev-java/commons-validator/files/digest-commons-validator-1.1.4
new file mode 100644
index 000000000000..2e6415ae09aa
--- /dev/null
+++ b/dev-java/commons-validator/files/digest-commons-validator-1.1.4
@@ -0,0 +1,2 @@
+MD5 62aa855c6c61dce1e5e3e94f0dbb911f commons-validator-1.1.4-gentoo-missingfiles.tar.bz2 4161
+MD5 6a4ef07da77dd86223e80870999448e8 commons-validator-1.1.4-src.tar.gz 181446