summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2007-05-08 11:14:00 +0000
committerAlistair Bush <ali_bush@gentoo.org>2007-05-08 11:14:00 +0000
commitb047166172aa69296a4cd49108585a955fc915b9 (patch)
tree56a00ad028c6d0bc08b639cba7deb4856f9e6722 /dev-java/fop
parentMask doc use flag for fop as unable to build documentation. (diff)
downloadgentoo-2-b047166172aa69296a4cd49108585a955fc915b9.tar.gz
gentoo-2-b047166172aa69296a4cd49108585a955fc915b9.tar.bz2
gentoo-2-b047166172aa69296a4cd49108585a955fc915b9.zip
Fixed out of memory build issues on amd64 see #177585
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-java/fop')
-rw-r--r--dev-java/fop/fop-0.93.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-java/fop/fop-0.93.ebuild b/dev-java/fop/fop-0.93.ebuild
index b5136ca70e21..049195ecb56b 100644
--- a/dev-java/fop/fop-0.93.ebuild
+++ b/dev-java/fop/fop-0.93.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fop/fop-0.93.ebuild,v 1.1 2007/05/07 10:22:18 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fop/fop-0.93.ebuild,v 1.2 2007/05/08 11:14:00 ali_bush Exp $
# TODO: hyphenation support doesn't seem to be built correctly, because there's no xml in hyph dir
# but upstream binary distro contains only fop.jar, no hyph nor sandbox
@@ -37,6 +37,7 @@ RDEPEND=">=virtual/jre-1.4
${COMMON_DEPEND}"
DEPEND=">=virtual/jdk-1.4
+ =dev-java/eclipse-ecj-3.2*
${COMMON_DEPEND}"
# test? (
# =dev-java/junit-3.8*
@@ -74,6 +75,8 @@ src_compile() {
use jai && af="${af} -Djai.present=true"
use jimi && af="${af} -Djimi.present=true"
+ ANT_OPTS="-Xmx256M"
+ java-pkg_force-compiler ecj-3.2
eant ${af} package $(use_doc javadocs)
}