summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-27 14:18:30 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-27 14:18:30 +0000
commit7241cb013cff066f35a9574a545e604408202a74 (patch)
tree999a86300918fe9ea6dad302f84fa0efd48a2a82 /dev-java/gnu-classpath
parentRemoval (bug #501432). (diff)
downloadgentoo-2-7241cb013cff066f35a9574a545e604408202a74.tar.gz
gentoo-2-7241cb013cff066f35a9574a545e604408202a74.tar.bz2
gentoo-2-7241cb013cff066f35a9574a545e604408202a74.zip
Make gnu-classpath support freetype 2.5.3; fixes bug #504944, reported and patch contributed by darkbasic.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/gnu-classpath')
-rw-r--r--dev-java/gnu-classpath/ChangeLog10
-rw-r--r--dev-java/gnu-classpath/files/gnu-classpath-0.98-r3-freetype-2.5.3-support.patch32
-rw-r--r--dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild8
3 files changed, 46 insertions, 4 deletions
diff --git a/dev-java/gnu-classpath/ChangeLog b/dev-java/gnu-classpath/ChangeLog
index 4b9cab4b2592..77045a68f0fa 100644
--- a/dev-java/gnu-classpath/ChangeLog
+++ b/dev-java/gnu-classpath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/gnu-classpath
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/ChangeLog,v 1.119 2013/03/02 19:55:16 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/ChangeLog,v 1.120 2014/04/27 14:18:30 tomwij Exp $
+
+ 27 Apr 2014; Tom Wijsman <TomWij@gentoo.org>
+ +files/gnu-classpath-0.98-r3-freetype-2.5.3-support.patch,
+ gnu-classpath-0.98-r3.ebuild, metadata.xml:
+ Make gnu-classpath support freetype 2.5.3; fixes bug #504944, reported and
+ patch contributed by darkbasic.
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org>
gnu-classpath-0.98-r3.ebuild:
diff --git a/dev-java/gnu-classpath/files/gnu-classpath-0.98-r3-freetype-2.5.3-support.patch b/dev-java/gnu-classpath/files/gnu-classpath-0.98-r3-freetype-2.5.3-support.patch
new file mode 100644
index 000000000000..42828e2a4b8f
--- /dev/null
+++ b/dev-java/gnu-classpath/files/gnu-classpath-0.98-r3-freetype-2.5.3-support.patch
@@ -0,0 +1,32 @@
+--- ./native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c.orig 2014-03-18 10:35:50.904133661 +0100
++++ ./native/jni/gtk-peer/gnu_java_awt_peer_gtk_FreetypeGlyphVector.c 2014-03-18 10:37:03.808131298 +0100
+@@ -42,8 +42,9 @@
+ #include <pango/pango.h>
+ #include <pango/pangoft2.h>
+ #include <pango/pangofc-font.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
++#include <ft2build.h>
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
+ #include "jcl.h"
+ #include "gdkfont.h"
+ #include "gnu_java_awt_peer_gtk_FreetypeGlyphVector.h"
+--- ./native/jni/gtk-peer/gnu_java_awt_peer_gtk_GdkFontPeer.c.orig 2014-03-18 10:37:12.048131031 +0100
++++ ./native/jni/gtk-peer/gnu_java_awt_peer_gtk_GdkFontPeer.c 2014-03-18 10:37:58.416129528 +0100
+@@ -39,10 +39,11 @@
+ #include <pango/pango.h>
+ #include <pango/pangoft2.h>
+ #include <pango/pangofc-font.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/fttypes.h>
+-#include <freetype/tttables.h>
++#include <ft2build.h>
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
++#include FT_TYPES_H
++#include FT_TRUETYPE_TABLES_H
+ #include "gdkfont.h"
+ #include "gtkpeer.h"
+ #include "gnu_java_awt_peer_gtk_GdkFontPeer.h" \ No newline at end of file
diff --git a/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild b/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild
index da37e3e2b6b0..2b39f00d3d01 100644
--- a/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild
+++ b/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild,v 1.9 2013/03/02 19:55:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.98-r3.ebuild,v 1.10 2014/04/27 14:18:30 tomwij Exp $
EAPI=4
@@ -63,6 +63,10 @@ RDEPEND=">=virtual/jre-1.5
S=${WORKDIR}/${MY_P}
+java_prepare() {
+ epatch "${FILESDIR}"/${PF}-freetype-2.5.3-support.patch
+}
+
src_configure() {
# We require ecj anyway, so force it to avoid problems with bad versions of javac
export JAVAC="${EPREFIX}/usr/bin/ecj"