summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-10-01 07:34:45 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-10-01 07:34:45 +0000
commit7b115ba56447a19780b0286a00df62f54bd692a0 (patch)
treefc333dd81697709e2356bd4af49bbd3d18446525 /dev-java/ibm-jre-bin
parentlockfile fix; hardened fix; syscall updates; minor fixes; cleanup (diff)
downloadgentoo-2-7b115ba56447a19780b0286a00df62f54bd692a0.tar.gz
gentoo-2-7b115ba56447a19780b0286a00df62f54bd692a0.tar.bz2
gentoo-2-7b115ba56447a19780b0286a00df62f54bd692a0.zip
Restrict fetch
(Portage version: 2.0.52-r1 all-the-cool-kids-are-doing-it)
Diffstat (limited to 'dev-java/ibm-jre-bin')
-rw-r--r--dev-java/ibm-jre-bin/ChangeLog6
-rw-r--r--dev-java/ibm-jre-bin/files/digest-ibm-jre-bin-1.4.1-r13
-rw-r--r--dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild67
-rw-r--r--dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild19
4 files changed, 20 insertions, 75 deletions
diff --git a/dev-java/ibm-jre-bin/ChangeLog b/dev-java/ibm-jre-bin/ChangeLog
index 2dc0a5a71845..d40715d77a02 100644
--- a/dev-java/ibm-jre-bin/ChangeLog
+++ b/dev-java/ibm-jre-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/ibm-jre-bin
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ChangeLog,v 1.19 2005/09/02 12:26:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ChangeLog,v 1.20 2005/10/01 07:34:45 axxo Exp $
+
+ 01 Oct 2005; Thomas Matthijs <axxo@gentoo.org>
+ -ibm-jre-bin-1.4.1-r1.ebuild, ibm-jre-bin-1.4.2.ebuild:
+ Restrict fetch
02 Sep 2005; Diego Pettenò <flameeyes@gentoo.org>
ibm-jre-bin-1.4.1-r1.ebuild, ibm-jre-bin-1.4.2.ebuild:
diff --git a/dev-java/ibm-jre-bin/files/digest-ibm-jre-bin-1.4.1-r1 b/dev-java/ibm-jre-bin/files/digest-ibm-jre-bin-1.4.1-r1
deleted file mode 100644
index d201a56b8fc6..000000000000
--- a/dev-java/ibm-jre-bin/files/digest-ibm-jre-bin-1.4.1-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 111805b43cc14fc2a7746da1b4fd02b8 IBMJava2-JRE-141.ppc.tgz 37508675
-MD5 b6680a76871727813f36cd87aa33d9ea IBMJava2-JRE-141.tgz 35198414
-MD5 789616d74351dc480a362508efc779d3 IBMJava2-JRE-141.ppc64.tgz 35602823
diff --git a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild b/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild
deleted file mode 100644
index aa0af7c13ab8..000000000000
--- a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.1-r1.ebuild,v 1.18 2005/09/02 12:26:21 flameeyes Exp $
-
-inherit java
-
-S="${WORKDIR}/j2sdk${PV}"
-DESCRIPTION="IBM Java Development Kit ${PV}"
-HOMEPAGE="http://www-106.ibm.com/developerworks/java/jdk/"
-SRC_URI="ppc? ( mirror://gentoo/IBMJava2-JRE-141.ppc.tgz )
- ppc64? ( mirror://gentoo/IBMJava2-JRE-141.ppc64.tgz )
- x86? ( mirror://gentoo/IBMJava2-JRE-141.tgz )"
-PROVIDE="virtual/jre"
-IUSE="browserplugin mozilla"
-SLOT="1.4"
-LICENSE="IBM-J1.4"
-KEYWORDS="ppc ~x86 ppc64 -*"
-DEPEND="virtual/libc
- >=dev-java/java-config-0.2.5"
-RDEPEND=""
-
-if use ppc; then
- S=${WORKDIR}/IBMJava2-ppc-141
-elif use ppc64; then
- S=${WORKDIR}/IBMJava2-ppc64-141
-else
- S=${WORKDIR}/IBMJava2-141
-fi;
-
-src_compile() {
- einfo "${PF} is a binary package, no compilation required"
-}
-
-src_install() {
- # Copy all the files to the designated directory
- dodir /opt/${P}
- cp -pR ${S}/jre/* ${D}/opt/${P}/
-
- dohtml -a html,htm,HTML -r docs
- dodoc ${S}/docs/COPYRIGHT
-
- dodir /etc/env.d/java
- sed \
- -e "s/@P@/${P}/g" \
- -e "s/@PV@/${PV}/g" \
- -e "s/@PF@/${PF}/g" \
- < ${FILESDIR}/${P} \
- > ${D}/etc/env.d/java/20${P} \
- || die "unable to install environment file"
-
- if use browserplugin || use mozilla; then
- local plugin="libjavaplugin_oji.so"
- if has_version '>=sys-devel/gcc-3' ; then
- plugin="libjavaplugin_ojigcc3.so"
- fi
- install_mozilla_plugin /opt/${P}/bin/${plugin}
- fi
-
-}
-
-pkg_postinst() {
- if ! use browserplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'browserplugin' please update your USE"
- fi
-}
diff --git a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild b/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild
index c02ba1436186..b7c6f208def1 100644
--- a/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild
+++ b/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild
@@ -1,20 +1,22 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild,v 1.12 2005/09/02 12:26:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jre-bin/ibm-jre-bin-1.4.2.ebuild,v 1.13 2005/10/01 07:34:45 axxo Exp $
inherit java
S="${WORKDIR}/j2sdk${PV}"
DESCRIPTION="IBM Java Development Kit ${PV}"
HOMEPAGE="http://www-106.ibm.com/developerworks/java/jdk/"
-SRC_URI="ppc? ( mirror://gentoo/IBMJava2-JRE-142.ppc.tgz )
- ppc64? ( mirror://gentoo/IBMJava2-JRE-142.ppc64.tgz )
- x86? ( mirror://gentoo/IBMJava2-JRE-142.tgz )"
+SRC_URI="ppc? ( IBMJava2-JRE-142.ppc.tgz )
+ ppc64? ( IBMJava2-JRE-142.ppc64.tgz )
+ x86? ( IBMJava2-JRE-142.tgz )"
PROVIDE="virtual/jre"
IUSE="browserplugin mozilla"
SLOT="1.4"
LICENSE="IBM-J1.4"
KEYWORDS="ppc ~x86 ppc64 -*"
+RESTRICT=fetch
+
DEPEND="virtual/libc
>=dev-java/java-config-0.2.5"
RDEPEND=""
@@ -27,6 +29,15 @@ else
S=${WORKDIR}/IBMJava2-142
fi;
+pkg_nofetch() {
+ einfo "Due to license restrictions, we cannot redistribute or fetch the distfiles"
+ einfo "Please visit: ${HOMEPAGE}"
+ einfo "Download: ${A}"
+ einfo "Place the file in: ${DISTDIR}"
+ einfo "Rerun emerge"
+}
+
+
src_compile() {
einfo "${PF} is a binary package, no compilation required"
}