summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-03-06 21:35:48 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-03-06 21:35:48 +0000
commit28de62adbf56e73d699b2f764207bedafae3a0e1 (patch)
tree63f18ecb1abdbdc405586ae7cba16f06fb4e535a /dev-java/jal/jal-20031117.ebuild
parentAdd new ebuild for khacc-1.7.8, see Bug# 38825. (diff)
downloadgentoo-2-28de62adbf56e73d699b2f764207bedafae3a0e1.tar.gz
gentoo-2-28de62adbf56e73d699b2f764207bedafae3a0e1.tar.bz2
gentoo-2-28de62adbf56e73d699b2f764207bedafae3a0e1.zip
Initial Import. Closes #34103
Diffstat (limited to 'dev-java/jal/jal-20031117.ebuild')
-rw-r--r--dev-java/jal/jal-20031117.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-java/jal/jal-20031117.ebuild b/dev-java/jal/jal-20031117.ebuild
new file mode 100644
index 000000000000..dd02e8f768aa
--- /dev/null
+++ b/dev-java/jal/jal-20031117.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jal/jal-20031117.ebuild,v 1.1 2004/03/06 21:35:48 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Jal is a partial port of the STL by the C++ Standard Template Library."
+SRC_URI="http://vigna.dsi.unimi.it/jal/${P}-bin.tar.gz"
+HOMEPAGE="http://vigna.dsi.unimi.it/jal/"
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+RDEPEND=">=virtual/jdk-1.4
+ >=dev-java/fastutil-3.1"
+
+src_compile () { :; }
+
+src_install() {
+ mv ${P}.jar ${PN}.jar
+ java-pkg_dojar ${PN}.jar
+ use doc && dohtml -r docs/*
+}
+