summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-09-20 04:24:37 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-09-20 04:24:37 +0000
commitfb280871df72b59e550887afe4f86bed7028dfd9 (patch)
tree913b0089bf653821f443be22bfd51fc0ec8f726e /dev-java/java-config
parentStable x86; and here I thought we were done with stable markings for modular X (diff)
downloadgentoo-2-fb280871df72b59e550887afe4f86bed7028dfd9.tar.gz
gentoo-2-fb280871df72b59e550887afe4f86bed7028dfd9.tar.bz2
gentoo-2-fb280871df72b59e550887afe4f86bed7028dfd9.zip
Version bump. The java-nsplugin eselect module now handles multilib stuff properly. Slightly better error messages for when a tool isn\'t available on a particular platform/jdk. Pruned old revisions.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-java/java-config')
-rw-r--r--dev-java/java-config/ChangeLog10
-rw-r--r--dev-java/java-config/files/digest-java-config-2.0.293
-rw-r--r--dev-java/java-config/java-config-2.0.29.ebuild61
3 files changed, 73 insertions, 1 deletions
diff --git a/dev-java/java-config/ChangeLog b/dev-java/java-config/ChangeLog
index 1131e1be7001..88aabbef68d3 100644
--- a/dev-java/java-config/ChangeLog
+++ b/dev-java/java-config/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/java-config
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.119 2006/09/14 18:32:13 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.120 2006/09/20 04:24:37 nichoj Exp $
+
+*java-config-2.0.29 (20 Sep 2006)
+
+ 20 Sep 2006; Joshua Nichols <nichoj@gentoo.org> -java-config-1.3.6.ebuild,
+ -java-config-2.0.28-r1.ebuild, +java-config-2.0.29.ebuild:
+ Version bump. The java-nsplugin eselect module now handles multilib stuff
+ properly. Slightly better error messages for when a tool isn't available on
+ a particular platform/jdk. Pruned old revisions.
14 Sep 2006; Joshua Nichols <nichoj@gentoo.org>
java-config-2.0.28-r1.ebuild:
diff --git a/dev-java/java-config/files/digest-java-config-2.0.29 b/dev-java/java-config/files/digest-java-config-2.0.29
new file mode 100644
index 000000000000..f6d8f82ac15f
--- /dev/null
+++ b/dev-java/java-config/files/digest-java-config-2.0.29
@@ -0,0 +1,3 @@
+MD5 bb1b626ee2c503b8fc16bafb6c6f54b3 java-config-2.0.29.tar.bz2 16503
+RMD160 1b583c261e16bd4deb919bca434c42d3b10ce576 java-config-2.0.29.tar.bz2 16503
+SHA256 66064a3e04deedbf3dba909335d0e1505a7f939b6ec241e3b9eebf1971b494f4 java-config-2.0.29.tar.bz2 16503
diff --git a/dev-java/java-config/java-config-2.0.29.ebuild b/dev-java/java-config/java-config-2.0.29.ebuild
new file mode 100644
index 000000000000..1cd94488ee50
--- /dev/null
+++ b/dev-java/java-config/java-config-2.0.29.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/java-config-2.0.29.ebuild,v 1.1 2006/09/20 04:24:37 nichoj Exp $
+
+inherit base distutils eutils
+
+DESCRIPTION="Java environment configuration tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/java/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# 2.4 needed to fix bug #147594, offending code fixed in trunk, so next bump can drop this
+DEPEND=">=dev-lang/python-2.4"
+RDEPEND=">=dev-lang/python-2.4
+ dev-java/java-config-wrapper"
+
+PATCHES="${FILESDIR}/${P}-classpath.patch"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/java-config-2/config/
+ for i in alpha amd64 hppa ia64 ppc ppc64 sparc x86; do
+ if use ${i}; then
+ newins config/jdk-defaults-${i}.conf jdk-defaults.conf || die "arch config not found"
+ fi
+ done
+
+ for tool in $(< config/symlink-tools); do
+ dosym /usr/bin/run-java-tool /usr/bin/${tool}
+ done
+
+ # Install profile.d for setting JAVA_HOME
+ dodir /etc/profile.d
+ exeinto /etc/profile.d
+ newexe ${FILESDIR}/${PN}-${SLOT}.profiled ${PN}-${SLOT}.sh || die "newexe failed"
+}
+
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/java-config-2/pym/java_config
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/java-config-2/pym/java_config
+
+ einfo "The way Java is handled on Gentoo has been recently updated."
+ einfo "If you have not done so already, you should follow the"
+ einfo "instructions available at:"
+ einfo "\thttp://www.gentoo.org/proj/en/java/java-upgrade.xml"
+ echo
+ einfo "While we moving towards the new Java system, we require"
+ einfo "a 1.3 or 1.4 JDK to be installed to ensure backwards compatibility"
+ einfo "with the old system."
+ einfo "For more details about this, please see:"
+ einfo "\thttps://overlays.gentoo.org/proj/java/wiki/Why_We_Need_Java14"
+}