summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-18 20:46:13 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-18 20:46:13 +0000
commitea6dc43d55866b11c029fd3154fffa9cf2eb523d (patch)
treead9d9d2d90b7093c3aab1be978dce47e7543c888 /dev-java/java-getopt
parentpovray license (diff)
downloadgentoo-2-ea6dc43d55866b11c029fd3154fffa9cf2eb523d.tar.gz
gentoo-2-ea6dc43d55866b11c029fd3154fffa9cf2eb523d.tar.bz2
gentoo-2-ea6dc43d55866b11c029fd3154fffa9cf2eb523d.zip
Fixes #7653.
Diffstat (limited to 'dev-java/java-getopt')
-rw-r--r--dev-java/java-getopt/ChangeLog9
-rw-r--r--dev-java/java-getopt/files/digest-java-getopt-1.0.91
-rw-r--r--dev-java/java-getopt/java-getopt-1.0.9.ebuild29
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/java-getopt/ChangeLog b/dev-java/java-getopt/ChangeLog
new file mode 100644
index 000000000000..5b693b39a797
--- /dev/null
+++ b/dev-java/java-getopt/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-java/java-getopt
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-getopt/ChangeLog,v 1.1 2002/10/18 20:46:13 karltk Exp $
+
+*java-getopt-1.0.0 (18 Oct 2002)
+
+ 18 Oct 2002; Karl Trygve Kalleberg <karltk@gentoo.org> java-getopt-1.0.9.ebuild, files/digest-java-getopt-1.0.9 :
+ Initial version, all code submitted by Thomas Osterlie
+ <thomas.osterlie@acm.org>. Fixes #7653.
diff --git a/dev-java/java-getopt/files/digest-java-getopt-1.0.9 b/dev-java/java-getopt/files/digest-java-getopt-1.0.9
new file mode 100644
index 000000000000..bdb312cb4bc9
--- /dev/null
+++ b/dev-java/java-getopt/files/digest-java-getopt-1.0.9
@@ -0,0 +1 @@
+MD5 ffbba007bb517dc42085d706ef7c0792 java-getopt-1.0.9.tar.gz 43683
diff --git a/dev-java/java-getopt/java-getopt-1.0.9.ebuild b/dev-java/java-getopt/java-getopt-1.0.9.ebuild
new file mode 100644
index 000000000000..65e840db2a5c
--- /dev/null
+++ b/dev-java/java-getopt/java-getopt-1.0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-getopt/java-getopt-1.0.9.ebuild,v 1.1 2002/10/18 20:46:13 karltk Exp $
+
+DESCRIPTION="Java command line option parser"
+HOMEPAGE="http://www.urbanophile.com/arenn/hacking/download.html"
+SRC_URI="ftp://ftp.urbanophile.com/pub/arenn/software/sources/java-getopt-${PV}.tar.gz"
+S=${WORKDIR}
+LICENSE="LGPL-2.1"
+SLOT="1"
+DEPEND=">=virtual/jdk-1.2
+ >=dev-java/ant-1.4.1"
+KEYWORDS="~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_compile() {
+ mv gnu/getopt/buildx.xml build.xml
+ ant all
+}
+
+src_install () {
+ dojar build/lib/gnu.getopt.jar
+ dohtml build/api/* -r
+ dodoc gnu/getopt/COPYING.LIB gnu/getopt/ChangeLog gnu/getopt/README
+}