summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-05-22 19:47:54 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-05-22 19:47:54 +0000
commit673b7b3fd0a87e66775e89b710b1db079cfb7439 (patch)
tree35c104afa4334a35e9ce1f8650fd31c1b0e5cd19 /dev-java/java-sdk-docs
parentFix build with GCC 4.7, wrt bug #417147 by Joe Kappus <joecool1029@gmail.com>. (diff)
downloadgentoo-2-673b7b3fd0a87e66775e89b710b1db079cfb7439.tar.gz
gentoo-2-673b7b3fd0a87e66775e89b710b1db079cfb7439.tar.bz2
gentoo-2-673b7b3fd0a87e66775e89b710b1db079cfb7439.zip
New distfile from upstream, bump from bug #67266 since it bit me.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/java-sdk-docs')
-rw-r--r--dev-java/java-sdk-docs/ChangeLog8
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.7.0.4.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-java/java-sdk-docs/ChangeLog b/dev-java/java-sdk-docs/ChangeLog
index 579c220e4f66..cd74d0e1e32c 100644
--- a/dev-java/java-sdk-docs/ChangeLog
+++ b/dev-java/java-sdk-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/java-sdk-docs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.83 2012/03/10 08:12:20 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.84 2012/05/22 19:47:54 robbat2 Exp $
+
+*java-sdk-docs-1.7.0.4 (22 May 2012)
+
+ 22 May 2012; Robin H. Johnson <robbat2@gentoo.org>
+ +java-sdk-docs-1.7.0.4.ebuild:
+ New distfile from upstream, bump from bug #67266 since it bit me.
*java-sdk-docs-1.6.0.30 (10 Mar 2012)
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.4.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.4.ebuild
new file mode 100644
index 000000000000..59a5fc0db00b
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.4.ebuild,v 1.1 2012/05/22 19:47:54 robbat2 Exp $
+
+ORIG_NAME="jdk-7u4-apidocs.zip"
+SRC_URI="${ORIG_NAME}"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/7/docs/"
+LICENSE="oracle-java-documentation-7"
+SLOT="1.7"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=""
+RESTRICT="fetch"
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/java-se-7-doc-download-435117.html"
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}