summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-06-22 13:09:21 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-06-22 13:09:21 +0000
commitc7a32f404bfbb79f212bbe7c51588212455d3545 (patch)
treed321c3eea0d367c74a38e04e0c0c2f34c5f041a0 /dev-java/java-sdk-docs
parentAdd USE=+deprecated for gtk2 dependency, add live ebuild for gtk3 development. (diff)
downloadgentoo-2-c7a32f404bfbb79f212bbe7c51588212455d3545.tar.gz
gentoo-2-c7a32f404bfbb79f212bbe7c51588212455d3545.tar.bz2
gentoo-2-c7a32f404bfbb79f212bbe7c51588212455d3545.zip
Version bump to 1.7.0.25 for bug #67266, bump reported by Will W.
(Portage version: 2.1.12.5/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/java-sdk-docs')
-rw-r--r--dev-java/java-sdk-docs/ChangeLog7
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.7.0.25.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-java/java-sdk-docs/ChangeLog b/dev-java/java-sdk-docs/ChangeLog
index 7a4834f9f511..5403fb13d132 100644
--- a/dev-java/java-sdk-docs/ChangeLog
+++ b/dev-java/java-sdk-docs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/java-sdk-docs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.90 2013/05/10 09:16:00 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.91 2013/06/22 13:09:21 tomwij Exp $
+
+*java-sdk-docs-1.7.0.25 (22 Jun 2013)
+
+ 22 Jun 2013; Tom Wijsman <TomWij@gentoo.org> +java-sdk-docs-1.7.0.25.ebuild:
+ Version bump to 1.7.0.25 for bug #67266, bump reported by Will W.
*java-sdk-docs-1.7.0.21 (10 May 2013)
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.25.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.25.ebuild
new file mode 100644
index 000000000000..c8f72235b208
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.25.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.7.0.25.ebuild,v 1.1 2013/06/22 13:09:21 tomwij Exp $
+
+EAPI=5
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/java-se-7-doc-download-435117.html"
+ORIG_NAME="jdk-7u$(get_version_component_range 4)-apidocs.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/7/docs/"
+SRC_URI="${ORIG_NAME}"
+
+LICENSE="oracle-java-documentation-7"
+SLOT="1.7"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}