summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-05-06 21:55:28 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-05-06 21:55:28 +0000
commit505f1275ad384f293b7ecf552e4993c6e0315283 (patch)
treeec6e4ad4ea2a6ba0a8b6dcbee8d05f67080e888b /dev-java/jdbc-postgresql
parentVersion bump. Fixes bug #250810. (diff)
downloadgentoo-2-505f1275ad384f293b7ecf552e4993c6e0315283.tar.gz
gentoo-2-505f1275ad384f293b7ecf552e4993c6e0315283.tar.bz2
gentoo-2-505f1275ad384f293b7ecf552e4993c6e0315283.zip
Remove old ebuilds.
(Portage version: 2.2_rc28/cvs/Linux i686)
Diffstat (limited to 'dev-java/jdbc-postgresql')
-rw-r--r--dev-java/jdbc-postgresql/ChangeLog7
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild94
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p505.ebuild94
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p506.ebuild81
4 files changed, 6 insertions, 270 deletions
diff --git a/dev-java/jdbc-postgresql/ChangeLog b/dev-java/jdbc-postgresql/ChangeLog
index 2158fe9a37d3..4b43ce464e55 100644
--- a/dev-java/jdbc-postgresql/ChangeLog
+++ b/dev-java/jdbc-postgresql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jdbc-postgresql
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/ChangeLog,v 1.24 2009/05/06 21:52:45 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/ChangeLog,v 1.25 2009/05/06 21:55:28 betelgeuse Exp $
+
+ 06 May 2009; Petteri Räty <betelgeuse@gentoo.org>
+ -jdbc-postgresql-8.2_p504.ebuild, -jdbc-postgresql-8.2_p505.ebuild,
+ -jdbc-postgresql-8.2_p506.ebuild:
+ Remove old ebuilds.
*jdbc-postgresql-8.3_p604 (06 May 2009)
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild
deleted file mode 100644
index c5be8e19c2e8..000000000000
--- a/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p504.ebuild,v 1.10 2008/05/21 15:58:55 dev-zero Exp $
-
-inherit java-pkg-2 java-ant-2
-
-MY_PN="postgresql-jdbc"
-MY_PV="${PV/_p/-}"
-MY_P="${MY_PN}-${MY_PV}.src"
-
-DESCRIPTION="JDBC Driver for PostgreSQL"
-SRC_URI="http://jdbc.postgresql.org/download/${MY_P}.tar.gz"
-HOMEPAGE="http://jdbc.postgresql.org/"
-
-LICENSE="POSTGRESQL"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-fbsd"
-IUSE="doc java5 source test"
-
-DEPEND=">=dev-java/java-config-2.0.31
- !java5? ( =virtual/jdk-1.4* )
- java5? ( =virtual/jdk-1.5* )
- doc? ( dev-libs/libxslt
- app-text/docbook-xsl-stylesheets )
- source? ( app-arch/zip )
- !test? ( >=dev-java/ant-core-1.6 )
- test? ( =dev-java/junit-3.8*
- >=dev-java/ant-1.6
- virtual/postgresql-server )"
-RDEPEND=">=virtual/jre-1.4"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if use java5; then
- JAVA_PKG_NV_DEPEND="=virtual/jdk-1.5*"
-
- # We must specify source/target versions because currently it is not
- # correctly picked up from NV_DEPEND for build.xml rewrite
- JAVA_PKG_WANT_SOURCE="1.5"
- JAVA_PKG_WANT_TARGET="1.5"
- else
- JAVA_PKG_NV_DEPEND="=virtual/jdk-1.4*"
- fi
-
- java-pkg-2_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
-
- # patch to make junit test work + correction for doc target
- cd ${S}
- epatch ${FILESDIR}/${P}-build.xml.patch
-}
-
-src_compile() {
- eant jar $(use_doc publicapi)
-
- # There is a task that creates this doc but I didn't find a way how to use system catalog
- # to lookup the stylesheet so the 'doc' target is rewritten here to use system call instead.
- if use doc; then
- mkdir -p ${S}/build/doc
- xsltproc -o ${S}/build/doc/pgjdbc.html http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl \
- ${S}/doc/pgjdbc.xml
- fi
-}
-
-src_install() {
- java-pkg_newjar jars/postgresql.jar jdbc-postgresql.jar
-
- if use_doc; then
- java-pkg_dojavadoc build/publicapi
- dohtml build/doc/pgjdbc.html
- fi
-
- use source && java-pkg_dosrc org
-}
-
-src_test() {
- einfo "In order to run the tests successfully, you have to have:"
- einfo "1) PostgreSQL server running"
- einfo "2) database 'test' defined with user 'test' with password 'password'"
- einfo " as owner of the database"
- einfo "3) plpgsql support in the 'test' database"
- einfo
- einfo "You can find a general info on how to perform these steps at"
- einfo "http://gentoo-wiki.com/HOWTO_Configure_Postgresql"
-
- mkdir lib
- java-pkg_jar-from --into lib junit
-
- ANT_TASKS="ant-junit" eant test
-}
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p505.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p505.ebuild
deleted file mode 100644
index 1c6af60bbc93..000000000000
--- a/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p505.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p505.ebuild,v 1.7 2008/05/21 15:58:55 dev-zero Exp $
-
-JAVA_PKG_IUSE="doc source"
-inherit java-pkg-2 java-ant-2
-
-MY_PN="postgresql-jdbc"
-MY_PV="${PV/_p/-}"
-MY_P="${MY_PN}-${MY_PV}.src"
-
-DESCRIPTION="JDBC Driver for PostgreSQL"
-SRC_URI="http://jdbc.postgresql.org/download/${MY_P}.tar.gz"
-HOMEPAGE="http://jdbc.postgresql.org/"
-
-LICENSE="POSTGRESQL"
-SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~x86-fbsd"
-IUSE="java5 test"
-
-DEPEND=">=dev-java/java-config-2.0.31
- !java5? ( =virtual/jdk-1.4* )
- java5? ( =virtual/jdk-1.5* )
- doc? ( dev-libs/libxslt
- app-text/docbook-xsl-stylesheets )
- !test? ( >=dev-java/ant-core-1.6 )
- test? ( =dev-java/junit-3.8*
- >=dev-java/ant-1.6
- virtual/postgresql-server )"
-RDEPEND=">=virtual/jre-1.4"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if use java5; then
- JAVA_PKG_NV_DEPEND="=virtual/jdk-1.5*"
-
- # We must specify source/target versions because currently it is not
- # correctly picked up from NV_DEPEND for build.xml rewrite
- JAVA_PKG_WANT_SOURCE="1.5"
- JAVA_PKG_WANT_TARGET="1.5"
- else
- JAVA_PKG_NV_DEPEND="=virtual/jdk-1.4*"
- fi
-
- java-pkg-2_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
-
- # patch to make junit test work + correction for doc target
- cd ${S}
- epatch ${FILESDIR}/${P}-build.xml.patch
-}
-
-src_compile() {
- eant jar $(use_doc publicapi)
-
- # There is a task that creates this doc but I didn't find a way how to use system catalog
- # to lookup the stylesheet so the 'doc' target is rewritten here to use system call instead.
- if use doc; then
- mkdir -p ${S}/build/doc
- xsltproc -o ${S}/build/doc/pgjdbc.html http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl \
- ${S}/doc/pgjdbc.xml
- fi
-}
-
-src_install() {
- java-pkg_newjar jars/postgresql.jar jdbc-postgresql.jar
-
- if use_doc; then
- java-pkg_dojavadoc build/publicapi
- dohtml build/doc/pgjdbc.html
- fi
-
- use source && java-pkg_dosrc org
-}
-
-src_test() {
- einfo "In order to run the tests successfully, you have to have:"
- einfo "1) PostgreSQL server running"
- einfo "2) database 'test' defined with user 'test' with password 'password'"
- einfo " as owner of the database"
- einfo "3) plpgsql support in the 'test' database"
- einfo
- einfo "You can find a general info on how to perform these steps at"
- einfo "http://gentoo-wiki.com/HOWTO_Configure_Postgresql"
-
- mkdir lib
- java-pkg_jar-from --into lib junit
-
- ANT_TASKS="ant-junit" eant test
-}
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p506.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p506.ebuild
deleted file mode 100644
index c9da57fa20e7..000000000000
--- a/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p506.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/jdbc-postgresql-8.2_p506.ebuild,v 1.2 2008/05/21 15:58:55 dev-zero Exp $
-
-JAVA_PKG_IUSE="doc source"
-inherit java-pkg-2 java-ant-2
-
-MY_PN="postgresql-jdbc"
-MY_PV="${PV/_p/-}"
-MY_P="${MY_PN}-${MY_PV}.src"
-
-DESCRIPTION="JDBC Driver for PostgreSQL"
-SRC_URI="http://jdbc.postgresql.org/download/${MY_P}.tar.gz"
-HOMEPAGE="http://jdbc.postgresql.org/"
-
-LICENSE="POSTGRESQL"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="java5 test"
-
-DEPEND=">=dev-java/java-config-2.0.31
- !java5? ( =virtual/jdk-1.4* )
- java5? ( =virtual/jdk-1.5* )
- doc? (
- dev-libs/libxslt
- app-text/docbook-xsl-stylesheets
- )
- !test? ( >=dev-java/ant-core-1.6 )
- test? (
- =dev-java/junit-3.8*
- >=dev-java/ant-1.6
- dev-java/ant-junit
- virtual/postgresql-server
- )"
-RDEPEND="!java5? ( >=virtual/jre-1.4 )
- java5? ( >=virtual/jre-1.5 )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- java-ant_rewrite-classpath
-}
-
-src_compile() {
- eant jar $(use_doc publicapi)
-
- # There is a task that creates this doc but I didn't find a way how to use system catalog
- # to lookup the stylesheet so the 'doc' target is rewritten here to use system call instead.
- if use doc; then
- mkdir -p ${S}/build/doc
- xsltproc -o ${S}/build/doc/pgjdbc.html http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl \
- ${S}/doc/pgjdbc.xml
- fi
-}
-
-src_test() {
- einfo "In order to run the tests successfully, you have to have:"
- einfo "1) PostgreSQL server running"
- einfo "2) database 'test' defined with user 'test' with password 'password'"
- einfo " as owner of the database"
- einfo "3) plpgsql support in the 'test' database"
- einfo
- einfo "You can find a general info on how to perform these steps at"
- einfo "http://gentoo-wiki.com/HOWTO_Configure_Postgresql"
-
- ANT_TASKS="ant-junit" eant test -Dgentoo.classpath=$(java-pkg_getjars --build-only junit)
-}
-
-src_install() {
- java-pkg_newjar jars/postgresql.jar jdbc-postgresql.jar
-
- if use doc ; then
- java-pkg_dojavadoc build/publicapi
- dohtml build/doc/pgjdbc.html
- fi
-
- use source && java-pkg_dosrc org
-}