summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2008-02-06 15:47:13 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2008-02-06 15:47:13 +0000
commit0b52c969277731953a90b322d957321a70f97492 (patch)
treef76b2c2192b3356ddd3b04eb6f2146b48bb550e0 /dev-java/jexcelapi
parentVersion bump. (diff)
downloadgentoo-2-0b52c969277731953a90b322d957321a70f97492.tar.gz
gentoo-2-0b52c969277731953a90b322d957321a70f97492.tar.bz2
gentoo-2-0b52c969277731953a90b322d957321a70f97492.zip
Version bump
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-java/jexcelapi')
-rw-r--r--dev-java/jexcelapi/ChangeLog9
-rw-r--r--dev-java/jexcelapi/jexcelapi-2.6.6.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-java/jexcelapi/ChangeLog b/dev-java/jexcelapi/ChangeLog
index 518b6d76cedc..5d2ed2950efc 100644
--- a/dev-java/jexcelapi/ChangeLog
+++ b/dev-java/jexcelapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jexcelapi
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/ChangeLog,v 1.14 2007/11/15 00:36:23 betelgeuse Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/ChangeLog,v 1.15 2008/02/06 15:47:13 fordfrog Exp $
+
+*jexcelapi-2.6.6 (06 Feb 2008)
+
+ 06 Feb 2008; Miroslav Šulc <fordfrog@gentoo.org> +jexcelapi-2.6.6.ebuild:
+ Version bump
15 Nov 2007; Petteri Räty <betelgeuse@gentoo.org>
-jexcelapi-2.5.1.ebuild:
diff --git a/dev-java/jexcelapi/jexcelapi-2.6.6.ebuild b/dev-java/jexcelapi/jexcelapi-2.6.6.ebuild
new file mode 100644
index 000000000000..18a06f4d34f8
--- /dev/null
+++ b/dev-java/jexcelapi/jexcelapi-2.6.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/jexcelapi-2.6.6.ebuild,v 1.1 2008/02/06 15:47:13 fordfrog Exp $
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+
+MY_P="${P//-/_}"
+MY_P="${MY_P//./_}"
+
+DESCRIPTION="A Java API to read, write, and modify Excel spreadsheets"
+HOMEPAGE="http://jexcelapi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jexcelapi/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2.5"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ find -name "*.jar" | xargs rm -v
+ find -name "*.class" -delete
+ rm -fr docs
+
+ # sun-jdk-1.5/jikes fails
+ java-pkg_filter-compiler jikes
+}
+
+src_compile() {
+ eant -f build/build.xml jxl $(use_doc docs)
+}
+
+src_install() {
+ java-pkg_newjar jxl.jar ${PN}.jar
+
+ java-pkg_dohtml index.html tutorial.html
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc "${S}"/src/*
+}