summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-09-07 15:59:54 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-09-07 15:59:54 +0000
commitd9b80a89341989392742766ef9ed206934fe41be (patch)
tree634832ebeb10d071e42d6a2eb9d98e38c6a61d70 /dev-java/jgoodies-forms
parentEAPI 5 bump; dropped unused build file (diff)
downloadgentoo-2-d9b80a89341989392742766ef9ed206934fe41be.tar.gz
gentoo-2-d9b80a89341989392742766ef9ed206934fe41be.tar.bz2
gentoo-2-d9b80a89341989392742766ef9ed206934fe41be.zip
EAPI bump; dropped unused patch file
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java/jgoodies-forms')
-rw-r--r--dev-java/jgoodies-forms/ChangeLog8
-rw-r--r--dev-java/jgoodies-forms/files/jgoodies-forms-1.0.7-build.xml.patch53
-rw-r--r--dev-java/jgoodies-forms/jgoodies-forms-1.3.0-r1.ebuild44
3 files changed, 51 insertions, 54 deletions
diff --git a/dev-java/jgoodies-forms/ChangeLog b/dev-java/jgoodies-forms/ChangeLog
index e9bf2b4565b4..daf069a7c084 100644
--- a/dev-java/jgoodies-forms/ChangeLog
+++ b/dev-java/jgoodies-forms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jgoodies-forms
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-forms/ChangeLog,v 1.32 2014/07/11 17:43:05 ercpe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-forms/ChangeLog,v 1.33 2014/09/07 15:59:54 ercpe Exp $
+
+*jgoodies-forms-1.3.0-r1 (07 Sep 2014)
+
+ 07 Sep 2014; Johann Schmitz <ercpe@gentoo.org>
+ +jgoodies-forms-1.3.0-r1.ebuild, -files/jgoodies-forms-1.0.7-build.xml.patch:
+ EAPI bump; dropped unused patch file
*jgoodies-forms-1.8.0 (11 Jul 2014)
diff --git a/dev-java/jgoodies-forms/files/jgoodies-forms-1.0.7-build.xml.patch b/dev-java/jgoodies-forms/files/jgoodies-forms-1.0.7-build.xml.patch
deleted file mode 100644
index ca92424f6df2..000000000000
--- a/dev-java/jgoodies-forms/files/jgoodies-forms-1.0.7-build.xml.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -Nru forms-1.0.7.vanilla/build.xml forms-1.0.7/build.xml
---- forms-1.0.7.vanilla/build.xml 2006-08-02 23:05:21.000000000 +0200
-+++ forms-1.0.7/build.xml 2006-08-02 23:07:45.000000000 +0200
-@@ -27,8 +27,6 @@
- <!-- ***************************************************************** -->
- <!-- Give users a chance to override build properties. -->
- <!-- ***************************************************************** -->
-- <property file="${user.home}/forms.build.properties" />
-- <property file="${user.home}/build.properties" />
- <property file="${basedir}/build.properties" />
- <property file="${basedir}/default.properties" />
-
-@@ -118,8 +116,7 @@
- optimize ="${build.compile.optimize}"
- source ="${build.compile.source}"
- target ="${build.compile.target}"
-- verbose ="${build.compile.verbose}"
-- bootclasspath="${build.boot.classpath}" />
-+ verbose ="${build.compile.verbose}" />
- </target>
-
- <!-- ***************************************************************** -->
-@@ -139,7 +136,6 @@
- source ="${build.compile.source}"
- target ="${build.compile.target}"
- verbose ="${build.compile.verbose}"
-- bootclasspath="${build.boot.classpath}"
- classpathref ="classpath.core" />
- </target>
-
-@@ -161,7 +157,6 @@
- source ="${build.compile.source}"
- target ="${build.compile.target}"
- verbose ="${build.compile.verbose}"
-- bootclasspath="${build.boot.classpath}"
- classpathref ="classpath.tests" />
- </target>
-
-@@ -182,7 +177,6 @@
- source ="${build.compile.source}"
- target ="${build.compile.target}"
- verbose ="${build.compile.verbose}"
-- bootclasspath="${build.boot.classpath}"
- classpathref ="classpath.tutorial" />
- </target>
-
-@@ -300,4 +294,4 @@
- </target>
-
-
--</project>
-\ No newline at end of file
-+</project>
diff --git a/dev-java/jgoodies-forms/jgoodies-forms-1.3.0-r1.ebuild b/dev-java/jgoodies-forms/jgoodies-forms-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..94e6d311fc4e
--- /dev/null
+++ b/dev-java/jgoodies-forms/jgoodies-forms-1.3.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-forms/jgoodies-forms-1.3.0-r1.ebuild,v 1.1 2014/09/07 15:59:54 ercpe Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="forms"
+MY_PV=${PV//./_}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="JGoodies Forms Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-macos"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+EANT_FILTER_COMPILTER="jikes"
+
+java_prepare() {
+ find -name "*.jar" -delete || die
+}
+
+src_install() {
+ java-pkg_dojar build/${MY_PN}.jar
+
+ dodoc RELEASE-NOTES.txt README.html || die
+
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/{core,extras}/com
+ use examples && java-pkg_doexamples src/tutorial
+}