summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-08-27 10:12:52 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-08-27 10:12:52 +0000
commitb69094ffe5c182278eb7ed9f78e95b655d218cb2 (patch)
treeebc81f2cf3092ed9b317b9533f40a56ff83d206b /dev-java/jswat/jswat-2.25.ebuild
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-b69094ffe5c182278eb7ed9f78e95b655d218cb2.tar.gz
gentoo-2-b69094ffe5c182278eb7ed9f78e95b655d218cb2.tar.bz2
gentoo-2-b69094ffe5c182278eb7ed9f78e95b655d218cb2.zip
bit of files/ cleanup, disabled junit because it runs inside a X program which is unacceptable, version bump
Diffstat (limited to 'dev-java/jswat/jswat-2.25.ebuild')
-rw-r--r--dev-java/jswat/jswat-2.25.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/jswat/jswat-2.25.ebuild b/dev-java/jswat/jswat-2.25.ebuild
new file mode 100644
index 000000000000..53e5c170e402
--- /dev/null
+++ b/dev-java/jswat/jswat-2.25.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jswat/jswat-2.25.ebuild,v 1.1 2004/08/27 10:12:52 axxo Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="Extensible graphical Java debugger"
+HOMEPAGE="http://www.bluemarsh.com/java/jswat"
+SRC_URI="mirror://sourceforge/jswat/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="x86 sparc -ppc amd64"
+IUSE="doc jikes" #junit"
+
+DEPEND=">=dev-java/ant-1.5"
+ #junit? ( dev-java/junit )"
+RDEPEND=">=virtual/jdk-1.4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/build.xml.patch
+}
+
+src_compile() {
+ local antopts="-Dversion=${PV}"
+ use jikes && antopts="${antopts} -Dbuild.compiler=jikes"
+ ant ${antopts} dist || die "Compile failed"
+
+ # Junits tests run inside a X window, disable.
+ #if use junit ; then
+ # addwrite /root/.java/
+ # einfo "Running JUnit tests, this may take awhile ..."
+ # ant ${antopts} test || die "Junit test failed"
+ #fi
+}
+
+src_install() {
+ # install jswat classes
+ java-pkg_dojar build/dist/*/*.jar
+
+ # prepare and install jswat script
+ dobin ${FILESDIR}/jswat2
+
+ # install documents
+ dodoc BUGS.txt HISTORY.txt LICENSE.txt OLD_HISTORY.txt TODO.txt
+ dohtml README.html
+ use doc && dohtml -r docs
+}