summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2006-09-12 08:05:16 +0000
committerVlastimil Babka <caster@gentoo.org>2006-09-12 08:05:16 +0000
commit84ffd00c44a25756ac1cce3b8cac118f61d8f124 (patch)
tree443e75e44834686d0e2cc7c725e7c6ba5382229b /dev-java/jython
parentAdded ~ppc64; bug #121862 (diff)
downloadgentoo-2-84ffd00c44a25756ac1cce3b8cac118f61d8f124.tar.gz
gentoo-2-84ffd00c44a25756ac1cce3b8cac118f61d8f124.tar.bz2
gentoo-2-84ffd00c44a25756ac1cce3b8cac118f61d8f124.zip
Revbump to ensure everyone has bug #147243 (caused by java-utils-2.eclass) fixed. Also sanitized dolauncher parameters quoting. Thanks to Joel <joel_123@hotmail.com> for reporting.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-java/jython')
-rw-r--r--dev-java/jython/ChangeLog9
-rw-r--r--dev-java/jython/files/digest-jython-2.1-r103
-rw-r--r--dev-java/jython/jython-2.1-r10.ebuild94
3 files changed, 105 insertions, 1 deletions
diff --git a/dev-java/jython/ChangeLog b/dev-java/jython/ChangeLog
index 07ea18703c40..9176b2f1617f 100644
--- a/dev-java/jython/ChangeLog
+++ b/dev-java/jython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jython
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/ChangeLog,v 1.34 2006/09/11 00:08:08 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/ChangeLog,v 1.35 2006/09/12 08:05:16 caster Exp $
+
+*jython-2.1-r10 (12 Sep 2006)
+
+ 12 Sep 2006; Vlastimil Babka <caster@gentoo.org> +jython-2.1-r10.ebuild:
+ Revbump to ensure everyone has bug #147243 (caused by java-utils-2.eclass)
+ fixed. Also sanitized dolauncher parameters quoting. Thanks to Joel
+ <joel_123@hotmail.com> for reporting.
11 Sep 2006; Joshua Nichols <nichoj@gentoo.org> jython-2.1-r9.ebuild:
Added ~ia64 keywords.
diff --git a/dev-java/jython/files/digest-jython-2.1-r10 b/dev-java/jython/files/digest-jython-2.1-r10
new file mode 100644
index 000000000000..430b21a5c3b2
--- /dev/null
+++ b/dev-java/jython/files/digest-jython-2.1-r10
@@ -0,0 +1,3 @@
+MD5 74f21a0185135396c71453bc279c179f jython-2.1.tar.bz2 1301528
+RMD160 94ae22604c1a816af7d066f2ed88b2abaf5c51d1 jython-2.1.tar.bz2 1301528
+SHA256 faa57a55d137268e80221cd628b234ca67de13504b813be1c0499c9f4d5872b2 jython-2.1.tar.bz2 1301528
diff --git a/dev-java/jython/jython-2.1-r10.ebuild b/dev-java/jython/jython-2.1-r10.ebuild
new file mode 100644
index 000000000000..cef16b781e6f
--- /dev/null
+++ b/dev-java/jython/jython-2.1-r10.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/jython-2.1-r10.ebuild,v 1.1 2006/09/12 08:05:16 caster Exp $
+
+inherit base java-pkg-2
+
+DESCRIPTION="An implementation of Python written in Java"
+HOMEPAGE="http://www.jython.org"
+MY_PV="21"
+#SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.class"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="JPython"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="readline source doc"
+# servlet
+
+RDEPEND=">=virtual/jre-1.2
+ readline? ( >=dev-java/libreadline-java-0.8.0 )"
+# servlet? ( >=net-www/tomcat-5.0 )
+DEPEND=">=virtual/jdk-1.2
+ source? ( app-arch/zip )
+ ${RDEPEND}"
+
+PATCHES="${FILESDIR}/${PV}-assert.patch
+ ${FILESDIR}/${PV}-assert-SimpleCompiler.py.patch"
+
+src_compile() {
+ local cp="."
+ local exclude=""
+
+ if use readline ; then
+ cp=${cp}:$(java-pkg_getjars libreadline-java)
+ else
+ exclude="${exclude} ! -name ReadlineConsole.java"
+ fi
+
+ #if use servlet; then
+ # cp=${cp}:$(java-pkg_getjars servlet)
+ #else
+ exclude="${exclude} ! -name PyServlet.java"
+ #fi
+
+ ejavac -classpath ${cp} -nowarn $(find org -name "*.java" ${exclude})
+
+ find org -name "*.class" | xargs jar cf ${PN}.jar
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ dodoc README.txt NEWS ACKNOWLEDGMENTS
+ use doc && java-pkg_dohtml -A .css .jpg .gif -r Doc/*
+
+ java-pkg_dolauncher jythonc \
+ --main "org.python.util.jython" \
+ --java_args "-Dpython.home=/usr/share/jython" \
+ --pkg_args "/usr/share/jython/tools/jythonc/jythonc.py"
+
+ java-pkg_dolauncher jython \
+ --main "org.python.util.jython" \
+ --java_args "-Dpython.home=/usr/share/jython"
+
+ dodir /usr/share/jython/cachedir
+ chmod a+rw ${D}/usr/share/jython/cachedir
+
+ rm Demo/jreload/example.jar
+ insinto /usr/share/${PN}
+ doins -r Lib Demo registry
+
+ insinto /usr/share/${PN}/tools
+ doins -r Tools/*
+
+ use source && java-pkg_dosrc com org
+}
+
+pkg_postinst() {
+ if use readline; then
+ einfo "To use readline you need to add the following to your registery"
+ einfo
+ einfo "python.console=org.python.util.ReadlineConsole"
+ einfo "python.console.readlinelib=GnuReadline"
+ einfo
+ einfo "The global registry can be found in /usr/share/${PN}/registry"
+ einfo "User registry in \$HOME/.jython"
+ einfo "See http://www.jython.org/docs/registry.html for more information"
+ einfo ""
+ fi
+
+ elog "This revision renames org.python.core.Py.assert to assert_."
+ elog "This is the solution that upstream will use in the next release."
+ elog "Just note that this revision is not API compatible with vanilla 2.1."
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=142099"
+}