summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-12-04 17:20:19 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-12-04 17:20:19 +0000
commit3ab4274a54387c9c69e39616c6e3dc5954a69f34 (patch)
treef359946aac3cc0b7eb06458e4c4b851deca450dc /dev-java/minml2/minml2-0.3.ebuild
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-3ab4274a54387c9c69e39616c6e3dc5954a69f34.tar.gz
gentoo-2-3ab4274a54387c9c69e39616c6e3dc5954a69f34.tar.bz2
gentoo-2-3ab4274a54387c9c69e39616c6e3dc5954a69f34.zip
Initial import. Fixes #72402. luckyduck rocks fur!
Diffstat (limited to 'dev-java/minml2/minml2-0.3.ebuild')
-rw-r--r--dev-java/minml2/minml2-0.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-java/minml2/minml2-0.3.ebuild b/dev-java/minml2/minml2-0.3.ebuild
new file mode 100644
index 000000000000..397e8c0cab3d
--- /dev/null
+++ b/dev-java/minml2/minml2-0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/minml2/minml2-0.3.ebuild,v 1.1 2004/12/04 17:20:19 karltk Exp $
+
+inherit eutils java-pkg
+
+DESCRIPTION="Small footprint namespace aware XML parser"
+SRC_URI="http://www.wilson.co.uk/xml/MinML2-${PV}.zip"
+HOMEPAGE="http://wilson.co.uk/xml/minml.htm"
+LICENSE="BSD"
+SLOT="0.3"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ jikes? ( >=dev-java/jikes-1.21 )
+ >=dev-java/ant-core-1.4
+ >=app-arch/unzip-5.50-r1"
+RDEPEND=">=virtual/jre-1.3"
+
+S=${WORKDIR}/MinML2.release
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/minml-jikes.patch
+
+ cp ${FILESDIR}/build.xml .
+}
+
+src_compile() {
+ local antflags="jar"
+ if use doc; then
+ antflags="${antflags} docs"
+ fi
+ if use jikes; then
+ antflags="${antflags} -Dbuild.compiler=jikes"
+ fi
+ ant ${antflags} || die "failed to build"
+}
+
+src_install() {
+ java-pkg_dojar dist/minml2.jar
+
+ dodoc history.txt licence.txt readme.txt
+ if use doc; then
+ java-pkg_dohtml -r docs/*
+ fi
+}