summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-01-10 15:08:51 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-01-10 15:08:51 +0000
commitde39d5a268904922ee093c3ba19918a8f5ada98e (patch)
tree49ede75b8b2a2fd283b4a3c4aa082eed7d1c498b /dev-java/resin-servlet-api
parentamd64/x86 stable, bug #253054 (diff)
downloadgentoo-2-de39d5a268904922ee093c3ba19918a8f5ada98e.tar.gz
gentoo-2-de39d5a268904922ee093c3ba19918a8f5ada98e.tar.bz2
gentoo-2-de39d5a268904922ee093c3ba19918a8f5ada98e.zip
Version bump.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-tuxonice x86_64)
Diffstat (limited to 'dev-java/resin-servlet-api')
-rw-r--r--dev-java/resin-servlet-api/ChangeLog9
-rw-r--r--dev-java/resin-servlet-api/resin-servlet-api-3.1.8.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-java/resin-servlet-api/ChangeLog b/dev-java/resin-servlet-api/ChangeLog
index 17f12761f423..f30a3be6a772 100644
--- a/dev-java/resin-servlet-api/ChangeLog
+++ b/dev-java/resin-servlet-api/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/resin-servlet-api
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/resin-servlet-api/ChangeLog,v 1.20 2008/06/10 20:58:33 nelchael Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/resin-servlet-api/ChangeLog,v 1.21 2009/01/10 15:08:51 nelchael Exp $
+
+*resin-servlet-api-3.1.8 (10 Jan 2009)
+
+ 10 Jan 2009; <nelchael@gentoo.org> +resin-servlet-api-3.1.8.ebuild:
+ Version bump.
*resin-servlet-api-3.0.26 (10 Jun 2008)
diff --git a/dev-java/resin-servlet-api/resin-servlet-api-3.1.8.ebuild b/dev-java/resin-servlet-api/resin-servlet-api-3.1.8.ebuild
new file mode 100644
index 000000000000..868001fd8c4b
--- /dev/null
+++ b/dev-java/resin-servlet-api/resin-servlet-api-3.1.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/resin-servlet-api/resin-servlet-api-3.1.8.ebuild,v 1.1 2009/01/10 15:08:51 nelchael Exp $
+
+JAVA_PKG_IUSE="source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Resin Servlet API 2.5/JSP API 2.1 implementation"
+HOMEPAGE="http://www.caucho.com/"
+SRC_URI="http://www.caucho.com/download/resin-${PV}-src.zip
+ mirror://gentoo/resin-gentoo-patches-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+IUSE=""
+
+COMMON_DEP=""
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/resin-${PV}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ mkdir "${S}/lib"
+
+ cd "${S}"
+ epatch "${WORKDIR}/${PV}/resin-${PV}-build.xml.patch" || die
+
+}
+
+EANT_BUILD_TARGET="jsdk"
+EANT_DOC_TARGET=""
+
+src_install() {
+
+ java-pkg_newjar "lib/jsdk-15.jar"
+ use source && java-pkg_dosrc "${S}"/modules/jsdk/src/*
+
+}