summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-02-11 11:43:45 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-02-11 11:43:45 +0000
commite0b6a6d3e7ec77f25a8ec078037d4ffc91fde970 (patch)
treee6a39005bd7cb074f40521fb6dba4017bdc14b06 /dev-java/sun-jdk
parentAdded 'ip27' to the 2007.0 MIPS folder. (diff)
downloadgentoo-2-e0b6a6d3e7ec77f25a8ec078037d4ffc91fde970.tar.gz
gentoo-2-e0b6a6d3e7ec77f25a8ec078037d4ffc91fde970.tar.bz2
gentoo-2-e0b6a6d3e7ec77f25a8ec078037d4ffc91fde970.zip
Version bump for bug #166305.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-java/sun-jdk')
-rw-r--r--dev-java/sun-jdk/ChangeLog8
-rw-r--r--dev-java/sun-jdk/files/digest-sun-jdk-1.5.0.116
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.5.0.11.ebuild156
3 files changed, 169 insertions, 1 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index 2eb82225cc47..bce3aa9e2594 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.184 2007/01/23 11:22:56 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.185 2007/02/11 11:43:45 betelgeuse Exp $
+
+*sun-jdk-1.5.0.11 (11 Feb 2007)
+
+ 11 Feb 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +sun-jdk-1.5.0.11.ebuild:
+ Version bump for bug #166305.
23 Jan 2007; Vlastimil Babka <caster@gentoo.org> -sun-jdk-1.5.0.09.ebuild:
Remove vulnerable version.
diff --git a/dev-java/sun-jdk/files/digest-sun-jdk-1.5.0.11 b/dev-java/sun-jdk/files/digest-sun-jdk-1.5.0.11
new file mode 100644
index 000000000000..e6f312fcc9a8
--- /dev/null
+++ b/dev-java/sun-jdk/files/digest-sun-jdk-1.5.0.11
@@ -0,0 +1,6 @@
+MD5 ace2fc1b8c9d381b4e297c66c5a9caa7 jdk-1_5_0_11-dlj-linux-amd64.bin 43954177
+RMD160 bd865019d3fb2268800696207dba158ea2986a7f jdk-1_5_0_11-dlj-linux-amd64.bin 43954177
+SHA256 98df66902f42f764cb89b12a1502b976f2e5ddb2aa5000e14846b90cef74e0db jdk-1_5_0_11-dlj-linux-amd64.bin 43954177
+MD5 9dfdad6a166ed403513c0a5509d82e4b jdk-1_5_0_11-dlj-linux-i586.bin 49598681
+RMD160 74c5bd78450397006ea145580c3554d77b64a31d jdk-1_5_0_11-dlj-linux-i586.bin 49598681
+SHA256 da7c0217c1c6d47aad77a8b5ca0b30b01846c8090d5b1d5907862ef7122a1705 jdk-1_5_0_11-dlj-linux-i586.bin 49598681
diff --git a/dev-java/sun-jdk/sun-jdk-1.5.0.11.ebuild b/dev-java/sun-jdk/sun-jdk-1.5.0.11.ebuild
new file mode 100644
index 000000000000..099eb5190de1
--- /dev/null
+++ b/dev-java/sun-jdk/sun-jdk-1.5.0.11.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.11.ebuild,v 1.1 2007/02/11 11:43:45 betelgeuse Exp $
+
+inherit java-vm-2 eutils pax-utils
+
+MY_PVL=${PV%.*}_${PV##*.}
+MY_PVA=${PV//./_}
+S="${WORKDIR}/jdk${MY_PVL}"
+
+X86_AT="jdk-${MY_PVA}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PVA}-dlj-linux-amd64.bin"
+
+DESCRIPTION="Sun's J2SE Development Kit, version ${PV}"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
+ amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="nostrip"
+IUSE="X alsa doc examples jce nsplugin"
+
+QA_TEXTRELS_x86="opt/${P}/jre/lib/i386/motif21/libmawt.so opt/${P}/jre/lib/i386/libdeploy.so"
+
+DEPEND="
+ doc? ( =dev-java/java-sdk-docs-1.5.0* )
+ jce? ( =dev-java/sun-jce-bin-1.5.0* )"
+
+RDEPEND="
+ sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ doc? ( =dev-java/java-sdk-docs-1.5.0* )
+ X? ( || ( ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXt
+ x11-libs/libXtst
+ )
+ virtual/x11
+ )
+ )"
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+PACKED_JARS="lib/tools.jar jre/lib/rt.jar jre/lib/jsse.jar jre/lib/charsets.jar jre/lib/ext/localedata.jar jre/lib/plugin.jar jre/lib/javaws.jar jre/lib/deploy.jar"
+
+src_unpack() {
+ if [ ! -r "${DISTDIR}/${A}" ]; then
+ die "cannot read ${A}. Please check the permission and try again."
+ fi
+
+ sh "${DISTDIR}/${A}" --accept-license --unpack || die "Failed to unpack"
+}
+
+src_install() {
+ local dirs="bin include jre lib man"
+
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler.
+ pax-mark m $(list-paxables ${S}{,/jre}/bin/*)
+
+ dodir /opt/${P}
+
+ for i in $dirs ; do
+ cp -pPR $i ${D}/opt/${P}/ || die "failed to copy"
+ done
+ dodoc COPYRIGHT README.html || die
+ dohtml README.html || die
+ dodir /opt/${P}/share/
+
+ cp -pPR src.zip ${D}/opt/${P}/share/ || die
+
+ if use examples; then
+ cp -pPR demo ${D}/opt/${P}/share/
+ if ( use x86 || use amd64 ); then
+ cp -pPR sample ${D}/opt/${P}/share/
+ fi
+ fi
+
+ if use jce; then
+ cd ${D}/opt/${P}/jre/lib/security || die
+ dodir /opt/${P}/jre/lib/security/strong-jce
+ mv ${D}/opt/${P}/jre/lib/security/US_export_policy.jar \
+ ${D}/opt/${P}/jre/lib/security/strong-jce || die
+ mv ${D}/opt/${P}/jre/lib/security/local_policy.jar \
+ ${D}/opt/${P}/jre/lib/security/strong-jce || die
+ local jcedir="/opt/sun-jce-bin-1.5.0/jre/lib/security/unlimited-jce/"
+ dosym ${jcedir}/US_export_policy.jar \
+ /opt/${P}/jre/lib/security/ || die
+ dosym ${jcedir}/local_policy.jar \
+ /opt/${P}/jre/lib/security/ || die
+ fi
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # create dir for system preferences
+ dodir /opt/${P}/jre/.systemPrefs
+ # Create files used as storage for system preferences.
+ touch ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ touch ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+ chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+
+ # install control panel for Gnome/KDE
+ sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+ -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+ ${D}/opt/${P}/jre/plugin/desktop/sun_java.desktop > \
+ ${T}/sun_java-${SLOT}.desktop \
+ || die "Failed to sed .desktop file"
+
+ domenu ${T}/sun_java-${SLOT}.desktop
+
+ # bug #56444
+ insinto /opt/${P}/jre/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ local xwarn="virtual/x11 and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+
+ echo
+ elog " Be careful: ${P}'s Java compiler uses"
+ elog " '-source 1.5' as default. Some keywords such as 'enum'"
+ elog " are not valid identifiers any more in that mode,"
+ elog " which can cause incompatibility with certain sources."
+
+ echo
+ elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+}