summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-10-18 20:22:25 +0000
committerAron Griffis <agriffis@gentoo.org>2005-10-18 20:22:25 +0000
commit924360744b63bc47157cd1a51863e4bba01fdb61 (patch)
treec61b3d8577718393a883c78adc6e398d76a4f357 /dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild
parentadd back browserplugin, marked as deprecated (diff)
downloadgentoo-2-924360744b63bc47157cd1a51863e4bba01fdb61.tar.gz
gentoo-2-924360744b63bc47157cd1a51863e4bba01fdb61.tar.bz2
gentoo-2-924360744b63bc47157cd1a51863e4bba01fdb61.zip
Warn about deprecated browserplugin useflag
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild')
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild
index 3d1eda1fb4a1..9a06b2677a96 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild,v 1.2 2005/10/18 19:20:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.05.ebuild,v 1.3 2005/10/18 20:22:25 agriffis Exp $
inherit java eutils
@@ -24,7 +24,7 @@ SLOT="1.5"
LICENSE="sun-bcla-java-vm"
KEYWORDS="~x86 ~amd64 -*"
RESTRICT="fetch"
-IUSE="nsplugin mozilla"
+IUSE="browserplugin nsplugin mozilla"
DEPEND=">=dev-java/java-config-1.2
sys-apps/sed"
@@ -105,7 +105,9 @@ src_install() {
dodoc COPYRIGHT LICENSE README
dohtml Welcome.html
- if use nsplugin || use mozilla; then
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
local plugin_dir="ns7-gcc29"
if has_version '>=sys-devel/gcc-3' ; then
plugin_dir="ns7"
@@ -148,7 +150,14 @@ pkg_postinst() {
# Set as default VM if none exists
java_pkg_postinst
- #Show info about netscape
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
+ fi
+
+ # Show info about netscape
if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
echo
einfo "If you want to install the plugin for Netscape 4.x, type"
@@ -183,10 +192,4 @@ pkg_postinst() {
echo
eerror "Some parts of Sun's JRE require virtual/x11 and virtual/lpr to be installed."
eerror "Be careful which Java libraries you attempt to use."
-
- if ! use nsplugin && use mozilla; then
- ewarn
- ewarn "The 'mozilla' useflag to enable the java browser plugin for applets"
- ewarn "has been renamed to 'nsplugin' please update your USE."
- fi
}