summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-17 11:19:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-17 11:19:53 +0000
commit7bc7ba9fc999b1f28901413a77436619bc79827b (patch)
tree01752381c5ecebf7890f18ca234309338246ca87 /dev-java/swt
parentRemove has_version check for dev-java/swt[xulrunner] wrt #409301. Correct elo... (diff)
downloadgentoo-2-7bc7ba9fc999b1f28901413a77436619bc79827b.tar.gz
gentoo-2-7bc7ba9fc999b1f28901413a77436619bc79827b.tar.bz2
gentoo-2-7bc7ba9fc999b1f28901413a77436619bc79827b.zip
Remove obsolete USE="xulrunner" and net-libs/xulrunner dependency since nothing is using it in tree and 3.7.x series has webkit replacement wrt #409299
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/swt')
-rw-r--r--dev-java/swt/ChangeLog8
-rw-r--r--dev-java/swt/metadata.xml1
-rw-r--r--dev-java/swt/swt-3.4-r4.ebuild42
-rw-r--r--dev-java/swt/swt-3.5.2.ebuild42
-rw-r--r--dev-java/swt/swt-3.6.1.ebuild42
5 files changed, 16 insertions, 119 deletions
diff --git a/dev-java/swt/ChangeLog b/dev-java/swt/ChangeLog
index 792cc67d2229..6f8f0786bca3 100644
--- a/dev-java/swt/ChangeLog
+++ b/dev-java/swt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/swt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.139 2012/03/03 22:10:27 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.140 2012/04/17 11:19:53 ssuominen Exp $
+
+ 17 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> swt-3.4-r4.ebuild,
+ swt-3.5.2.ebuild, swt-3.6.1.ebuild, metadata.xml:
+ Remove obsolete USE="xulrunner" and net-libs/xulrunner dependency since
+ nothing is using it in tree and 3.7.x series has webkit replacement wrt
+ #409299
*swt-3.7.2 (03 Mar 2012)
diff --git a/dev-java/swt/metadata.xml b/dev-java/swt/metadata.xml
index 27284507b924..2e5728b03433 100644
--- a/dev-java/swt/metadata.xml
+++ b/dev-java/swt/metadata.xml
@@ -9,6 +9,5 @@
</longdescription>
<use>
<flag name="webkit">Embedded browser support via net-libs/webkit-gtk:2, replacing former xulrunner-based browser.</flag>
- <flag name="xulrunner">Embedded browser support via xulrunner-1.9 (1.8 for swt-3.3). Xulrunner 2.0 is not supported, will be replaced by webkit in 3.7.</flag>
</use>
</pkgmetadata>
diff --git a/dev-java/swt/swt-3.4-r4.ebuild b/dev-java/swt/swt-3.4-r4.ebuild
index 48b453b0d695..e756061b9af6 100644
--- a/dev-java/swt/swt-3.4-r4.ebuild
+++ b/dev-java/swt/swt-3.4-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.4-r4.ebuild,v 1.9 2011/03/29 09:17:56 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.4-r4.ebuild,v 1.10 2012/04/17 11:19:53 ssuominen Exp $
EAPI="1"
@@ -32,7 +32,7 @@ SLOT="3.4"
LICENSE="CPL-1.0 LGPL-2.1 MPL-1.1"
KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="cairo gnome opengl xulrunner"
+IUSE="cairo gnome opengl"
COMMON=">=dev-libs/glib-2.6
>=x11-libs/gtk+-2.6.8:2
>=dev-libs/atk-1.10.2
@@ -42,7 +42,6 @@ COMMON=">=dev-libs/glib-2.6
=gnome-base/gnome-vfs-2*
=gnome-base/libgnomeui-2*
)
- xulrunner? ( net-libs/xulrunner:1.9 )
opengl? (
virtual/opengl
virtual/glu
@@ -148,28 +147,6 @@ src_compile() {
${make} make_gnome || die "Failed to build GNOME VFS support"
fi
- if use xulrunner ; then
- einfo "Building the Mozilla component against xulrunner-1.9"
-
- export MOZILLA_INCLUDES="$(pkg-config --cflags libxul libxul-embedding)"
- # the -R is a workaround for bug #234934
- export MOZILLA_LIBS="-Wl,-R$(pkg-config libxul --variable=sdkdir) $(pkg-config --libs libxul libxul-embedding)"
-
- ${make} make_mozilla || die "Failed to build Mozilla support"
-
- # upstream ships libswt-xulrunner*.so even though the build.sh does not
- # build it anymore... missing this file leads to another instance
- # of bug #234934 so we build it too
- einfo "Building the xulrunner component against xulrunner-1.9"
-
- export XULRUNNER_INCLUDES="${MOZILLA_INCLUDES}"
- export XULRUNNER_LIBS="${MOZILLA_LIBS}"
-
- ${make} make_xulrunner || die "Failed to build xulrunner support"
-
- ${make} make_xpcominit || die "Failed to build xpcominit support"
- fi
-
if use cairo ; then
einfo "Building CAIRO support"
${make} make_cairo || die "Unable to build CAIRO support"
@@ -203,18 +180,5 @@ src_install() {
java-pkg_sointo /usr/$(get_libdir)
java-pkg_doso *.so
- if use xulrunner; then
- local gecko_dir="$(pkg-config libxul --variable=sdkdir)"
- java-pkg_register-environment-variable MOZILLA_FIVE_HOME "${gecko_dir}"
- fi
-
dohtml about.html || die
}
-
-pkg_postinst() {
- if use xulrunner; then
- local gecko_dir="$(pkg-config libxul --variable=sdkdir)"
- elog "You built swt with xulrunner support. For your custom applications please set"
- elog "MOZILLA_FIVE_HOME environment variable to ${gecko_dir}"
- fi
-}
diff --git a/dev-java/swt/swt-3.5.2.ebuild b/dev-java/swt/swt-3.5.2.ebuild
index 82e9eb64cb56..0bdac2c61bf1 100644
--- a/dev-java/swt/swt-3.5.2.ebuild
+++ b/dev-java/swt/swt-3.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.5.2.ebuild,v 1.7 2011/03/29 09:17:56 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.5.2.ebuild,v 1.8 2012/04/17 11:19:53 ssuominen Exp $
EAPI=2
@@ -32,7 +32,7 @@ SLOT="3.5"
LICENSE="CPL-1.0 LGPL-2.1 MPL-1.1"
KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="cairo gnome opengl xulrunner"
+IUSE="cairo gnome opengl"
COMMON=">=dev-libs/glib-2.6
>=x11-libs/gtk+-2.6.8:2
>=dev-libs/atk-1.10.2
@@ -42,7 +42,6 @@ COMMON=">=dev-libs/glib-2.6
=gnome-base/gnome-vfs-2*
=gnome-base/libgnomeui-2*
)
- xulrunner? ( =net-libs/xulrunner-1.9* )
opengl? (
virtual/opengl
virtual/glu
@@ -139,28 +138,6 @@ src_compile() {
${make} make_gnome || die "Failed to build GNOME VFS support"
fi
- if use xulrunner ; then
- einfo "Building the Mozilla component against xulrunner-1.9"
-
- export MOZILLA_INCLUDES="$(pkg-config --cflags libxul libxul-embedding)"
- # the -R is a workaround for bug #234934
- export MOZILLA_LIBS="-Wl,-R$(pkg-config libxul --variable=sdkdir) $(pkg-config --libs libxul libxul-embedding)"
-
- ${make} make_mozilla || die "Failed to build Mozilla support"
-
- # upstream ships libswt-xulrunner*.so even though the build.sh does not
- # build it anymore... missing this file leads to another instance
- # of bug #234934 so we build it too
- einfo "Building the xulrunner component against xulrunner-1.9"
-
- export XULRUNNER_INCLUDES="${MOZILLA_INCLUDES}"
- export XULRUNNER_LIBS="${MOZILLA_LIBS}"
-
- ${make} make_xulrunner || die "Failed to build xulrunner support"
-
- ${make} make_xpcominit || die "Failed to build xpcominit support"
- fi
-
if use cairo ; then
einfo "Building CAIRO support"
${make} make_cairo || die "Unable to build CAIRO support"
@@ -194,18 +171,5 @@ src_install() {
java-pkg_sointo /usr/$(get_libdir)
java-pkg_doso *.so
- if use xulrunner; then
- local gecko_dir="$(pkg-config libxul --variable=sdkdir)"
- java-pkg_register-environment-variable MOZILLA_FIVE_HOME "${gecko_dir}"
- fi
-
dohtml about.html || die
}
-
-pkg_postinst() {
- if use xulrunner; then
- local gecko_dir="$(pkg-config libxul --variable=sdkdir)"
- elog "You built swt with xulrunner support. For your custom applications please set"
- elog "MOZILLA_FIVE_HOME environment variable to ${gecko_dir}"
- fi
-}
diff --git a/dev-java/swt/swt-3.6.1.ebuild b/dev-java/swt/swt-3.6.1.ebuild
index c63611a4bf77..5bce3f43f606 100644
--- a/dev-java/swt/swt-3.6.1.ebuild
+++ b/dev-java/swt/swt-3.6.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.6.1.ebuild,v 1.7 2011/03/29 09:17:56 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.6.1.ebuild,v 1.8 2012/04/17 11:19:53 ssuominen Exp $
EAPI=2
@@ -32,7 +32,7 @@ SLOT="3.6"
LICENSE="CPL-1.0 LGPL-2.1 MPL-1.1"
KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="cairo gnome opengl xulrunner"
+IUSE="cairo gnome opengl"
COMMON=">=dev-libs/glib-2.6
>=x11-libs/gtk+-2.6.8:2
>=dev-libs/atk-1.10.2
@@ -42,7 +42,6 @@ COMMON=">=dev-libs/glib-2.6
=gnome-base/gnome-vfs-2*
=gnome-base/libgnomeui-2*
)
- xulrunner? ( =net-libs/xulrunner-1.9* )
opengl? (
virtual/opengl
virtual/glu
@@ -139,28 +138,6 @@ src_compile() {
${make} make_gnome || die "Failed to build GNOME VFS support"
fi
- if use xulrunner ; then
- einfo "Building the Mozilla component against xulrunner-1.9"
-
- export MOZILLA_INCLUDES="$(pkg-config --cflags libxul libxul-embedding)"
- # the -R is a workaround for bug #234934
- export MOZILLA_LIBS="-Wl,-R$(pkg-config libxul --variable=sdkdir) $(pkg-config --libs libxul libxul-embedding)"
-
- ${make} make_mozilla || die "Failed to build Mozilla support"
-
- # upstream ships libswt-xulrunner*.so even though the build.sh does not
- # build it anymore... missing this file leads to another instance
- # of bug #234934 so we build it too
- einfo "Building the xulrunner component against xulrunner-1.9"
-
- export XULRUNNER_INCLUDES="${MOZILLA_INCLUDES}"
- export XULRUNNER_LIBS="${MOZILLA_LIBS}"
-
- ${make} make_xulrunner || die "Failed to build xulrunner support"
-
- ${make} make_xpcominit || die "Failed to build xpcominit support"
- fi
-
if use cairo ; then
einfo "Building CAIRO support"
${make} make_cairo || die "Unable to build CAIRO support"
@@ -194,18 +171,5 @@ src_install() {
java-pkg_sointo /usr/$(get_libdir)
java-pkg_doso *.so
- if use xulrunner; then
- local gecko_dir="$(pkg-config libxul --variable=sdkdir)"
- java-pkg_register-environment-variable MOZILLA_FIVE_HOME "${gecko_dir}"
- fi
-
dohtml about.html || die
}
-
-pkg_postinst() {
- if use xulrunner; then
- local gecko_dir="$(pkg-config libxul --variable=sdkdir)"
- elog "You built swt with xulrunner support. For your custom applications please set"
- elog "MOZILLA_FIVE_HOME environment variable to ${gecko_dir}"
- fi
-}