summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-03-22 01:41:00 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-03-22 01:41:00 +0000
commit265f80c9e06d488872fdd8787eeecac6e769bacc (patch)
tree5f43c95d96c483b2f3616a2b6c2b61cb60b6db63 /dev-java/tagunit
parentInstall auth-agent. Fixes bug #213884. (diff)
downloadgentoo-2-265f80c9e06d488872fdd8787eeecac6e769bacc.tar.gz
gentoo-2-265f80c9e06d488872fdd8787eeecac6e769bacc.tar.bz2
gentoo-2-265f80c9e06d488872fdd8787eeecac6e769bacc.zip
Use java-virtual/servlet-api:2.4 and prepare for generic src_test.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-java/tagunit')
-rw-r--r--dev-java/tagunit/ChangeLog10
-rw-r--r--dev-java/tagunit/tagunit-1.0.1-r2.ebuild52
2 files changed, 60 insertions, 2 deletions
diff --git a/dev-java/tagunit/ChangeLog b/dev-java/tagunit/ChangeLog
index ac6fc943e7a8..54e02c47e96f 100644
--- a/dev-java/tagunit/ChangeLog
+++ b/dev-java/tagunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tagunit
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/ChangeLog,v 1.16 2007/05/03 15:46:58 caster Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/ChangeLog,v 1.17 2008/03/22 01:41:00 betelgeuse Exp $
+
+*tagunit-1.0.1-r2 (22 Mar 2008)
+
+ 22 Mar 2008; Petteri Räty <betelgeuse@gentoo.org>
+ +tagunit-1.0.1-r2.ebuild:
+ Use java-virtual/servlet-api:2.4 and prepare for generic src_test.
03 May 2007; Vlastimil Babka <caster@gentoo.org> -tagunit-1.0.1.ebuild:
Gen-1 punt.
diff --git a/dev-java/tagunit/tagunit-1.0.1-r2.ebuild b/dev-java/tagunit/tagunit-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..86ffc153b843
--- /dev/null
+++ b/dev-java/tagunit/tagunit-1.0.1-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/tagunit-1.0.1-r2.ebuild,v 1.1 2008/03/22 01:41:00 betelgeuse Exp $
+
+EAPI=1
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="TagUnit is a tag library for testing custom tags within JSP pages."
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+HOMEPAGE="http://www.tagunit.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEP="
+ java-virtuals/servlet-api:2.4
+ >=dev-java/ant-core-1.6"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+DEPEND="=virtual/jdk-1.4*
+ ${COMMON_DEP}
+ test? ( dev-java/ant-junit:0 )
+ app-arch/unzip"
+
+S="${WORKDIR}/${P}-src/tagunit-core"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ echo ${PV} > ../version.txt
+ mkdir ../lib || die
+ cd ../lib || die
+ java-pkg_jar-from ant-core
+ java-pkg_jar-from --virtual servlet-api-2.4
+}
+
+EANT_BUILD_TARGET="build"
+EANT_TEST_JUNIT_INTO="../lib"
+
+src_install() {
+ java-pkg_dojar lib/${PN}.jar
+ cd "${S}/.."
+ dodoc changes.txt readme.txt || die
+ use doc && java-pkg_dojavadoc tagunit-core/doc/api
+ use source && java-pkg_dosrc tagunit-core/src/*
+}