summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-02-11 12:01:12 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-02-11 12:01:12 +0000
commit21961a8785b323706a896d9078a50dba4a4a2de9 (patch)
treeef8716b8e75b230c142b55575466acd190968fa2 /dev-java
parentAdded ip30 to the mips 2007.0 profile. (diff)
downloadgentoo-2-21961a8785b323706a896d9078a50dba4a4a2de9.tar.gz
gentoo-2-21961a8785b323706a896d9078a50dba4a4a2de9.tar.bz2
gentoo-2-21961a8785b323706a896d9078a50dba4a4a2de9.zip
Version bump for bug #166305.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog8
-rw-r--r--dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.116
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.11.ebuild134
3 files changed, 147 insertions, 1 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index 00c158cf9cbf..c9722583b2c5 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.78 2007/01/23 11:37:49 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.79 2007/02/11 12:01:12 betelgeuse Exp $
+
+*sun-jre-bin-1.5.0.11 (11 Feb 2007)
+
+ 11 Feb 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +sun-jre-bin-1.5.0.11.ebuild:
+ Version bump for bug #166305.
23 Jan 2007; Vlastimil Babka <caster@gentoo.org> files/construct-1.6.sh,
files/construct.sh, -sun-jre-bin-1.5.0.09.ebuild,
diff --git a/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.11 b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.11
new file mode 100644
index 000000000000..e6f312fcc9a8
--- /dev/null
+++ b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.11
@@ -0,0 +1,6 @@
+MD5 ace2fc1b8c9d381b4e297c66c5a9caa7 jdk-1_5_0_11-dlj-linux-amd64.bin 43954177
+RMD160 bd865019d3fb2268800696207dba158ea2986a7f jdk-1_5_0_11-dlj-linux-amd64.bin 43954177
+SHA256 98df66902f42f764cb89b12a1502b976f2e5ddb2aa5000e14846b90cef74e0db jdk-1_5_0_11-dlj-linux-amd64.bin 43954177
+MD5 9dfdad6a166ed403513c0a5509d82e4b jdk-1_5_0_11-dlj-linux-i586.bin 49598681
+RMD160 74c5bd78450397006ea145580c3554d77b64a31d jdk-1_5_0_11-dlj-linux-i586.bin 49598681
+SHA256 da7c0217c1c6d47aad77a8b5ca0b30b01846c8090d5b1d5907862ef7122a1705 jdk-1_5_0_11-dlj-linux-i586.bin 49598681
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.11.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.11.ebuild
new file mode 100644
index 000000000000..6805eccf564d
--- /dev/null
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.11.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.11.ebuild,v 1.1 2007/02/11 12:01:12 betelgeuse Exp $
+
+inherit pax-utils eutils java-vm-2
+
+MY_PVL=${PV%.*}_${PV##*.}
+MY_PVA=${PV//./_}
+#S="${WORKDIR}/jdk${MY_PVL}"
+
+X86_AT="jdk-${MY_PVA}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PVA}-dlj-linux-amd64.bin"
+
+DESCRIPTION="Sun's J2SE Development Kit, version ${PV}"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
+ amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="nostrip"
+IUSE="X alsa nsplugin"
+
+RDEPEND="
+ sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXt
+ x11-libs/libXtst
+ )"
+
+DEPEND=""
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+PACKED_JARS="lib/rt.jar lib/jsse.jar lib/charsets.jar lib/ext/localedata.jar lib/plugin.jar lib/javaws.jar lib/deploy.jar"
+
+QA_TEXTRELS_x86="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so"
+
+src_unpack() {
+ if [ ! -r ${DISTDIR}/${A} ]; then
+ die "cannot read ${A}. Please check the permission and try again."
+ fi
+
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh "${DISTDIR}/${A}" --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash ${FILESDIR}/construct.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_install() {
+ local dirs="bin lib man"
+
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler.
+ pax-mark m $(list-paxables ${S}/bin/*)
+
+ # only X86 has the plugin and javaws
+ use x86 && dirs="${dirs} javaws plugin"
+ dodir /opt/${P}
+
+ for i in $dirs ; do
+ cp -pPR $i ${D}/opt/${P}/ || die "failed to copy"
+ done
+ dodoc CHANGES README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+ dodir /opt/${P}/share/
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # TODO Don't think we still needs these -nichoj
+ # create dir for system preferences
+ #dodir /opt/${P}/jre/.systemPrefs
+ # Create files used as storage for system preferences.
+ #touch ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ #chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ #touch ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+ #chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ # bug #56444
+ insinto /opt/${P}/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties \
+ fontconfig.properties || die
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ local xwarn="virtual/x11 and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+
+ echo
+ elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+}