summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2009-01-31 14:27:13 +0000
committerSerkan Kaba <serkan@gentoo.org>2009-01-31 14:27:13 +0000
commit5a6396e9bfe9f3764f11d4f1acf83cb837c790f5 (patch)
tree2c0e35a0048f4521a04b386f753fd3634eb99eac /dev-java
parentVersion bump. (diff)
downloadgentoo-2-5a6396e9bfe9f3764f11d4f1acf83cb837c790f5.tar.gz
gentoo-2-5a6396e9bfe9f3764f11d4f1acf83cb837c790f5.tar.bz2
gentoo-2-5a6396e9bfe9f3764f11d4f1acf83cb837c790f5.zip
Revbump to avoid bundling of unit tests in the jar. Migrate to EAPI 1.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jflex/ChangeLog11
-rw-r--r--dev-java/jflex/files/jflex-1.4.1-build.xml.patch14
-rw-r--r--dev-java/jflex/jflex-1.4.1-r1.ebuild (renamed from dev-java/jflex/jflex-1.4.1.ebuild)11
3 files changed, 27 insertions, 9 deletions
diff --git a/dev-java/jflex/ChangeLog b/dev-java/jflex/ChangeLog
index 631fb10678fe..bc035f5b8c13 100644
--- a/dev-java/jflex/ChangeLog
+++ b/dev-java/jflex/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jflex
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/ChangeLog,v 1.3 2008/01/10 22:34:32 caster Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/ChangeLog,v 1.4 2009/01/31 14:27:08 serkan Exp $
+
+*jflex-1.4.1-r1 (31 Jan 2009)
+
+ 31 Jan 2009; Serkan Kaba <serkan@gentoo.org>
+ files/jflex-1.4.1-build.xml.patch, -jflex-1.4.1.ebuild,
+ +jflex-1.4.1-r1.ebuild:
+ Revbump to avoid bundling of unit tests in the jar. Migrate to EAPI 1.
10 Jan 2008; Vlastimil Babka <caster@gentoo.org> jflex-1.4.1.ebuild:
Restrict junit dependency.
diff --git a/dev-java/jflex/files/jflex-1.4.1-build.xml.patch b/dev-java/jflex/files/jflex-1.4.1-build.xml.patch
index 36cf85cb47f2..8353cbe52a76 100644
--- a/dev-java/jflex/files/jflex-1.4.1-build.xml.patch
+++ b/dev-java/jflex/files/jflex-1.4.1-build.xml.patch
@@ -1,5 +1,5 @@
---- build.xml 2007-05-21 17:01:26.000000000 +0200
-+++ build-neww.xml 2007-05-21 17:02:02.000000000 +0200
+--- build.xml 2009-01-31 16:14:57.000000000 +0200
++++ build.xml.fixed 2009-01-31 16:17:14.000000000 +0200
@@ -35,7 +35,7 @@
<target name="declare" description="define tasks for jflex and cup">
@@ -18,3 +18,13 @@
</target>
<target name="copy" description="copy resources to build dir">
+@@ -79,7 +79,8 @@
+
+ <target name="jar" depends="compile,copy" description="make JFlex.jar">
+ <jar basedir="../lib"
+- includes="JFlex/**,java_cup/**,skeleton"
++ includes="JFlex/**,java_cup/**,skeleton"
++ excludes="JFlex/tests/*"
+ jarfile="../lib/JFlex.jar"
+ manifest="manifest"/>
+ </target>
diff --git a/dev-java/jflex/jflex-1.4.1.ebuild b/dev-java/jflex/jflex-1.4.1-r1.ebuild
index 99170f34c87c..23cb48a0b2cc 100644
--- a/dev-java/jflex/jflex-1.4.1.ebuild
+++ b/dev-java/jflex/jflex-1.4.1-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/jflex-1.4.1.ebuild,v 1.2 2008/01/10 22:34:32 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jflex/jflex-1.4.1-r1.ebuild,v 1.1 2009/01/31 14:27:08 serkan Exp $
# Currently, this package uses an included JFlex.jar file to bootstrap.
# Upstream was contacted and this bootstrap is really needed. The only way to avoid it would be to use a supplied pre-compiled .scanner file.
+EAPI="1"
JAVA_PKG_IUSE="source"
inherit java-pkg-2 java-ant-2
@@ -18,11 +19,11 @@ KEYWORDS="~x86 ~amd64"
RDEPEND=">=virtual/jre-1.4
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
>=dev-java/ant-core-1.7.0
- >=dev-java/javacup-0.11a_beta20060608"
+ >=dev-java/javacup-0.11a_beta20060608:0"
DEPEND=">=virtual/jdk-1.4
- =dev-java/junit-3.8*
- >=dev-java/javacup-0.11a_beta20060608"
+ dev-java/junit:0
+ >=dev-java/javacup-0.11a_beta20060608:0"
IUSE="doc source vim-syntax"