summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-03-08 17:56:16 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-03-08 17:56:16 +0000
commit6cefd2b45555cb60a620a3536811073054a04f88 (patch)
tree54c485da2d66d8b362c7f4fc46294efce5e49698 /dev-java
parentRevision bump. EAPI 5. (diff)
downloadgentoo-2-6cefd2b45555cb60a620a3536811073054a04f88.tar.gz
gentoo-2-6cefd2b45555cb60a620a3536811073054a04f88.tar.bz2
gentoo-2-6cefd2b45555cb60a620a3536811073054a04f88.zip
Revision bump. EAPI 5.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-attributes/ChangeLog11
-rw-r--r--dev-java/commons-attributes/commons-attributes-2.2-r2.ebuild (renamed from dev-java/commons-attributes/commons-attributes-2.2-r1.ebuild)25
-rw-r--r--dev-java/commons-attributes/commons-attributes-2.2.ebuild50
3 files changed, 22 insertions, 64 deletions
diff --git a/dev-java/commons-attributes/ChangeLog b/dev-java/commons-attributes/ChangeLog
index fa7220d0571c..b98c59e87977 100644
--- a/dev-java/commons-attributes/ChangeLog
+++ b/dev-java/commons-attributes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-attributes
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/ChangeLog,v 1.13 2008/04/13 14:35:48 maekke Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/ChangeLog,v 1.14 2014/03/08 17:56:16 tomwij Exp $
+
+*commons-attributes-2.2-r2 (08 Mar 2014)
+
+ 08 Mar 2014; Tom Wijsman <TomWij@gentoo.org>
+ +commons-attributes-2.2-r2.ebuild:
+ Revision bump. EAPI 5.
13 Apr 2008; Markus Meier <maekke@gentoo.org>
commons-attributes-2.2-r1.ebuild:
@@ -66,4 +72,3 @@
+files/commons-attributes-2.1-gentoo.patch, +files/anttasks.properties,
+metadata.xml, +commons-attributes-2.1.ebuild:
Initial commit (bug #97008).
-
diff --git a/dev-java/commons-attributes/commons-attributes-2.2-r1.ebuild b/dev-java/commons-attributes/commons-attributes-2.2-r2.ebuild
index c697b5d1801f..fa1617a4e28d 100644
--- a/dev-java/commons-attributes/commons-attributes-2.2-r1.ebuild
+++ b/dev-java/commons-attributes/commons-attributes-2.2-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/commons-attributes-2.2-r1.ebuild,v 1.3 2008/04/13 14:35:48 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/commons-attributes-2.2-r2.ebuild,v 1.1 2014/03/08 17:56:16 tomwij Exp $
+
+EAPI="5"
-EAPI=1
JAVA_PKG_IUSE="doc source"
inherit eutils java-pkg-2 java-ant-2
@@ -14,14 +15,15 @@ SRC_URI="mirror://apache/commons/attributes/source/${P}-src.tar.gz"
LICENSE="Apache-2.0"
SLOT="2"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-COMMON_DEP="dev-java/xjavadoc
- dev-java/gjdoc
- dev-java/ant-core
- dev-java/qdox:1.6"
+COMMON_DEP="dev-java/ant-core:0
+ dev-java/gjdoc:0
+ dev-java/qdox:1.6
+ dev-java/xjavadoc:0"
+
DEPEND=">=virtual/jdk-1.4
${COMMON_DEP}"
+
RDEPEND=">=virtual/jre-1.4
${COMMON_DEP}"
@@ -30,7 +32,8 @@ EANT_GENTOO_CLASSPATH="ant-core,gjdoc,qdox-1.6"
src_compile() {
java-pkg-2_src_compile
- # the generated build.xml is faulty
+
+ # The generated build.xml is faulty.
jar uf target/${PN}-compiler-${PV}.jar -C compiler/src/java \
org/apache/commons/attributes/anttasks.properties || die
}
@@ -41,8 +44,8 @@ src_install() {
java-pkg_register-ant-task
- dodoc NOTICE.txt || die
- dohtml README.html || die
+ dodoc NOTICE.txt
+ dohtml README.html
use doc && java-pkg_dojavadoc dist/docs/api
use source && java-pkg_dosrc api/src/java/org compiler/src/java/org
diff --git a/dev-java/commons-attributes/commons-attributes-2.2.ebuild b/dev-java/commons-attributes/commons-attributes-2.2.ebuild
deleted file mode 100644
index 23725e420c08..000000000000
--- a/dev-java/commons-attributes/commons-attributes-2.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/commons-attributes-2.2.ebuild,v 1.2 2008/04/05 00:37:20 betelgeuse Exp $
-
-EAPI=1
-JAVA_PKG_IUSE="doc source"
-
-inherit eutils java-pkg-2 java-ant-2
-
-DESCRIPTION="Commons Attributes enables Java programmers to use C#/.Net-style attributes in their code."
-HOMEPAGE="http://commons.apache.org/attributes/"
-SRC_URI="mirror://apache/commons/attributes/source/${P}-src.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-COMMON_DEP="dev-java/xjavadoc
- dev-java/gjdoc
- dev-java/ant-core
- dev-java/qdox:1.6"
-DEPEND=">=virtual/jdk-1.4
- ${COMMON_DEP}"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEP}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- mkdir -p target/lib
- cd target/lib
- java-pkg_jar-from ant-core ant.jar
- java-pkg_jar-from gjdoc
- java-pkg_jar-from qdox-1.6
-}
-
-src_install() {
- java-pkg_newjar target/${PN}-api-${PV}.jar ${PN}-api.jar
- java-pkg_newjar target/${PN}-compiler-${PV}.jar ${PN}-compiler.jar
-
- java-pkg_register-ant-task
-
- dodoc NOTICE.txt || die
- dohtml README.html || die
-
- use doc && java-pkg_dojavadoc dist/docs/api
- use source && java-pkg_dosrc api/src/java/org compiler/src/java/org
-}