summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2003-03-17 21:06:09 +0000
committerDylan Carlson <absinthe@gentoo.org>2003-03-17 21:06:09 +0000
commit74c3eb59ca544f9b3583ef69b4df0778e67ce767 (patch)
tree42034f18c88ffc8546a39da2c00556b38e462abf /dev-java
parentjava commons eclass imported from bug #17350, with several fixes/changes. (diff)
downloadgentoo-2-74c3eb59ca544f9b3583ef69b4df0778e67ce767.tar.gz
gentoo-2-74c3eb59ca544f9b3583ef69b4df0778e67ce767.tar.bz2
gentoo-2-74c3eb59ca544f9b3583ef69b4df0778e67ce767.zip
masked for testing. now makes use of the new 'java-commons' eclass.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-cli/ChangeLog13
-rw-r--r--dev-java/commons-cli/commons-cli-1.0-r2.ebuild24
-rw-r--r--dev-java/commons-cli/files/digest-commons-cli-1.0-r21
3 files changed, 37 insertions, 1 deletions
diff --git a/dev-java/commons-cli/ChangeLog b/dev-java/commons-cli/ChangeLog
index 56907eb0d6bd..133303079ec7 100644
--- a/dev-java/commons-cli/ChangeLog
+++ b/dev-java/commons-cli/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-java/commons-cli
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/ChangeLog,v 1.2 2003/03/17 02:04:58 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/ChangeLog,v 1.3 2003/03/17 21:06:09 absinthe Exp $
+
+*commons-cli-1.0-r2 (17 Mar 2003)
+
+ 17 Mar 2003; Dylan Carlson <absinthe@gentoo.org> commons-cli-1.0-r2.ebuild:
+ Changes to utilize new 'java-commons' eclass initiated by Lim Swee Tat
+ <st_lim@stlim.net> in bug # 17350. Fixed up the eclass and added 'makedoc'
+ target to java-commons_src_compile() for the 'doc' use flag, and updated the
+ ebuild accordingly.
+
+ If you want the API documentation installed, add 'doc' to your USE flags, or
+ run: 'USE="doc" emerge foo.ebuild'
*commons-cli-1.0-r1 (16 Mar 2003)
diff --git a/dev-java/commons-cli/commons-cli-1.0-r2.ebuild b/dev-java/commons-cli/commons-cli-1.0-r2.ebuild
new file mode 100644
index 000000000000..97c5555d82cb
--- /dev/null
+++ b/dev-java/commons-cli/commons-cli-1.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/commons-cli-1.0-r2.ebuild,v 1.1 2003/03/17 21:06:09 absinthe Exp $
+
+inherit java-commons
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="The CLI library provides a simple and easy to use API for working with the command line arguments and options."
+HOMEPAGE="http://jakarta.apache.org/commons/logging.html"
+SRC_URI="http://www.apache.org/dist/jakarta/commons/cli/source/cli-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes junit"
+
+src_compile() {
+ patch -d ${S} -p0 < ${FILESDIR}/${PN}-${PV}-gentoo.diff || die "Could not correct version in build.xml"
+ java-commons_src_compile myconf make
+ use doc && java-commons_src_compile makedoc
+}
+
diff --git a/dev-java/commons-cli/files/digest-commons-cli-1.0-r2 b/dev-java/commons-cli/files/digest-commons-cli-1.0-r2
new file mode 100644
index 000000000000..9fa950d9ac6b
--- /dev/null
+++ b/dev-java/commons-cli/files/digest-commons-cli-1.0-r2
@@ -0,0 +1 @@
+MD5 ba34d585046b1f17dacbb13b377f4255 cli-1.0-src.tar.gz 37046