summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-07-12 21:08:46 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-07-12 21:08:46 +0000
commit7d902f25c36cb9ad39c66396f9fb8c83b6f30725 (patch)
treea117f7bd8c647297b3f86b6856fe565155aa11b6 /dev-java
parentVersion bump for bug #184407. (diff)
downloadgentoo-2-7d902f25c36cb9ad39c66396f9fb8c83b6f30725.tar.gz
gentoo-2-7d902f25c36cb9ad39c66396f9fb8c83b6f30725.tar.bz2
gentoo-2-7d902f25c36cb9ad39c66396f9fb8c83b6f30725.zip
Version bump for bug #184407.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog8
-rw-r--r--dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.6.0.026
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.6.0.02.ebuild127
3 files changed, 140 insertions, 1 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index ff47aa5a6ab6..192131d8a5ac 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.101 2007/07/02 18:57:09 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.102 2007/07/12 21:08:46 betelgeuse Exp $
+
+*sun-jre-bin-1.6.0.02 (12 Jul 2007)
+
+ 12 Jul 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +sun-jre-bin-1.6.0.02.ebuild:
+ Version bump for bug #184407.
02 Jul 2007; Christian Faulhammer <opfer@gentoo.org>
sun-jre-bin-1.4.2.15.ebuild:
diff --git a/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.6.0.02 b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.6.0.02
new file mode 100644
index 000000000000..97ee9bce8942
--- /dev/null
+++ b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.6.0.02
@@ -0,0 +1,6 @@
+MD5 fd1ccd16ec899bf189f327b206e801f1 jdk-6u2-dlj-linux-amd64.bin 51985841
+RMD160 a137169b04acf1e95a63490bd238c3c18c4c568d jdk-6u2-dlj-linux-amd64.bin 51985841
+SHA256 5a06581756e8e8076f00ec096f9ad02bcbd032cbaafcc3e1324de094a3aad7be jdk-6u2-dlj-linux-amd64.bin 51985841
+MD5 31fb431b22906344b4b0121e50bef84a jdk-6u2-dlj-linux-i586.bin 58408110
+RMD160 3b0c124693401ebc07dea50dfbf05bc9c2d47c28 jdk-6u2-dlj-linux-i586.bin 58408110
+SHA256 6d25968debfcac1397fb3dc36c505d0cce8f787f0fc135aab8d6a7d517df68c2 jdk-6u2-dlj-linux-i586.bin 58408110
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.02.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.02.ebuild
new file mode 100644
index 000000000000..ca1b93ec0348
--- /dev/null
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.02.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.02.ebuild,v 1.1 2007/07/12 21:08:46 betelgeuse Exp $
+
+inherit versionator pax-utils eutils java-vm-2
+
+UPDATE="$(get_version_component_range 4)"
+UPDATE="${UPDATE#0}"
+MY_PV="$(get_version_component_range 2)u${UPDATE}"
+
+SUFFIX=".bin"
+X86_AT="jdk-${MY_PV}-dlj-linux-i586${SUFFIX}"
+AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64${SUFFIX}"
+
+DESCRIPTION="Sun's J2SE Development Kit, version ${PV}"
+HOMEPAGE="http://java.sun.com/javase/6/"
+# This release is probably under a different url because tmarble is on holiday
+#SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
+# amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
+URL_BASE="http://dlc.sun.com/dlj/binaries"
+SRC_URI="x86? ( ${URL_BASE}/${X86_AT} )
+ amd64? ( ${URL_BASE}/${AMD64_AT} )"
+SLOT="1.6"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="strip"
+IUSE="X alsa nsplugin"
+
+RDEPEND="
+ sys-libs/glibc
+ x86? ( =virtual/libstdc++-3.3 )
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXtst
+ )"
+
+DEPEND=""
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+QA_TEXTRELS_x86="opt/${P}/lib/i386/client/libjvm.so
+ opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so
+ opt/${P}/lib/i386/server/libjvm.so"
+
+src_unpack() {
+ if [ ! -r ${DISTDIR}/${A} ]; then
+ die "cannot read ${A}. Please check the permission and try again."
+ fi
+
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh ${DISTDIR}/${A} --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash ${FILESDIR}/construct-1.6.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_install() {
+ local dirs="bin lib man"
+
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler.
+ pax-mark m $(list-paxables ${S}/bin/*)
+
+ # only X86 has the plugin and javaws
+ use x86 && dirs="${dirs} javaws plugin"
+ dodir /opt/${P}
+
+ cp -pPR $dirs "${D}/opt/${P}/" || die "failed to copy"
+
+ dodoc README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+ dodir /opt/${P}/share/
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # install control panel for Gnome/KDE
+ if [[ -e "${D}/opt/${P}/plugin/desktop/sun_java.desktop" ]]; then
+ sed -e "s/\(Name=Java\)/\1 Control Panel for Sun JRE ${SLOT}/" \
+ -e "s#Exec=.*#Exec=/opt/${P}/bin/ControlPanel#" \
+ -e "s#Icon=.*#Icon=/opt/${P}/plugin/desktop/sun_java.png#" \
+ ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+ ${T}/sun_jre-${SLOT}.desktop || die
+ domenu ${T}/sun_jre-${SLOT}.desktop || die
+ fi
+
+ # bug #56444
+ insinto /opt/${P}/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ local xwarn="virtual/x11 and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+
+ echo
+ elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+}