summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Almenar <strider@gentoo.org>2002-11-06 05:24:12 +0000
committerAdrian Almenar <strider@gentoo.org>2002-11-06 05:24:12 +0000
commit96a1492c275da73f13392f88dd271e226598b292 (patch)
treeaca293c4dd2dcf352be0c5349a9e1772ff1524b5 /dev-java
parentPatched faac to support the new libsndfile-1.x API. Please comment on (diff)
downloadgentoo-2-96a1492c275da73f13392f88dd271e226598b292.tar.gz
gentoo-2-96a1492c275da73f13392f88dd271e226598b292.tar.bz2
gentoo-2-96a1492c275da73f13392f88dd271e226598b292.zip
Initial Import
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-logging/ChangeLog9
-rw-r--r--dev-java/commons-logging/commons-logging-1.0.2.ebuild51
-rw-r--r--dev-java/commons-logging/files/digest-commons-logging-1.0.21
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-java/commons-logging/ChangeLog b/dev-java/commons-logging/ChangeLog
new file mode 100644
index 000000000000..4711830c9734
--- /dev/null
+++ b/dev-java/commons-logging/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-java/commons-logging
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/ChangeLog,v 1.1 2002/11/06 05:24:12 strider Exp $
+
+*commons-logging-1.0.2 (06 Nov 2002)
+
+ 06 Nov 2002; Adrian Almenar <strider@gentoo.org> ChangeLog commons-logging-1.0.2.ebuild files/digest-commons-logging-1.0.2 :
+ Initial import.
+
diff --git a/dev-java/commons-logging/commons-logging-1.0.2.ebuild b/dev-java/commons-logging/commons-logging-1.0.2.ebuild
new file mode 100644
index 000000000000..c2741df10fa7
--- /dev/null
+++ b/dev-java/commons-logging/commons-logging-1.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/commons-logging-1.0.2.ebuild,v 1.1 2002/11/06 05:24:12 strider Exp $
+
+S="${WORKDIR}/${P}-src"
+DESCRIPTION="Jakarta component that abstract logging API"
+HOMEPAGE="http://jakarta.apache.org/commons/logging.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="jikes junit"
+
+src_compile() {
+ local myc
+
+ cd logging
+ cp LICENSE.txt ../LICENSE
+
+ if [ -n "`use jikes`" ] ; then
+ myc="${myc} -Dbuild.compiler=jikes"
+ fi
+
+ if [ -n "`use junit`" ] ; then
+ echo "junit.jar=`java-config --classpath=junit`" | sed s/:.*// > build.properties
+ ANT_OPTS=${myc} ant test || die "Testing Classes Failed"
+ fi
+
+ echo "log4j.jar=`java-config --classpath=log4j`" >> build.properties
+
+ ANT_OPTS=${myc} ant dist || die "Compilation failed"
+}
+
+src_install () {
+ cd logging
+ dojar dist/commons-logging-api.jar || die "Unable to install"
+ dojar dist/commons-logging.jar || die "Unable to install"
+ dodoc RELEASE-NOTES.txt
+ dohtml PROPOSAL.html STATUS.html usersguide.html
+ dohtml -r dist/docs/*
+}
+
+pkg_postinst() {
+ einfo "**************** Documentation can be found at ******************\n
+ WEB: ${HOMEPAGE}\n
+ LOCAL: /usr/share/doc/${PF}\n
+ *****************************************************************"
+}
diff --git a/dev-java/commons-logging/files/digest-commons-logging-1.0.2 b/dev-java/commons-logging/files/digest-commons-logging-1.0.2
new file mode 100644
index 000000000000..608ab555e60d
--- /dev/null
+++ b/dev-java/commons-logging/files/digest-commons-logging-1.0.2
@@ -0,0 +1 @@
+MD5 78bfaac25906a54b925bcc285872c9c9 commons-logging-1.0.2-src.tar.gz 33550