summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2007-01-28 17:09:22 +0000
committerWilliam Thomson <wltjr@gentoo.org>2007-01-28 17:09:22 +0000
commita1720a9746ff4f265de7bf7f20958e55d1593847 (patch)
treeaacd3b2f823db657af564067ebb875226ba741eb /dev-java
parentBrought forward ~ppc keyword, and removed older versions (diff)
downloadgentoo-2-a1720a9746ff4f265de7bf7f20958e55d1593847.tar.gz
gentoo-2-a1720a9746ff4f265de7bf7f20958e55d1593847.tar.bz2
gentoo-2-a1720a9746ff4f265de7bf7f20958e55d1593847.zip
Migrated to gen 2, potential stale and might need to be removed from tree, last release from upstream was October 11, 2003
(Portage version: 2.1.2-r1)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/helpgui/ChangeLog11
-rw-r--r--dev-java/helpgui/files/digest-helpgui-1.12
-rw-r--r--dev-java/helpgui/files/digest-helpgui-1.1-r13
-rw-r--r--dev-java/helpgui/helpgui-1.1-r1.ebuild34
4 files changed, 48 insertions, 2 deletions
diff --git a/dev-java/helpgui/ChangeLog b/dev-java/helpgui/ChangeLog
index 6b4e0d792935..eda4e2fa607f 100644
--- a/dev-java/helpgui/ChangeLog
+++ b/dev-java/helpgui/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/helpgui
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/helpgui/ChangeLog,v 1.1 2005/05/22 16:02:45 luckyduck Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/helpgui/ChangeLog,v 1.2 2007/01/28 17:09:22 wltjr Exp $
+
+*helpgui-1.1-r1 (28 Jan 2007)
+
+ 28 Jan 2007; William L. Thomson Jr. <wltjr@gentoo.org>
+ +helpgui-1.1-r1.ebuild:
+ Migrated to gen 2, potential stale and might need to be removed from tree,
+ last release from upstream was October 11, 2003
*helpgui-1.1 (22 May 2005)
diff --git a/dev-java/helpgui/files/digest-helpgui-1.1 b/dev-java/helpgui/files/digest-helpgui-1.1
index 871d24bc10b7..80fb39290717 100644
--- a/dev-java/helpgui/files/digest-helpgui-1.1
+++ b/dev-java/helpgui/files/digest-helpgui-1.1
@@ -1 +1,3 @@
MD5 971f0525560fb86812678c3b114ab241 helpgui-1.1-src.jar 168356
+RMD160 bde49ee68e0ba6313eb97e19a27153eac74448be helpgui-1.1-src.jar 168356
+SHA256 bed678f1fcfb46cb65785a3fe6b819c312458fc6bca976142c52a0e0896a8112 helpgui-1.1-src.jar 168356
diff --git a/dev-java/helpgui/files/digest-helpgui-1.1-r1 b/dev-java/helpgui/files/digest-helpgui-1.1-r1
new file mode 100644
index 000000000000..80fb39290717
--- /dev/null
+++ b/dev-java/helpgui/files/digest-helpgui-1.1-r1
@@ -0,0 +1,3 @@
+MD5 971f0525560fb86812678c3b114ab241 helpgui-1.1-src.jar 168356
+RMD160 bde49ee68e0ba6313eb97e19a27153eac74448be helpgui-1.1-src.jar 168356
+SHA256 bed678f1fcfb46cb65785a3fe6b819c312458fc6bca976142c52a0e0896a8112 helpgui-1.1-src.jar 168356
diff --git a/dev-java/helpgui/helpgui-1.1-r1.ebuild b/dev-java/helpgui/helpgui-1.1-r1.ebuild
new file mode 100644
index 000000000000..8133607d2cc2
--- /dev/null
+++ b/dev-java/helpgui/helpgui-1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/helpgui/helpgui-1.1-r1.ebuild,v 1.1 2007/01/28 17:09:22 wltjr Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="HelpGUI is a simple library which develop a help viewer component."
+HOMEPAGE="http://helpgui.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc source"
+
+DEPEND=">=virtual/jdk-1.4
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.4"
+
+src_unpack() {
+ jar xf ${DISTDIR}/${A} || die
+}
+
+src_compile() {
+ eant helpgui_jar $(use_doc javadocs)
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+
+ dodoc README
+ use doc && java-pkg_dohtml -r build/docs/
+ use source && java-pkg_dosrc src/*
+}