summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2010-01-10 13:32:16 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2010-01-10 13:32:16 +0000
commitac212bd2782f17901316c46055b82f16720fa22a (patch)
treebe78b4dd16a425cc9c3f5b79458a93b3eca1be51 /dev-java
parentTransfer Prefix keywords (diff)
downloadgentoo-2-ac212bd2782f17901316c46055b82f16720fa22a.tar.gz
gentoo-2-ac212bd2782f17901316c46055b82f16720fa22a.tar.bz2
gentoo-2-ac212bd2782f17901316c46055b82f16720fa22a.zip
Version bump using EAPI 2. Resolves bug #296163.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/tomcat-native/ChangeLog10
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.18.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index e61629c6885c..3d984ae01a2f 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.22 2009/01/16 17:48:36 betelgeuse Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.23 2010/01/10 13:32:16 betelgeuse Exp $
+
+*tomcat-native-1.1.18 (10 Jan 2010)
+
+ 10 Jan 2010; Petteri Räty <betelgeuse@gentoo.org>
+ +tomcat-native-1.1.18.ebuild:
+ Version bump using EAPI 2. Resolves bug #296163.
*tomcat-native-1.1.16 (16 Jan 2009)
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.18.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.18.ebuild
new file mode 100644
index 000000000000..e7127dfea318
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.18.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.18.ebuild,v 1.1 2010/01/10 13:32:16 betelgeuse Exp $
+
+EAPI="2"
+
+inherit base eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src/jni/native
+
+src_configure(){
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+}
+
+src_compile() {
+ base_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}