summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-01-09 12:50:45 +0000
committerThomas Sachau <tommy@gentoo.org>2010-01-09 12:50:45 +0000
commitaf312f7f83c96b990a2073bdb0218a470b1ca0a6 (patch)
tree6447f7e528329b1c3299555428235038da2efa2c /dev-java
parentVersion bump and removed old versions. (diff)
downloadgentoo-2-af312f7f83c96b990a2073bdb0218a470b1ca0a6.tar.gz
gentoo-2-af312f7f83c96b990a2073bdb0218a470b1ca0a6.tar.bz2
gentoo-2-af312f7f83c96b990a2073bdb0218a470b1ca0a6.zip
Version bump
(Portage version: 2.2_rc61-r1/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/fec/ChangeLog10
-rw-r--r--dev-java/fec/fec-1.0.4.ebuild57
-rw-r--r--dev-java/fec/files/fec-1.0.4-libfec8path.patch29
3 files changed, 94 insertions, 2 deletions
diff --git a/dev-java/fec/ChangeLog b/dev-java/fec/ChangeLog
index 2e473d054719..2b8e7a69c3a9 100644
--- a/dev-java/fec/ChangeLog
+++ b/dev-java/fec/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/fec
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fec/ChangeLog,v 1.6 2009/03/09 22:34:52 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fec/ChangeLog,v 1.7 2010/01/09 12:50:45 tommy Exp $
+
+*fec-1.0.4 (09 Jan 2010)
+
+ 09 Jan 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +fec-1.0.4.ebuild, +files/fec-1.0.4-libfec8path.patch:
+ Version bump
09 Mar 2009; Markus Meier <maekke@gentoo.org> fec-1.0.3-r1.ebuild:
amd64/x86 stable, bug #260958
diff --git a/dev-java/fec/fec-1.0.4.ebuild b/dev-java/fec/fec-1.0.4.ebuild
new file mode 100644
index 000000000000..eb61b8679840
--- /dev/null
+++ b/dev-java/fec/fec-1.0.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fec/fec-1.0.4.ebuild,v 1.1 2010/01/09 12:50:45 tommy Exp $
+
+JAVA_PKG_IUSE="doc source"
+
+inherit flag-o-matic java-pkg-2 java-ant-2 toolchain-funcs
+
+DESCRIPTION="Forword error correction libs"
+HOMEPAGE="http://www.onionnetworks.com/developers/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hardened"
+
+COMMON_DEPEND="dev-java/log4j
+ dev-java/concurrent-util"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEPEND}"
+EANT_BUILD_TARGET="jars"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}" || die
+ sed -i -e 's/build.compiler=jikes/#build.compiler=jikes/g' build.properties || die
+ epatch "${FILESDIR}"/${P}-libfec8path.patch
+ eant clean
+ cd lib || die
+ rm -v *.jar || die
+ java-pkg_jar-from log4j
+ java-pkg_jar-from concurrent-util concurrent.jar concurrent-jaxed.jar
+ cd "${S}" || die
+ unzip -q common-20020926.zip || die
+ cd common-20020926 || die
+ eant clean
+ cp -r src/com ../src/ || die
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+ cd "${S}"/src/csrc
+ use hardened && append-flags -fPIC
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ java-pkg_newjar lib/onion-${PN}.jar ${PN}.jar
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/com
+ dolib.so src/csrc/libfec{8,16}.so || die
+}
diff --git a/dev-java/fec/files/fec-1.0.4-libfec8path.patch b/dev-java/fec/files/fec-1.0.4-libfec8path.patch
new file mode 100644
index 000000000000..503db7c837eb
--- /dev/null
+++ b/dev-java/fec/files/fec-1.0.4-libfec8path.patch
@@ -0,0 +1,29 @@
+--- src/com/onionnetworks/fec/Native8Code.java 2009-08-21 02:37:00.515004583 +0200
++++ src/com/onionnetworks/fec/Native8Code.java.new 2009-08-21 02:37:57.829254678 +0200
+@@ -3,6 +3,7 @@
+ //import java.security.AccessController;
+ //import sun.security.action.*;
+ import com.onionnetworks.util.*;
++import java.io.File;
+
+ /**
+ * This class is the frontend for the JNI wrapper for the C implementation of
+@@ -21,15 +22,10 @@
+ final private long code;
+
+ static {
+- String path = NativeDeployer.getLibraryPath
+- (Native8Code.class.getClassLoader(),"fec8");
+- if (path != null) {
+- System.load(path);
++ File path = new File("/usr/lib/libfec8.so");
++ System.out.println("Loading FEC lib ["+path.getAbsolutePath()+']');
++ System.load(path.getAbsolutePath());
+ initFEC();
+- } else {
+- System.out.println("Unable to find native library for fec8 for platform "+NativeDeployer.OS_ARCH);
+- System.out.println(path);
+- }
+ }
+
+ public Native8Code(int k, int n) {