summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2013-05-28 20:17:47 +0000
committerVlastimil Babka <caster@gentoo.org>2013-05-28 20:17:47 +0000
commitd35c9dcecb7785a5e88dbe9ab70d41bd56d4fc3b (patch)
tree0eee237566c51e7a2bc41e8ad5a1d31daa232c75 /dev-java
parentfix deprecated imports by Mikle Kolyada (#471530) (diff)
downloadgentoo-2-d35c9dcecb7785a5e88dbe9ab70d41bd56d4fc3b.tar.gz
gentoo-2-d35c9dcecb7785a5e88dbe9ab70d41bd56d4fc3b.tar.bz2
gentoo-2-d35c9dcecb7785a5e88dbe9ab70d41bd56d4fc3b.zip
Version bump, security bug #466822. Installs libpng-1.5 or libpng-1.6 file depending on what is detected, bug #464914.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4E61DE84)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea-bin/ChangeLog9
-rw-r--r--dev-java/icedtea-bin/icedtea-bin-6.1.12.5.ebuild (renamed from dev-java/icedtea-bin/icedtea-bin-6.1.12.2.ebuild)27
2 files changed, 30 insertions, 6 deletions
diff --git a/dev-java/icedtea-bin/ChangeLog b/dev-java/icedtea-bin/ChangeLog
index 69a793ed6461..c5021be15000 100644
--- a/dev-java/icedtea-bin/ChangeLog
+++ b/dev-java/icedtea-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/icedtea-bin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/ChangeLog,v 1.44 2013/04/29 05:21:17 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/ChangeLog,v 1.45 2013/05/28 20:17:47 caster Exp $
+
+*icedtea-bin-6.1.12.5 (27 May 2013)
+
+ 27 May 2013; Vlastimil Babka <caster@gentoo.org>
+ -icedtea-bin-6.1.12.2.ebuild, +icedtea-bin-6.1.12.5.ebuild:
+ Version bump, security bug #466822. Installs libpng-1.5 or libpng-1.6 file
+ depending on what is detected, bug #464914.
*icedtea-bin-7.2.3.9 (29 Apr 2013)
diff --git a/dev-java/icedtea-bin/icedtea-bin-6.1.12.2.ebuild b/dev-java/icedtea-bin/icedtea-bin-6.1.12.5.ebuild
index 401d0f07ff93..d467795bedbe 100644
--- a/dev-java/icedtea-bin/icedtea-bin-6.1.12.2.ebuild
+++ b/dev-java/icedtea-bin/icedtea-bin-6.1.12.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/icedtea-bin-6.1.12.2.ebuild,v 1.4 2013/04/09 20:26:41 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/icedtea-bin-6.1.12.5.ebuild,v 1.1 2013/05/28 20:17:47 caster Exp $
EAPI="4"
@@ -13,8 +13,10 @@ PLUGIN_VERSION="${PVR}"
DESCRIPTION="A Gentoo-made binary build of the IcedTea JDK"
HOMEPAGE="http://icedtea.classpath.org"
SRC_URI="
- amd64? ( ${dist}/${PN}-core-${TARBALL_VERSION}-amd64.tar.bz2 )
- x86? ( ${dist}/${PN}-core-${TARBALL_VERSION}-x86.tar.bz2 )
+ amd64? ( ${dist}/${PN}-core-${TARBALL_VERSION}-amd64.tar.bz2
+ ${dist}/${PN}-libpng15-${TARBALL_VERSION}-amd64.tar.bz2 )
+ x86? ( ${dist}/${PN}-core-${TARBALL_VERSION}-x86.tar.bz2
+ ${dist}/${PN}-libpng15-${TARBALL_VERSION}-x86.tar.bz2 )
doc? ( ${dist}/${PN}-doc-${TARBALL_VERSION}.tar.bz2 )
examples? (
amd64? ( ${dist}/${PN}-examples-${TARBALL_VERSION}-amd64.tar.bz2 )
@@ -28,7 +30,7 @@ SRC_URI="
LICENSE="GPL-2-with-linking-exception"
SLOT="6"
-KEYWORDS="-* amd64 x86"
+KEYWORDS="-* ~amd64 ~x86"
IUSE="+X +alsa cjk +cups doc examples nsplugin source"
REQUIRED_USE="nsplugin? ( X )"
@@ -52,7 +54,7 @@ X_COMMON_DEP="
COMMON_DEP="
>=media-libs/giflib-4.1.6-r1
- =media-libs/libpng-1.5*
+ >=media-libs/libpng-1.5
>=sys-devel/gcc-4.3
>=sys-libs/glibc-2.11.2
>=sys-libs/zlib-1.2.3-r1
@@ -81,6 +83,21 @@ RDEPEND="${COMMON_DEP}
alsa? ( ${ALSA_COMMON_DEP} )
cups? ( ${CUPS_COMMON_DEP} )"
+src_unpack() {
+ unpack ${A}
+
+ if has_version '=media-libs/libpng-1.5*:0'; then
+ elog "Installing libpng-1.5 ABI version"
+ elog "You will have to remerge icedtea6-bin after upgrading to libpng-1.6"
+ elog "Note that revdep-rebuild will not do it automatically due to the mask file."
+ local arch=${ARCH}
+ use x86 && arch=i386
+ mv -v ${PN}-libpng15-${PV}/jre/lib/${arch}/*.so ${P}/jre/lib/${arch} || die
+ else
+ einfo "Installing libpng-1.6 ABI version"
+ fi
+}
+
src_install() {
local dest="/opt/${P}"
local ddest="${ED}/${dest}"