summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-03-17 05:08:17 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-03-17 05:08:17 +0000
commite1da686650a6bdb15574a080fc73b446df2ef11a (patch)
treeec25b6890deef908e97bf2896fc8d23f79a11ce5 /dev-java
parentamd64 works ;) (Manifest recommit) (diff)
downloadgentoo-2-e1da686650a6bdb15574a080fc73b446df2ef11a.tar.gz
gentoo-2-e1da686650a6bdb15574a080fc73b446df2ef11a.tar.bz2
gentoo-2-e1da686650a6bdb15574a080fc73b446df2ef11a.zip
Not using jakarta-commons.eclass anymore due to breakage
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-logging/Manifest6
-rw-r--r--dev-java/commons-logging/commons-logging-1.0.3-r1.ebuild44
-rw-r--r--dev-java/commons-logging/files/digest-commons-logging-1.0.3-r11
3 files changed, 49 insertions, 2 deletions
diff --git a/dev-java/commons-logging/Manifest b/dev-java/commons-logging/Manifest
index 10a8aff1dfd8..2fc99b04ae3e 100644
--- a/dev-java/commons-logging/Manifest
+++ b/dev-java/commons-logging/Manifest
@@ -1,4 +1,6 @@
-MD5 9239b65b8a08e613a9d29e0df82cc70c ChangeLog 1875
-MD5 34c6b0367b7ef7c222be9712920d0f72 commons-logging-1.0.3.ebuild 965
+MD5 61abae760af61a546de38c6670aa670a commons-logging-1.0.3-r1.ebuild 1274
+MD5 9553085f9741ee1fd50343c7c69f0316 ChangeLog 1874
+MD5 22d322cf44f697ea6f5055194eaf8e85 commons-logging-1.0.3.ebuild 964
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 3d6fb50b9453c1e9c219a22a23345e23 files/digest-commons-logging-1.0.3 76
+MD5 3d6fb50b9453c1e9c219a22a23345e23 files/digest-commons-logging-1.0.3-r1 76
diff --git a/dev-java/commons-logging/commons-logging-1.0.3-r1.ebuild b/dev-java/commons-logging/commons-logging-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..97cb16729392
--- /dev/null
+++ b/dev-java/commons-logging/commons-logging-1.0.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/commons-logging-1.0.3-r1.ebuild,v 1.1 2004/03/17 05:08:17 zx Exp $
+
+inherit java-pkg
+
+S="${WORKDIR}/${P}-src/"
+DESCRIPTION="The Jakarta-Commons Logging package is an ultra-thin bridge between different logging libraries."
+HOMEPAGE="http://jakarta.apache.org/commons/logging/"
+SRC_URI="mirror://apache/jakarta/commons/logging/source/${PN}-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/log4j-1.2.5
+ dev-java/avalon-logkit
+ >=dev-java/ant-1.4
+ jikes? ( dev-java/jikes )
+ junit? ( >=dev-java/junit-3.7 )"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE="doc jikes junit"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ echo "log4j.jar=`java-config -p log4j`" > build.properties
+ echo "logkit.jar=`java-config -p avalon-logkit`" >> build.properties
+ echo "junit.jar=`java-config -p junit`" >> build.properties
+}
+
+src_compile() {
+ local antflags="compile"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ use junit && antflags="${antflags} test"
+ ant ${antflags}
+}
+
+src_install() {
+ java-pkg_dojar target/*
+ dodoc RELEASE-NOTES.txt
+ dohtml PROPOSAL.html STATUS.html usersguide.html
+ use doc && dohtml -r dist/docs/
+}
diff --git a/dev-java/commons-logging/files/digest-commons-logging-1.0.3-r1 b/dev-java/commons-logging/files/digest-commons-logging-1.0.3-r1
new file mode 100644
index 000000000000..095408c78caf
--- /dev/null
+++ b/dev-java/commons-logging/files/digest-commons-logging-1.0.3-r1
@@ -0,0 +1 @@
+MD5 d40606211a1559a9d9fd35eb9091ac15 commons-logging-1.0.3-src.tar.gz 45202