summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-03-11 20:37:24 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-03-11 20:37:24 +0000
commitf7d6a85f436f03b9b3b4a194ae7572d106bb4fe4 (patch)
tree7caf1a072f86a14ba4be0c1c08db3c9afaa0e04e /dev-java
parentRemoved stale SRC_URI (Manifest recommit) (diff)
downloadgentoo-2-f7d6a85f436f03b9b3b4a194ae7572d106bb4fe4.tar.gz
gentoo-2-f7d6a85f436f03b9b3b4a194ae7572d106bb4fe4.tar.bz2
gentoo-2-f7d6a85f436f03b9b3b4a194ae7572d106bb4fe4.zip
Some fixes needed to be applied before I unmask this beast.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/ant/ChangeLog6
-rw-r--r--dev-java/ant/ant-1.6.0-r2.ebuild4
-rw-r--r--dev-java/ant/ant-1.6.1.ebuild32
3 files changed, 30 insertions, 12 deletions
diff --git a/dev-java/ant/ChangeLog b/dev-java/ant/ChangeLog
index 71cf1783aea9..8239984aae9d 100644
--- a/dev-java/ant/ChangeLog
+++ b/dev-java/ant/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/ant
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ChangeLog,v 1.54 2004/03/11 02:34:01 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ChangeLog,v 1.55 2004/03/11 20:37:24 zx Exp $
+
+ 11 Mar 2004; Chris Aniszczyk <zx@gentoo.org> ant-1.6.0-r2.ebuild,
+ ant-1.6.1.ebuild:
+ Added some fixes. Thanks to Pavel <hlobil@sympatico.ca> for some input.
*ant-1.6.1 (10 Mar 2004)
diff --git a/dev-java/ant/ant-1.6.0-r2.ebuild b/dev-java/ant/ant-1.6.0-r2.ebuild
index 688e8ab04590..dc91847b134f 100644
--- a/dev-java/ant/ant-1.6.0-r2.ebuild
+++ b/dev-java/ant/ant-1.6.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.0-r2.ebuild,v 1.4 2004/02/25 07:39:32 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.0-r2.ebuild,v 1.5 2004/03/11 20:37:24 zx Exp $
inherit java-pkg
@@ -10,7 +10,7 @@ SRC_URI="mirror://apache/ant/source/apache-${PN}-${PV}-src.tar.bz2"
HOMEPAGE="http://ant.apache.org"
LICENSE="Apache-1.1"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* ~x86"
DEPEND="virtual/glibc
>=virtual/jdk-1.4
>=dev-java/java-config-1.2"
diff --git a/dev-java/ant/ant-1.6.1.ebuild b/dev-java/ant/ant-1.6.1.ebuild
index 10f1370a4a88..334152c96c61 100644
--- a/dev-java/ant/ant-1.6.1.ebuild
+++ b/dev-java/ant/ant-1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.1.ebuild,v 1.1 2004/03/11 02:34:01 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant/ant-1.6.1.ebuild,v 1.2 2004/03/11 20:37:24 zx Exp $
inherit java-pkg
@@ -24,6 +24,24 @@ IUSE="doc"
S="${WORKDIR}/apache-ant-${PV}"
+pkg_setup() {
+ if [ -n "$JAVA_HOME" ] ; then
+ export CLASSPATH=".:$JAVA_HOME/lib:$JAVA_HOME/lib/tools.jar:$JAVA_HOME/jre/lib/rt.jar:."
+ else
+ einfo "Warning: JAVA_HOME environment variable is not set (or not exported)."
+ einfo " If build fails because sun.* classes could not be found"
+ einfo " you will need to set the JAVA_HOME environment variable"
+ einfo " to the installation directory of java."
+ einfo " Try using java-config script"
+ die
+ fi
+
+ if [ `arch` == "ppc" ] ; then
+ # We're compiling _ON_ PPC
+ export THREADS_FLAG="green"
+ fi
+}
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -34,15 +52,11 @@ src_unpack() {
}
src_compile() {
-
- [ -z ${JDK_HOME} ] && einfo "JDK_HOME not set, please check with java-config" && die
-
addwrite "/proc/self/maps"
- export JAVA_HOME=${JDK_HOME}
- if [ `arch` == "ppc" ] ; then
- # We're compiling _ON_ PPC
- export THREADS_FLAG="green"
- fi
+
+ local myc
+ myc="${myc} -Ddist.dir=${D}/usr/share/ant"
+ myc="${myc} -Djavac.target=1.4"
./build.sh -Ddist.dir=${D}/usr/share/ant || die
}