summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-10 22:33:28 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-10 22:33:28 +0000
commit020504cf21d6ecbd08505424df0aa7bc769d2bf6 (patch)
treeffa386c063e69e6e2f7574beb0991ee29dcd4501 /dev-lang/R/R-2.1.1.ebuild
parentVersion bump #129528 by Natanael Copa. (diff)
downloadgentoo-2-020504cf21d6ecbd08505424df0aa7bc769d2bf6.tar.gz
gentoo-2-020504cf21d6ecbd08505424df0aa7bc769d2bf6.tar.bz2
gentoo-2-020504cf21d6ecbd08505424df0aa7bc769d2bf6.zip
touchups
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-lang/R/R-2.1.1.ebuild')
-rw-r--r--dev-lang/R/R-2.1.1.ebuild35
1 files changed, 22 insertions, 13 deletions
diff --git a/dev-lang/R/R-2.1.1.ebuild b/dev-lang/R/R-2.1.1.ebuild
index ade9ce8771e0..c67ad2bc4aa9 100644
--- a/dev-lang/R/R-2.1.1.ebuild
+++ b/dev-lang/R/R-2.1.1.ebuild
@@ -1,30 +1,38 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.1.1.ebuild,v 1.6 2005/11/22 15:11:55 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.1.1.ebuild,v 1.7 2006/04/10 22:33:28 vapier Exp $
inherit fortran toolchain-funcs
-IUSE="blas jpeg nls png readline tcltk X"
DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+HOMEPAGE="http://www.r-project.org/"
SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
#There are daily release patches, don't know how to utilize these
#"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-HOMEPAGE="http://www.r-project.org/"
-DEPEND="virtual/libc
- >=dev-lang/perl-5.6.1-r3
- readline? ( >=sys-libs/readline-4.1-r3 )
- jpeg? ( >=media-libs/jpeg-6b-r2 )
- png? ( >=media-libs/libpng-1.2.1 )
- blas? ( virtual/blas )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )"
-SLOT="0"
+
LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="blas jpeg nls png readline tcltk X"
+
+DEPEND=">=dev-lang/perl-5.6.1-r3
+ readline? ( >=sys-libs/readline-4.1-r3 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ blas? ( virtual/blas )
+ tcltk? ( dev-lang/tk )
+ X? ( || ( ( x11-libs/libX11 )
+ virtual/x11 ) )"
+DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/xproto
+ x11-libs/libXt
+ x11-libs/libX11 )
+ virtual/x11 ) )"
pkg_setup() {
# Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
# Thanks to vapier for providing the test.
+ cd "${T}"
echo 'int main(){}' > test.c
$(tc-getCC) -c test.c -o test.o
if file test.o | grep -qs 64-bit ; then
@@ -33,6 +41,7 @@ pkg_setup() {
else
FORTRAN="g77 f2c"
fi
+ rm -f test.{c,o}
fortran_pkg_setup
}