summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-01-03 11:14:55 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-01-03 11:14:55 +0000
commit4bfa8aee97d378c7e375b871b682d68954d7c10e (patch)
tree148968fa266c16ebf429119cadc06638593739c7 /dev-lang/R
parentdependency changed to =dev-libs/lzo-1* so that unmasking lzo-2 will not break... (diff)
downloadgentoo-2-4bfa8aee97d378c7e375b871b682d68954d7c10e.tar.gz
gentoo-2-4bfa8aee97d378c7e375b871b682d68954d7c10e.tar.bz2
gentoo-2-4bfa8aee97d378c7e375b871b682d68954d7c10e.zip
Version bump, closes bug 115304.
(Portage version: 2.0.53)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog9
-rw-r--r--dev-lang/R/Manifest12
-rw-r--r--dev-lang/R/R-2.2.1.ebuild100
-rw-r--r--dev-lang/R/files/digest-R-2.2.11
4 files changed, 110 insertions, 12 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index e27f34a4db5c..56e64dc253fd 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/R
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.64 2005/12/12 19:56:13 cryos Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.65 2006/01/03 11:14:55 cryos Exp $
+
+*R-2.2.1 (03 Jan 2006)
+
+ 03 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org> +R-2.2.1.ebuild:
+ Version bump, closes bug 115304.
*R-2.2.0-r1 (12 Dec 2005)
diff --git a/dev-lang/R/Manifest b/dev-lang/R/Manifest
index 5249980cbcec..719ee6fb2e74 100644
--- a/dev-lang/R/Manifest
+++ b/dev-lang/R/Manifest
@@ -1,19 +1,11 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 50da06d23274c78ec060f86d84470517 ChangeLog 9941
MD5 f4c46f25907c3aa68c31a150acaf151b R-2.1.1.ebuild 2644
MD5 c47d2c1039131afdf9b275f9302e015f R-2.2.0-r1.ebuild 2985
+MD5 c47d2c1039131afdf9b275f9302e015f R-2.2.1.ebuild 2985
MD5 8f28d07ba48615d7a496f31db3e9bf4d files/R-2.2.0-ifc-configure.patch 524
MD5 44015fe4137f1326769e89f2c2c2eda7 files/R-logo.png 4867
MD5 15ce6e575cf7a5844aa8deecb504e7be files/R.desktop 425
MD5 1be6338417fd08a609cb02164398a26b files/digest-R-2.1.1 61
MD5 1bf0aa0599dbf556341336a582094569 files/digest-R-2.2.0-r1 61
+MD5 cddf1048b239d92f43e97e9c222abaee files/digest-R-2.2.1 61
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDndYintT9W3vfTuoRAkHUAJ9hG5G02/wxz57IyGoUIDZQ5FqhCgCfXpAU
-4dZDajoCftkguEc/OdJMOtw=
-=NCqN
------END PGP SIGNATURE-----
diff --git a/dev-lang/R/R-2.2.1.ebuild b/dev-lang/R/R-2.2.1.ebuild
new file mode 100644
index 000000000000..2966f0cbd454
--- /dev/null
+++ b/dev-lang/R/R-2.2.1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1.ebuild,v 1.1 2006/01/03 11:14:55 cryos Exp $
+
+inherit fortran toolchain-funcs
+
+IUSE="blas jpeg nls png readline tcltk X lapack"
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
+HOMEPAGE="http://www.r-project.org/"
+DEPEND="virtual/libc
+ >=dev-lang/perl-5.6.1-r3
+ readline? ( >=sys-libs/readline-4.1-r3 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tk )"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+AT_M4DIR="${S}/m4"
+
+pkg_setup() {
+ # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
+ # Thanks to vapier for providing the test.
+ cd ${T}
+ echo 'int main(){}' > test.c
+ $(tc-getCC) -c test.c -o test.o
+ if file test.o | grep -qs 64-bit ; then
+ einfo "64 bit architecture detected, using g77."
+ FORTRAN="g77 ifc"
+ else
+ FORTRAN="g77 f2c"
+ fi
+ rm -f test.{c,o}
+ fortran_pkg_setup
+}
+
+src_compile() {
+ local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
+
+ if use tcltk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh
+ --with-tk-config=/usr/lib/tkConfig.sh"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ $(use_with blas) \
+ $(use_with lapack) \
+ $(use_with jpeg jpeglib) \
+ $(use_with png libpng) \
+ $(use_with readline) \
+ $(use_with X x) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ rhome=${D}/usr/$(get_libdir)/R \
+ install || die "Installation Failed"
+
+ # fix the R wrapper script to have the correct R_HOME_DIR
+ # sed regexp borrowed from included debian rules
+ sed \
+ -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
+ -i ${D}/usr/$(get_libdir)/R/bin/R \
+ || die "sed failed."
+
+ # The same kinds of seds are needed for these variables too, see bug 115140
+ sed \
+ -e "/^R_SHARE_DIR=.*/s::R_SHARE_DIR=/usr/$(get_libdir)/R/share:" \
+ -e "/^R_INCLUDE_DIR=.*/s::R_INCLUDE_DIR=/usr/$(get_libdir)/R/include:" \
+ -e "/^R_DOC_DIR=.*/s::R_DOC_DIR=/usr/$(get_libdir)/R/doc:" \
+ -i ${D}/usr/$(get_libdir)/R/bin/R \
+ || die "sed failed."
+
+ # R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
+ # the 2nd one is corrected by above sed, the first is replaced by a symlink
+ cd ${D}/usr/bin/
+ rm R
+ dosym ../$(get_libdir)/R/bin/R /usr/bin/R
+ dodir /etc/env.d
+ echo -n \
+ "LDPATH=\"/usr/$(get_libdir)/R/lib\"" \
+ > ${D}/etc/env.d/99R
+ cd ${S}
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog FAQ *NEWS README \
+ RESOURCES THANKS VERSION Y2K
+}
diff --git a/dev-lang/R/files/digest-R-2.2.1 b/dev-lang/R/files/digest-R-2.2.1
new file mode 100644
index 000000000000..c263b9191c20
--- /dev/null
+++ b/dev-lang/R/files/digest-R-2.2.1
@@ -0,0 +1 @@
+MD5 42542290c6d1585af7ded330f811385c R-2.2.1.tar.gz 13665367