summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2003-05-29 19:33:17 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2003-05-29 19:33:17 +0000
commit93c911514fa7a233dea3100e69ccc328fead8e19 (patch)
tree73e30dc48e09112b2e3d7783d85c52ee45eb177e /dev-lang/R
parentverson bump; closes 21448. (diff)
downloadgentoo-2-93c911514fa7a233dea3100e69ccc328fead8e19.tar.gz
gentoo-2-93c911514fa7a233dea3100e69ccc328fead8e19.tar.bz2
gentoo-2-93c911514fa7a233dea3100e69ccc328fead8e19.zip
verson bump; closes 21448.
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog7
-rw-r--r--dev-lang/R/Manifest4
-rw-r--r--dev-lang/R/R-1.7.0.ebuild96
-rw-r--r--dev-lang/R/files/digest-R-1.7.01
4 files changed, 105 insertions, 3 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index b8c26a5af8df..6decd9859177 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/R
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.9 2003/04/12 15:06:56 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.10 2003/05/29 19:33:11 g2boojum Exp $
+
+*R-1.7.0 (29 May 2003)
+
+ 29 May 2003; Grant Goodyear <g2boojum@gentoo.org> R-1.7.0.ebuild:
+ Version update. Thanks to Stuart Luppescu for the heads-up.
*R-1.6.2 (12 Apr 2003)
diff --git a/dev-lang/R/Manifest b/dev-lang/R/Manifest
index 40ad050e4720..4a5cfcd6a949 100644
--- a/dev-lang/R/Manifest
+++ b/dev-lang/R/Manifest
@@ -2,9 +2,9 @@ MD5 69e7caa2fa11325d1729eb41abfd4e0e R-1.6.1.ebuild 2672
MD5 06575366d8d0a2f47dfa6a7478af1694 R-1.4.1.ebuild 2466
MD5 11e2f9279d2c8a6867a6f960fc0197cb R-1.6.2.ebuild 2674
MD5 a129dec8f541cb4e8b21f51511d50b81 R-1.4.1-r1.ebuild 2469
-MD5 11e2f9279d2c8a6867a6f960fc0197cb R-1.7.0.ebuild 2674
+MD5 cbdb91166892da7fd0cd8f5cace90706 R-1.7.0.ebuild 2674
MD5 13e45453d57b8713d4640ae079b05fd6 R-1.5.1.ebuild 2764
-MD5 4edb30bf26be3760b9960b9678038a7b ChangeLog 2081
+MD5 e3303687e7dbe734c8de707f3b1df7ab ChangeLog 2238
MD5 f695db67db56e52a2f19cff1e64a6e97 files/R-1.5.1-tcltk.diff 503
MD5 44015fe4137f1326769e89f2c2c2eda7 files/R-logo.png 4867
MD5 0980ed6af02571cc8a1dc58941c5d2bf files/digest-R-1.4.1-r1 57
diff --git a/dev-lang/R/R-1.7.0.ebuild b/dev-lang/R/R-1.7.0.ebuild
new file mode 100644
index 000000000000..4c34ac0717bf
--- /dev/null
+++ b/dev-lang/R/R-1.7.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.7.0.ebuild,v 1.1 2003/05/29 19:33:11 g2boojum Exp $
+
+IUSE="atlas X tcltk gnome"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+
+SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
+
+ #There are daily release patches, don't know how to utilize these
+ #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
+
+HOMEPAGE="http://www.r-project.org/"
+
+DEPEND="virtual/glibc
+ >=dev-lang/perl-5.6.1-r3
+ >=sys-libs/readline-4.1-r3
+ >=sys-libs/zlib-1.1.3-r2
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/libpng-1.2.1
+ atlas? ( dev-libs/atlas )
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tk )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~x86 ~sparc"
+
+src_compile() {
+
+ local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
+
+ #Eventually, we will want to take into account that a user may have
+ #an alternate or additional blas libraries,
+ #i.e. USE variable blas and and virtual/blas
+ use atlas || myconf="${myconf} --without-blas" #default enabled
+
+ use X || myconf="${myconf} --without-x" #default enabled
+
+ if use tcltk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib --with-tk-config=/usr/lib"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ use gnome && myconf="${myconf} --with-gnome" #default disabled
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ make || die
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "Installation Failed"
+
+ #fix the R wrapper script to have the correct R_HOME_DIR
+ #sed regexp borrowed from included debian rules
+ cp ${D}/usr/lib/R/bin/R ${S}/bin/R.orig
+ sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
+ ${S}/bin/R.orig > ${D}/usr/lib/R/bin/R
+
+ #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
+ #the 2nd one is corrected by above sed, for the 1st
+ #I'll just symlink it into /usr/bin
+ cd ${D}/usr/bin/
+ rm R
+ dosym ../lib/R/bin/R /usr/bin/R
+ cd ${S}
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
+ RESOURCES THANKS VERSION Y2K
+
+ #Add rudimentary menu entry if gnome
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/R.desktop
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/R-logo.png
+ fi
+
+}
diff --git a/dev-lang/R/files/digest-R-1.7.0 b/dev-lang/R/files/digest-R-1.7.0
new file mode 100644
index 000000000000..b8611896d1f4
--- /dev/null
+++ b/dev-lang/R/files/digest-R-1.7.0
@@ -0,0 +1 @@
+MD5 292dbe4dc47e6b492ff72a62471654ca R-1.7.0.tgz 9236335