summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-01-16 00:35:27 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-01-16 00:35:27 +0000
commitae8350231dce0d012ff1579be420544a2690c651 (patch)
tree154ac0e5e203aab4da84e33b3aebe73027902d81 /dev-lang/R
parentAdding gfortran to profiles, and automatically selecting it where available, ... (diff)
downloadgentoo-2-ae8350231dce0d012ff1579be420544a2690c651.tar.gz
gentoo-2-ae8350231dce0d012ff1579be420544a2690c651.tar.bz2
gentoo-2-ae8350231dce0d012ff1579be420544a2690c651.zip
Add gfortran to the list of allowed Fortran compilers, closes bug 118147.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog5
-rw-r--r--dev-lang/R/R-2.2.1.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 56e64dc253fd..14b5c1f7a2f3 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.65 2006/01/03 11:14:55 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.66 2006/01/16 00:35:27 cryos Exp $
+
+ 16 Jan 2006; Marcus D. Hanwell <cryos@gentoo.org> R-2.2.1.ebuild:
+ Add gfortran to the list of allowed Fortran compilers, closes bug 118147.
*R-2.2.1 (03 Jan 2006)
diff --git a/dev-lang/R/R-2.2.1.ebuild b/dev-lang/R/R-2.2.1.ebuild
index 2966f0cbd454..e779d0c6d161 100644
--- a/dev-lang/R/R-2.2.1.ebuild
+++ b/dev-lang/R/R-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1.ebuild,v 1.1 2006/01/03 11:14:55 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.2.1.ebuild,v 1.2 2006/01/16 00:35:27 cryos Exp $
inherit fortran toolchain-funcs
@@ -29,10 +29,10 @@ pkg_setup() {
echo 'int main(){}' > test.c
$(tc-getCC) -c test.c -o test.o
if file test.o | grep -qs 64-bit ; then
- einfo "64 bit architecture detected, using g77."
- FORTRAN="g77 ifc"
+ einfo "64 bit architecture detected, using g77 or gfortran."
+ FORTRAN="gfortran g77 ifc"
else
- FORTRAN="g77 f2c"
+ FORTRAN="gfortran g77 f2c"
fi
rm -f test.{c,o}
fortran_pkg_setup