summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-06-16 00:27:47 +0000
committerAnant Narayanan <anant@gentoo.org>2007-06-16 00:27:47 +0000
commit64ee98e69b8644ea47a6306f0694225c7215cee3 (patch)
tree388301cc233f9654a5b872febc690185b6141b7c /dev-lang/dmd-bin
parent2.1.3_rc3 bump for bug #182157 (diff)
downloadgentoo-2-64ee98e69b8644ea47a6306f0694225c7215cee3.tar.gz
gentoo-2-64ee98e69b8644ea47a6306f0694225c7215cee3.tar.bz2
gentoo-2-64ee98e69b8644ea47a6306f0694225c7215cee3.zip
vBump to 1.015, closes bug #181663
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-lang/dmd-bin')
-rw-r--r--dev-lang/dmd-bin/ChangeLog7
-rw-r--r--dev-lang/dmd-bin/dmd-bin-1.015.ebuild110
-rw-r--r--dev-lang/dmd-bin/files/digest-dmd-bin-1.0153
3 files changed, 119 insertions, 1 deletions
diff --git a/dev-lang/dmd-bin/ChangeLog b/dev-lang/dmd-bin/ChangeLog
index 56c39823f3e6..6d320b53411f 100644
--- a/dev-lang/dmd-bin/ChangeLog
+++ b/dev-lang/dmd-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/dmd-bin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/ChangeLog,v 1.5 2007/05/20 21:23:08 anant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/ChangeLog,v 1.6 2007/06/16 00:27:47 anant Exp $
+
+*dmd-bin-1.015 (16 Jun 2007)
+
+ 16 Jun 2007; Anant Narayanan <anant@gentoo.org> +dmd-bin-1.015.ebuild:
+ vBump to 1.015, closes bug #181663
*dmd-bin-1.014 (21 May 2007)
diff --git a/dev-lang/dmd-bin/dmd-bin-1.015.ebuild b/dev-lang/dmd-bin/dmd-bin-1.015.ebuild
new file mode 100644
index 000000000000..61e60ab62846
--- /dev/null
+++ b/dev-lang/dmd-bin/dmd-bin-1.015.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/dmd-bin-1.015.ebuild,v 1.1 2007/06/16 00:27:47 anant Exp $
+
+inherit eutils
+
+MY_P=${P/-bin/}
+MY_P=${MY_P/-/.}
+
+DESCRIPTION="Digital Mars D Compiler"
+HOMEPAGE="http://www.digitalmars.com/d/"
+SRC_URI="http://ftp.digitalmars.com/${MY_P}.zip"
+
+LICENSE="DMD"
+RESTRICT="mirror nostrip"
+SLOT="0"
+KEYWORDS="~x86"
+
+LOC="/opt/dmd"
+S="${WORKDIR}"
+
+DEPEND="sys-apps/findutils"
+RDEPEND="amd64? ( app-emulation/emul-linux-x86-compat )
+ x86? ( >=virtual/libstdc++-3.3 )"
+
+
+src_unpack() {
+ unpack ${A}
+
+ # Remove unneccessary files
+ mv ${S}/dmd/lib/libphobos.a ${S}/dmd
+ rm -r ${S}/dmd/lib
+ mkdir ${S}/dmd/lib
+ mv ${S}/dmd/libphobos.a ${S}/dmd/lib
+
+ rm -r ${S}/dm
+ rm ${S}/dmd/bin/*.dll ${S}/dmd/bin/*.exe ${S}/dmd/bin/readme.txt
+ rm ${S}/dmd/bin/sc.ini ${S}/dmd/bin/windbg.hlp
+
+ # Cleanup line endings
+ cd ${S}/dmd
+ edos2unix `find . -name '*.c' -type f`
+ edos2unix `find . -name '*.d' -type f`
+ edos2unix `find . -name '*.ddoc' -type f`
+ edos2unix `find . -name '*.h' -type f`
+ edos2unix `find . -name '*.mak' -type f`
+ edos2unix `find . -name '*.txt' -type f`
+ edos2unix `find samples -name '*.html' -type f`
+
+ # Fix permissions
+ fperms guo=r `find . -type f`
+ fperms guo=rx `find . -type d`
+ fperms guo=rx bin/dmd bin/dumpobj bin/obj2asm bin/rdmd
+}
+
+src_compile() {
+ cd ${S}/dmd/src/phobos
+ sed -i -e "s:DMD=.*:DMD=${S}/dmd/bin/dmd -I${S}/dmd/src/phobos -L${S}/dmd/lib/libphobos.a:" linux.mak internal/gc/linux.mak
+ edos2unix linux.mak internal/gc/linux.mak
+ make -f linux.mak
+ cp libphobos.a ${S}/dmd/lib
+
+ # Clean up
+ make -f linux.mak clean
+ rm internal/gc/*.o
+}
+
+src_install() {
+ cd ${S}/dmd
+
+ # Broken dmd.conf
+ # http://d.puremagic.com/issues/show_bug.cgi?id=278
+ mv bin/dmd bin/dmd.bin
+ cat <<END > "bin/dmd"
+#!/bin/sh
+${LOC}/bin/dmd.bin -I${LOC}/src/phobos -L${LOC}/lib/libphobos.a \$*
+END
+ fperms guo=rx bin/dmd bin/dmd.bin
+
+ # Man pages
+ doman man/man1/dmd.1
+ doman man/man1/dumpobj.1
+ doman man/man1/obj2asm.1
+ rm -r man
+
+ # Install
+ mkdir "${D}/opt"
+ mv "${S}/dmd" "${D}/opt/dmd"
+
+ # Set PATH
+ doenvd "${FILESDIR}/25dmd"
+}
+
+pkg_postinst () {
+ ewarn "The DMD Configuration file has been disabled, "
+ ewarn "and will be re-enabled when: "
+ ewarn " "
+ ewarn "http://d.puremagic.com/issues/show_bug.cgi?id=278"
+ ewarn " "
+ ewarn "has been fixed. Meanwhile, please supply all your"
+ ewarn "configuration options in the /opt/dmd/bin/dmd "
+ ewarn "shell script. "
+ ewarn " "
+ ewarn "You may need to run: "
+ ewarn " "
+ ewarn "env-update && source /etc/profile "
+ ewarn " "
+ ewarn "to be able to use the compiler immediately. "
+ ewarn " "
+}
diff --git a/dev-lang/dmd-bin/files/digest-dmd-bin-1.015 b/dev-lang/dmd-bin/files/digest-dmd-bin-1.015
new file mode 100644
index 000000000000..cd1342f806f5
--- /dev/null
+++ b/dev-lang/dmd-bin/files/digest-dmd-bin-1.015
@@ -0,0 +1,3 @@
+MD5 46d433cbd14933b225a9d1c6b7cecbbb dmd.1.015.zip 4813902
+RMD160 9967fbc001c9858ce36e5674d8cad42bdd954873 dmd.1.015.zip 4813902
+SHA256 58be3c414ec7adbe96024ed79f6f5dd4630e3468f37d1ff10a7449f39a4987c3 dmd.1.015.zip 4813902