summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-01-03 07:45:23 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-01-03 07:45:23 +0000
commit2b2d4e60e012467a6ad75413f654daca415125cc (patch)
tree58dbd81fcd9ebc6db2f9e93876c448ac2e5d87fe /dev-lang/ekopath
parentAppend -fPIC on arm/hppa, bug #443246 (diff)
downloadgentoo-2-2b2d4e60e012467a6ad75413f654daca415125cc.tar.gz
gentoo-2-2b2d4e60e012467a6ad75413f654daca415125cc.tar.bz2
gentoo-2-2b2d4e60e012467a6ad75413f654daca415125cc.zip
Version bump, install docs conditionally wrt #411383 by Andrew Savchenko <bircoph@gmail.com>
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 895192F9)
Diffstat (limited to 'dev-lang/ekopath')
-rw-r--r--dev-lang/ekopath/ChangeLog12
-rw-r--r--dev-lang/ekopath/ekopath-4.0.12.1_pre20121102.ebuild76
2 files changed, 85 insertions, 3 deletions
diff --git a/dev-lang/ekopath/ChangeLog b/dev-lang/ekopath/ChangeLog
index 060c14cd3bdf..9713c9839aff 100644
--- a/dev-lang/ekopath/ChangeLog
+++ b/dev-lang/ekopath/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/ekopath
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.15 2012/06/25 14:16:20 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.16 2013/01/03 07:45:23 xarthisius Exp $
+
+*ekopath-4.0.12.1_pre20121102 (03 Jan 2013)
+
+ 03 Jan 2013; Kacper Kowalik <xarthisius@gentoo.org>
+ +ekopath-4.0.12.1_pre20121102.ebuild:
+ Version bump, install docs conditionally wrt #411383 by Andrew Savchenko
+ <bircoph@gmail.com>
25 Jun 2012; Kacper Kowalik <xarthisius@gentoo.org>
ekopath-4.0.12.1_pre20120530.ebuild:
@@ -107,4 +114,3 @@
15 Jun 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ekopath-4.0.10_pre20110612.ebuild, +metadata.xml:
Initial import
-
diff --git a/dev-lang/ekopath/ekopath-4.0.12.1_pre20121102.ebuild b/dev-lang/ekopath/ekopath-4.0.12.1_pre20121102.ebuild
new file mode 100644
index 000000000000..5c06fb9e3af5
--- /dev/null
+++ b/dev-lang/ekopath/ekopath-4.0.12.1_pre20121102.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-4.0.12.1_pre20121102.ebuild,v 1.1 2013/01/03 07:45:23 xarthisius Exp $
+
+EAPI=4
+
+inherit versionator
+
+MY_PV=$(get_version_component_range 1-4)
+DATE=$(get_version_component_range 5)
+DATE=${DATE/pre}
+DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
+
+DESCRIPTION="PathScale EKOPath Compiler Suite"
+HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
+SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${PN}-${DATE}-installer.run
+ -> ${P}.run"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="!!app-arch/rpm"
+RDEPEND=""
+
+RESTRICT="mirror"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ opt/${PN}/lib/${MY_PV}/x8664/*
+ opt/${PN}/bin/path*
+ opt/${PN}/bin/funclookup
+ opt/${PN}/bin/doctool
+ opt/${PN}/bin/subclient
+ opt/${PN}/bin/subserver
+ opt/${PN}/bin/assign"
+
+src_unpack() {
+ cp "${DISTDIR}"/${A} "${S}" || die
+ chmod +x "${S}"/${P}.run
+}
+
+src_prepare() {
+ cat > "99${PN}" <<-EOF
+ PATH=/opt/${PN}/bin
+ ROOTPATH=/opt/${PN}/bin
+ LDPATH=/opt/${PN}/lib:/opt/${PN}/lib/${MY_PV}/x8664/64
+ EOF
+}
+
+src_install() {
+ local opts
+ use doc || opts="${opts} --disable-components documentation"
+ # You must paxmark -m EI_PAX (not PT_PAX) to run the installer
+ # on a pax enabled kernel. Adding PT_PAX breaks the binary.
+ /usr/bin/scanelf -Xxz m ${P}.run >> /dev/null
+
+ ./${P}.run \
+ --prefix "${D}/opt/${PN}" \
+ --mode unattended \
+ ${opts} || die
+
+ # This is a temporary/partial fix to remove a RWX GNU STACK header
+ # from libstl.so. It still leaves libstl.a in bad shape.
+ # The correct fix is in the assembly atomic-cxx.S, which we don't get
+ # See http://www.gentoo.org/proj/en/hardened/gnu-stack.xml
+ # Section 6. How to fix the stack (in practice)
+ /usr/bin/scanelf -Xe "${D}/opt/ekopath/lib/${MY_PV}/x8664/64/libstl.so"
+
+ rm -rf "${D}"/opt/${PN}/uninstall || die
+ rm -rf "${D}"/opt/${PN}/bin/{pathdb,funclookup} || die #libtinfo
+ rm -rf "${D}"/opt/${PN}/lib/${MY_PV}/x8664/coco || die #DT_PATH
+ doenvd "99${PN}"
+}