summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-08-03 14:00:25 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-08-03 14:00:25 +0000
commitc5b838ca115fb06a8b0a99c8667d84e40c604121 (patch)
treef42e41602a0c0a2841bfcf09167eeff7ee42525f /dev-lang/ekopath
parentVersion bump (diff)
downloadgentoo-2-c5b838ca115fb06a8b0a99c8667d84e40c604121.tar.gz
gentoo-2-c5b838ca115fb06a8b0a99c8667d84e40c604121.tar.bz2
gentoo-2-c5b838ca115fb06a8b0a99c8667d84e40c604121.zip
Fix a) paxmarkings on installer and b) RWX GNU STACK on libstl.so
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ekopath')
-rw-r--r--dev-lang/ekopath/ChangeLog7
-rw-r--r--dev-lang/ekopath/ekopath-4.0.10_pre20110728.ebuild14
2 files changed, 19 insertions, 2 deletions
diff --git a/dev-lang/ekopath/ChangeLog b/dev-lang/ekopath/ChangeLog
index ceaf39b62566..1e35e7c88321 100644
--- a/dev-lang/ekopath/ChangeLog
+++ b/dev-lang/ekopath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ekopath
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.4 2011/07/31 08:04:04 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ChangeLog,v 1.5 2011/08/03 14:00:24 blueness Exp $
+
+ 03 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
+ ekopath-4.0.10_pre20110728.ebuild:
+ Fix a) paxmarkings on installer and b) RWX GNU STACK on libstl.so
+ This is for pax enabled kernels, but tested and safe on vanilla.
*ekopath-4.0.10_pre20110728 (31 Jul 2011)
diff --git a/dev-lang/ekopath/ekopath-4.0.10_pre20110728.ebuild b/dev-lang/ekopath/ekopath-4.0.10_pre20110728.ebuild
index 17d3cc49abb2..fe9fa1d74021 100644
--- a/dev-lang/ekopath/ekopath-4.0.10_pre20110728.ebuild
+++ b/dev-lang/ekopath/ekopath-4.0.10_pre20110728.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-4.0.10_pre20110728.ebuild,v 1.1 2011/07/31 08:04:04 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-4.0.10_pre20110728.ebuild,v 1.2 2011/08/03 14:00:25 blueness Exp $
EAPI=4
@@ -58,9 +58,21 @@ src_prepare() {
}
src_install() {
+ # You must paxmark -m EI_PAX (not PT_PAX) to run the installer
+ # on a pax enabled kernel. Adding PT_PAX breaks the binary.
+ /usr/bin/scanelf -Xxz m ${P}.run >> /dev/null
+
./${P}.run \
--prefix "${D}/opt/${PN}" \
--mode unattended || die
+
+ # This is a temporary/partial fix to remove a RWX GNU STACK header
+ # from libstl.so. It still leaves libstl.a in bad shape.
+ # The correct fix is in the assembly atomic-cxx.S, which we don't get
+ # See http://www.gentoo.org/proj/en/hardened/gnu-stack.xml
+ # Section 6. How to fix the stack (in practice)
+ /usr/bin/scanelf -Xe "${D}/opt/ekopath/lib/4.0.11/x8664/64/libstl.so"
+
rm -rf "${D}"/opt/${PN}/uninstall || die
doenvd "99${PN}"
}