summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-07-30 11:47:32 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-07-30 11:47:32 +0000
commit87890912f5fe7247634daa13a1a1bf412623ccd3 (patch)
treeb2fd06a85957a549f74b14a29928c4b8de7a9647 /dev-lang/ghc
parentStable for HPPA (bug #517788). (diff)
downloadgentoo-2-87890912f5fe7247634daa13a1a1bf412623ccd3.tar.gz
gentoo-2-87890912f5fe7247634daa13a1a1bf412623ccd3.tar.bz2
gentoo-2-87890912f5fe7247634daa13a1a1bf412623ccd3.zip
Fix underlinking of ghc-prim. Workarounds ghc-stage2 ld.so SIGSEGV on hardened (reported by aranea).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog7
-rw-r--r--dev-lang/ghc/files/ghc-7.8.3-prim-lm.patch15
-rw-r--r--dev-lang/ghc/ghc-7.8.3.ebuild3
3 files changed, 23 insertions, 2 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index fccf4886201a..723ed99df37a 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.259 2014/07/12 06:18:49 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.260 2014/07/30 11:47:32 slyfox Exp $
+
+ 30 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/ghc-7.8.3-prim-lm.patch, ghc-7.8.3.ebuild:
+ Fix underlinking of ghc-prim. Workarounds ghc-stage2 ld.so SIGSEGV on hardened
+ (reported by aranea).
12 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> ghc-7.8.3.ebuild:
Added amd64 and x86 binaries.
diff --git a/dev-lang/ghc/files/ghc-7.8.3-prim-lm.patch b/dev-lang/ghc/files/ghc-7.8.3-prim-lm.patch
new file mode 100644
index 000000000000..9b321f580498
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-7.8.3-prim-lm.patch
@@ -0,0 +1,15 @@
+Fix underlinking on ghc-prim.
+Fixes ghc-stage2 crahs on hardened toolchain.
+Reported-by: aranea
+diff --git a/libraries/ghc-prim/ghc-prim.cabal b/libraries/ghc-prim/ghc-prim.cabal
+index ffb32af..0431380 100644
+--- a/libraries/ghc-prim/ghc-prim.cabal
++++ b/libraries/ghc-prim/ghc-prim.cabal
+@@ -65,3 +65,7 @@ Library
+ -- We need to set the package name to ghc-prim (without a version number)
+ -- as it's magic.
+ ghc-options: -package-name ghc-prim
++
++ -- ghc 'sin' (and other) primops generate 'libm' calls,
++ -- but ghc itself does not add '-lm'
++ extra-libraries: m
diff --git a/dev-lang/ghc/ghc-7.8.3.ebuild b/dev-lang/ghc/ghc-7.8.3.ebuild
index af254c26ecc3..1b2e55eeb0f3 100644
--- a/dev-lang/ghc/ghc-7.8.3.ebuild
+++ b/dev-lang/ghc/ghc-7.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.3.ebuild,v 1.2 2014/07/12 06:18:49 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.3.ebuild,v 1.3 2014/07/30 11:47:32 slyfox Exp $
EAPI=5
@@ -399,6 +399,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-7.8.2-ia64-no-shared.patch
epatch "${FILESDIR}"/${PN}-7.8.2-cgen-constify.patch
+ epatch "${FILESDIR}"/${PN}-7.8.3-prim-lm.patch
if use prefix; then
# Make configure find docbook-xsl-stylesheets from Prefix