summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2008-10-23 12:09:18 +0000
committerGeorge Shapovalov <george@gentoo.org>2008-10-23 12:09:18 +0000
commit21d8d7ddfa9b6f1dd5165b2336cabc8cab0e5212 (patch)
tree6dbb8417586ad2d2f208d2a46170b732c915d624 /dev-lang/gnat-gcc
parentalpha/ia64/x86 stable wrt #192989 (diff)
downloadgentoo-2-21d8d7ddfa9b6f1dd5165b2336cabc8cab0e5212.tar.gz
gentoo-2-21d8d7ddfa9b6f1dd5165b2336cabc8cab0e5212.tar.bz2
gentoo-2-21d8d7ddfa9b6f1dd5165b2336cabc8cab0e5212.zip
new version, repomed unused autotools from 3.4.6
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'dev-lang/gnat-gcc')
-rw-r--r--dev-lang/gnat-gcc/ChangeLog10
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-3.4.6.ebuild4
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.3.2.ebuild58
3 files changed, 69 insertions, 3 deletions
diff --git a/dev-lang/gnat-gcc/ChangeLog b/dev-lang/gnat-gcc/ChangeLog
index 45d4adf647dd..0076863ae066 100644
--- a/dev-lang/gnat-gcc/ChangeLog
+++ b/dev-lang/gnat-gcc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/gnat-gcc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.26 2008/06/25 14:27:44 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.27 2008/10/23 12:09:18 george Exp $
+
+ 23 Oct 2008; George Shapovalov <george@gentoo.org> gnat-gcc-3.4.6.ebuild:
+ fixed repoman complaint about not using inherited autotools
+
+*gnat-gcc-4.3.2 (23 Oct 2008)
+
+ 23 Oct 2008; George Shapovalov <george@gentoo.org> +gnat-gcc-4.3.2.ebuild:
+ new version
25 Jun 2008; George Shapovalov <george@gentoo.org> gnat-gcc-4.3.0.ebuild,
gnat-gcc-4.3.1.ebuild:
diff --git a/dev-lang/gnat-gcc/gnat-gcc-3.4.6.ebuild b/dev-lang/gnat-gcc/gnat-gcc-3.4.6.ebuild
index a49e1d3df917..8e2c83b1c5cf 100644
--- a/dev-lang/gnat-gcc/gnat-gcc-3.4.6.ebuild
+++ b/dev-lang/gnat-gcc/gnat-gcc-3.4.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-3.4.6.ebuild,v 1.9 2008/03/17 12:37:50 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-3.4.6.ebuild,v 1.10 2008/10/23 12:09:18 george Exp $
WANT_AUTOCONF=2.1
-inherit gnatbuild autotools
+inherit gnatbuild
DESCRIPTION="GNAT Ada Compiler - gcc version"
HOMEPAGE="http://gcc.gnu.org/"
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.3.2.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.3.2.ebuild
new file mode 100644
index 000000000000..83fffc3ae544
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-4.3.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.3.2.ebuild,v 1.1 2008/10/23 12:09:18 george Exp $
+
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+# overriding the BOOT_SLOT, as 4.1 should do fine, no need for bootstrap duplication
+BOOT_SLOT="4.1"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+ ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+ x86? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-i386.tar.bz2 )
+ amd64? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# starting with 4.3.0 gnat needs these libs
+DEPEND=">=dev-libs/mpfr-2.3.1
+ >=dev-libs/gmp-4.2.2"
+
+QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+ ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ #fixup some hardwired flags
+ cd "${S}"/gcc/ada
+
+ # universal gcc -> gnatgcc substitution occasionally produces lines too long
+ # and then build halts on the style check.
+ #
+ # The sed in makegpr.adb is actually not for the line length but rather to
+ # "undo" the fixing, Last3 is matching just that - the last three characters
+ # of the compiler name.
+ sed -i -e 's:(Last3 = "gnatgcc"):(Last3 = "gcc"):' makegpr.adb &&
+ sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+ die "reversing [gnat]gcc substitution in comments failed"
+
+ # Looks like old bootstrap cannot process new C syntax..
+ sed -i -e "/-DREVISION/d" -e "/-DDEVPHASE/d" \
+ -e "s: -DDATESTAMP=\$(DATESTAMP_s)::" "${S}"/gcc/Makefile.in
+ sed -i -e "s: DATESTAMP DEVPHASE REVISION::" \
+ -e "s:PKGVERSION:\"\":" "${S}"/gcc/version.c
+}
+
+src_compile() {
+ # looks like gnatlib_and_tools and gnatlib_shared have become part of
+ # bootstrap
+ gnatbuild_src_compile configure make-tools bootstrap
+}