summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2005-08-02 02:11:01 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2005-08-02 02:11:01 +0000
commite7be2aa77904b5620ae91bc8c6aef724f1e65a68 (patch)
tree2bda7b511d66bf3b32077a30a52e9483b3bc91aa /dev-lang/gwydion-dylan-bin/gwydion-dylan-bin-2.4.0.ebuild
parentFixes bug #98588, thanks to pythonhead (diff)
downloadgentoo-2-e7be2aa77904b5620ae91bc8c6aef724f1e65a68.tar.gz
gentoo-2-e7be2aa77904b5620ae91bc8c6aef724f1e65a68.tar.bz2
gentoo-2-e7be2aa77904b5620ae91bc8c6aef724f1e65a68.zip
Added the Gwydion-Dylan Compiler
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-lang/gwydion-dylan-bin/gwydion-dylan-bin-2.4.0.ebuild')
-rw-r--r--dev-lang/gwydion-dylan-bin/gwydion-dylan-bin-2.4.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lang/gwydion-dylan-bin/gwydion-dylan-bin-2.4.0.ebuild b/dev-lang/gwydion-dylan-bin/gwydion-dylan-bin-2.4.0.ebuild
new file mode 100644
index 000000000000..10087f7b017e
--- /dev/null
+++ b/dev-lang/gwydion-dylan-bin/gwydion-dylan-bin-2.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gwydion-dylan-bin/gwydion-dylan-bin-2.4.0.ebuild,v 1.1 2005/08/02 02:11:01 araujo Exp $
+
+DESCRIPTION="The Dylan Programming Language Compiler"
+HOMEPAGE="http://www.gwydiondylan.org/"
+SRC_URI="x86? ( mirror://gentoo/${P}-x86.tbz2 )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RESTRICT="nostrip"
+LOC="/opt/gwydion-dylan"
+
+DEPEND=""
+RDEPEND=">=dev-libs/boehm-gc-6.4"
+
+S="${WORKDIR}"
+
+src_compile() {
+ mkdir -p ./${LOC}
+ mv usr/* ./${LOC}
+}
+
+src_install() {
+ cp -pr * ${D}
+ insinto /etc/env.d
+ doins ${FILESDIR}/20gwydion-dylan
+}