summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-24 19:43:15 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-24 19:43:15 +0000
commit49595403bbba6ccc67e282724a207e18f6d374f1 (patch)
tree1b059b55fd14bcb0bbfac4f8d4554c7c7c25199b /dev-lang/hugs98/ChangeLog
parentadding par to portage (diff)
downloadgentoo-2-49595403bbba6ccc67e282724a207e18f6d374f1.tar.gz
gentoo-2-49595403bbba6ccc67e282724a207e18f6d374f1.tar.bz2
gentoo-2-49595403bbba6ccc67e282724a207e18f6d374f1.zip
Fixes #1926
Diffstat (limited to 'dev-lang/hugs98/ChangeLog')
-rw-r--r--dev-lang/hugs98/ChangeLog29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lang/hugs98/ChangeLog b/dev-lang/hugs98/ChangeLog
new file mode 100644
index 000000000000..3ff183b7f4ea
--- /dev/null
+++ b/dev-lang/hugs98/ChangeLog
@@ -0,0 +1,29 @@
+# ChangeLog for dev-lang/hugs98
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/ChangeLog,v 1.1 2002/04/24 19:43:15 karltk Exp $
+
+*hugs98-12.2000 (24 Apr 2002)
+
+ 24 Apr 2002; Karl Trygve Kalleberg <karltk@gentoo.org> hugs98-12.2000.ebuild files/digest-hugs98-12.2002 :
+
+ Hugs 98 is a functional programming system based on Haskell 98, the de facto
+ standard for non-strict functional programming languages. Hugs 98 provides
+ an almost complete implementation of Haskell 98, including:
+
+ * Lazy evaluation, higher order functions, and pattern matching.
+ * A wide range of built-in types, from characters to bignums, and lists to
+ functions, with comprehensive facilities for defining new datatypes and
+ type synonyms.
+ * An advanced polymorphic type system with type and constructor class
+ overloading.
+ * All of the features of the Haskell 98 expression and pattern syntax
+ including lambda, case, conditional and let expressions, list
+ comprehensions, do-notation, operator sections, and wildcard,
+ irrefutable and `as' patterns.
+ * An implementation of the main Haskell 98 primitives for monadic I/O,
+ with support for simple interactive programs, access to text files,
+ handle-based I/O, and exception handling.
+ * An almost complete implementation of the Haskell module system. Hugs 98
+ also supports a number of advanced and experimental extensions including
+ multi-parameter classes, extensible records, rank-2 polymorphism,
+ existentials, scoped type variables, and restricted type synonyms.